Bug 2781 - (int-93369) fails to import non-UTF8 QUOTED-PRINTABLE vcard
(int-93369)
: fails to import non-UTF8 QUOTED-PRINTABLE vcard
Status: RESOLVED FIXED
Product: Contacts
General
: 4.1.2 (4.2008.36-5)
: All Maemo
: Low normal (vote)
: 5.0-alpha
Assigned To: rtcomm@maemo.org
: contacts-bugs
: http://bugzilla.gnome.org/show_bug.cg...
: community-diablo, patch, upstream
:
:
  Show dependency tree
 
Reported: 2008-01-15 07:43 UTC by kenneth
Modified: 2010-02-18 14:48 UTC (History)
6 users (show)

See Also:


Attachments
example vcard (157 bytes, text/plain)
2008-10-31 22:35 UTC, kenneth
Details
Evolution screenshot (45.34 KB, image/png)
2008-10-31 23:54 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description kenneth (reporter) 2008-01-15 07:43:49 UTC
STEPS TO REPRODUCE THE PROBLEM:
create a vcard containing something like say æøå (the norwegian letters) and
try to import it into the contacts list.

EXPECTED OUTCOME:
import fine.

ACTUAL OUTCOME:
fails to import the contact. and if its a multicontact file, fails to import
the rest of the file.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2008-10-31 20:35:22 UTC
> create a vcard containing something like say æøå (the norwegian letters) and
> try to import it into the contacts list.

Can you please attach an example vcard (remove any confidential data, please)?
Does the vcard has the charset defined?
With which application has the vcard been created?
I remember several such bug reports for Evolution, e.g.
http://bugzilla.gnome.org/show_bug.cgi?id=243998
Comment 2 kenneth (reporter) 2008-10-31 22:35:00 UTC
Created an attachment (id=1015) [details]
example vcard

this vcard contains the norwegian letters æøå.

if one attempt to import it into the addressbook, one will get a error message.

if a contact with similar letters in it is part of a multicontact card, the
import will fail when reaching it.
Comment 3 Andre Klapper maemo.org 2008-10-31 23:54:04 UTC
Created an attachment (id=1018) [details]
Evolution screenshot

Imported vcard from comment 2 in GNOME Evolution.
Might either be an upstream bug or not a bug at all - how should the
application know how to interpret the byte values when there is no charset
announced?
Comment 4 kenneth (reporter) 2008-11-01 00:09:33 UTC
from what i can tell, this encoder/decoder here does a fine job of decoding the
quoted-printables used in the vcard:
http://www.nowan.hu/quotedprintableencoder.aspx
Comment 5 Andre Klapper maemo.org 2008-11-01 00:17:37 UTC
OK, I'm partially wrong. I should read the specification of QUOTED-PRINTABLE
before adding comments... :-)

Importing a Vcard with the line
 ADR;WORK;POSTAL;ENCODING=QUOTED-PRINTABLE:;;Wilhelmsh=C3=B6her Allee
73;Town;State;70000;Country
works fine in Evolution.
Comment 6 Andre Klapper maemo.org 2008-11-13 20:27:52 UTC
*** Bug 2867 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2008-11-13 21:36:28 UTC
After some testing, this looks like an upstream evolution-data-server bug to
me.
I have filed upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=560681 .
Comment 8 Andre Klapper maemo.org 2008-11-19 16:02:04 UTC
Milan said "It seems EVcard doesn't understand the CHARSET parameter", I guess
that's the basic problem here. See
http://bugzilla.gnome.org/show_bug.cgi?id=560681 .
Any brave C volunteers that want to write a patch? :)
Comment 9 Andre Klapper maemo.org 2008-11-24 12:53:44 UTC
Upstream has a patch for this that has already been committed to svn trunk.
It does not fix the broken vcard attached in comment 2 (that one is just an
invalid card), but it will make it possible to import iso-8859-* charset vcards
if the charset is properly set.
Comment 10 Andre Klapper maemo.org 2008-11-24 12:54:58 UTC
Adding patch keyword (patch attached in upstream bug)
Comment 11 Andre Klapper maemo.org 2009-04-23 17:23:48 UTC
This has been fixed for Fremantle.
Comment 12 Lucas Maneos 2009-10-22 07:57:04 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 13 Mathias Hasselmann maemo.org 2009-10-22 10:40:41 UTC
"Patches" are there:
https://garage.maemo.org/svn/eds/trunk/evolution-data-server/.

But you might want to wait a bit before preparing Diablo 4 patches, as I am
working on a related issue right now.
Comment 14 Murray Cumming 2010-02-18 13:33:57 UTC
I'm gathering some vcard example data. What device/program produced the
attached vcard?
Comment 15 kenneth (reporter) 2010-02-18 14:48:18 UTC
the vcard was from a sonyericsson Z710.