Bug 2750 - Support clock synchronization by GPS
: Support clock synchronization by GPS
Status: RESOLVED FIXED
Product: Utilities
Clock
: 4.0
: All Linux
: Low enhancement with 4 votes (vote)
: Harmattan
Assigned To: unassigned
: clock-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-11 00:03 UTC by David Hagood
Modified: 2010-05-13 10:14 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description David Hagood (reporter) 2008-01-11 00:03:20 UTC
Use case: the user wants the device to have the correct time.

It would be nice if, when a GPS connection is active, the device would check
it's clock against the GPS reported time and set the device clock as needed.

This needn't be a full implementation of NTPD, for example (although that would
be nice) - just a simple cross-check when the fix is aquired.

It would also be nice if, when a network connection is established, the device
could do a check against a network NTP server and set the clock. Again, this
needn't bee a full NTPD implementation, but rather just a quick ntpdate.

Ideally, the device would, upon getting a network connection:
1) IF a NTP server were given via DHCP (option 42, per     RFC 1533, RFC 2132),
use that.
2) Failing that, use mDNS/DNS-SD (Zeroconf) and look for a NTP server.
3) Failing that, see if the default gateway is running an NTP server.
4) Failing that, try pool.ntp.org.
Comment 1 Per Wille 2008-01-21 12:08:29 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 ag2 2008-02-08 01:06:54 UTC
A third-party solution is available until Nokia addresses this:

http://maemostuff.com
Comment 3 Karsten Br├Ąckelmann 2008-05-23 15:02:41 UTC
Re-setting the assignee, since Carlos moved on to other tasks.

Please note that this does not affect the legitimacy of the bug in any way.
It's a purely administrative operation. Sorry for the noise.
Comment 4 Andre Klapper maemo.org 2008-10-27 15:46:16 UTC
As written in comment 2, gps-clockd is available at http://nitapps.com/
Comment 5 Andre Klapper maemo.org 2008-10-28 15:28:14 UTC
Setting the clock from NTP is bug 472, hence changing the summary to only
include GPS.
Comment 6 Andre Klapper maemo.org 2008-11-03 16:58:47 UTC
moving this to clock because this is the place where i'd look first.
Comment 7 Quim Gil nokia 2008-11-17 12:24:27 UTC
This feature is planned to be officially supported in Harmattan.
Comment 8 Quim Gil nokia 2008-11-26 13:34:17 UTC
Roadmapped for Harmattan. Resolving as fixed since we have agreed that no
actual code is needed to resolve feature requests. Trust the Maemo SW product
managers.  ;)
Comment 9 Lucas Maneos 2010-05-13 10:14:58 UTC
*** Bug 10163 has been marked as a duplicate of this bug. ***