Bug 2727 - Modest crashes after upgrade to 1.0-2008.02-2
: Modest crashes after upgrade to 1.0-2008.02-2
Status: RESOLVED FIXED
Product: Email
General
: 4.0
: ARM Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-07 22:35 UTC by Steve Yelvington
Modified: 2008-12-06 15:23 UTC (History)
2 users (show)

See Also:


Attachments
two 'modest showui' sessions ending in segfault while composing email (8.47 KB, text/plain)
2008-01-11 04:54 UTC, hvilches
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Steve Yelvington (reporter) 2008-01-07 22:35:13 UTC
STEPS TO REPRODUCE THE PROBLEM: Startup modest. 

EXPECTED OUTCOME: Get my mail.

ACTUAL OUTCOME: Crash. There is no trace of modest still running in the system
table.

REPRODUCIBILITY: Always.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Running "modest showui" from the command line generates an error: 
  Inconsistency detected by ld.so: dl-open.c:603 _dl_open: Assertion
'_dl_debug_initialize(0, args.nsid)->r_state == RT_CONSISTENT' failed!

Modest is configured to fetch mail from my imap server, but it crashes before
opening a connection.

Removing/reinstalling did not fix.
Deleting the .modest/ directory did not fix. The directory and all its children
are, however, re-created in the split-second before the app crashes.
Comment 1 Dirk-Jan C. Binnema nokia 2008-01-08 23:12:40 UTC
*ouch*

haven't been able to reproduce that. you can kill your settings (accounts)
with:
$ gconftool-2 --recursive-unset /apps/modest

but, it seems to be something specific with your imap server. which one are you
using?
Comment 2 hvilches 2008-01-10 23:12:15 UTC
I experienced what appear to be random crashes as soon as I upgraded.
I un-installed, but can't reinstall, as the repository is down. But, when it
was installed, I would go in and it would not show my INBOX until I selected
it. Then while composing a message, it would often crash and close every modest
window.

I am using IMAP and the server requires my username to have '@'.

I am willing to help any way I can to hash out the IMAP issues.
Comment 3 hvilches 2008-01-11 04:23:25 UTC
I reinstalled, rebooted, opened modest, it got new mail, i opened one, i
clicked reply, i highlighted a word and copied it to the clipboard, i switched
to PasswordSafe, i switched back to modest, crash. All windows closed.

I restarted modest, opened another email, went to another app, and in the
background, modest crashed. This one makes me think is happening when it
rechecks email.

I am using imap with ssl.

Please let me help fix this, or is there a way to downgrade? I will provide any
info/accounts you may need. The app is awesome, and has worked great until now.
Pretty please, I do not want to use Claws!!!!

Thanks!
Comment 4 hvilches 2008-01-11 04:54:49 UTC
Created an attachment (id=694) [details]
two 'modest showui' sessions ending in segfault while composing email
Comment 5 Bruce Cowan 2008-01-12 05:23:46 UTC
I also see this bug.

I manually removed both ~/.modest and unset the gconf keys. I then added
details of my old account, which has a '%' in the username. After pressing
"Finish", modest crashed.

An account with a '@' in the username is fine.

This is with 2008.03-1
Comment 6 Dirk-Jan C. Binnema nokia 2008-01-26 20:46:52 UTC
does this still happen with the latest update?
Comment 7 hvilches 2008-01-28 01:20:59 UTC
After the update, modest has been very stable.
Comment 8 Dirk-Jan C. Binnema nokia 2008-01-30 15:22:18 UTC
excellent, thanks.

closing this bug.