Bug 2723 - Pushing key once causes multiple repeats
: Pushing key once causes multiple repeats
Status: RESOLVED WORKSFORME
Product: Desktop platform
general
: 4.0
: N800 Linux
: Medium major with 34 votes (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-01-07 00:08 UTC by Denis Zalewsky
Modified: 2010-02-04 10:02 UTC (History)
21 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Denis Zalewsky (reporter) 2008-01-07 00:08:46 UTC
STEPS TO REPRODUCE THE PROBLEM:

E.g. install FBReader, load any book and push joystick 'down' button until get
multiply key repeating. Also there was similar button push repeating problems
with external HW keyboard (e.g. Apple wireless kbd).

EXPECTED OUTCOME:

Pushing button once should raise single key press event

ACTUAL OUTCOME:

Pushing button once sometimes raises multiply (2-10?) key press events

REPRODUCIBILITY:

sometimes (frequently)

EXTRA SOFTWARE INSTALLED:

FBReader

OTHER COMMENTS:
Comment 1 Matt Emson 2008-01-07 02:07:40 UTC
Running OS2008 on an N800, I have experienced the same issues via the onscreen
keyboards. The stylus sized keyboard will often double a letter, especially
when typing quickly. The frequency is fairly random, though certain websites
and apps seem to cause the issue more frequently. Facebook is one website that
springs to mind, and Modest and maemo wordpy are apps.

The onscreen thumboard has similar issues, except they seem to manifest more
frequently. I find that the overall accuracy of the thumbboard is greatly
reduced over the accuracy of OS2007. The thumb board seems to have additional
issues with detecting key presses accurately. I've seen it select an adjaccent
key frequently, even with taps dead centre to the desired key. These phantom
presses often don't actually register a physical output. I have also witnessed
keys being refistered 5 or 6 keys away (e.g. press 'k' and 't' is hilighted.)
Comment 2 denise118 2008-01-10 03:48:06 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Noah Mittman 2008-01-15 15:25:19 UTC
Yep. Having this in OS2008 on N800.

MicroB suffers from this constantly, where holding down on the d-pad to scroll
registers a longer scroll than is being requested; Sometimes, MicroB will not
stop scrolling, as it gets "stuck".

@Matt, I get major virtual kbd inaccuracy too, but I don't know if the bugs are
connnected. We should start a separate bug for that, I think
Comment 4 Noah Mittman 2008-01-15 15:42:46 UTC
@Matt, I just opened #2784 for the digitizer problem.
Comment 5 candreas 2008-01-15 19:40:02 UTC
Occurs extremely often with down D-Pad function in FBReader and MicroB where
single press results in continuous down scrolling.
Comment 6 Aaron 2008-01-23 05:43:00 UTC
This may or may not be the same bug: when using my bluetooth iGo Stowaway
keyboard, I not only get multiple bounces, there are times when some keys will
flip to auto-repeat, and the only way to get them to stop is to exit the app. 
I've even had the keypresses continue AFTER exiting the app, and that can
totally mess up my panels.

I can repeatably get this behavior within Maemopad+ on OS2008, usually within
just a few lines of text.
Comment 7 Ryan Abel maemo.org 2008-06-05 07:31:10 UTC
Corrected summary.
Comment 8 Tony Green 2008-06-22 17:31:26 UTC
This is an especially problematic bug when trying to fill in password fields,
because you don't see the characters typed so can't see when more than one has
been registered.

For someone like me who keeps important information encrypted in the password
safe application, this can be a serious problem.
Comment 9 Chris H 2008-07-21 19:30:57 UTC
This has become worse for me in Diablo, under load. e.g. while loading a large
web page, the fullscreen button toggles fullscreen on then off.  

Also, tapping the home key sometimes minimises everything, or tapping the back
button closes the active window (very annoying when browsing and trying to go
back)
Comment 10 Ryan Abel maemo.org 2008-07-21 22:42:34 UTC
(In reply to comment #9)
> This has become worse for me in Diablo, under load. e.g. while loading a large
> web page, the fullscreen button toggles fullscreen on then off.  
> 

This isn't a key-repeat issue.
Comment 11 Jamie Bennett 2008-08-04 23:25:53 UTC
This has been around for quite some time and lots of users have reported this
in one form or another. This is related to the scrollbar issue too if I'm not
mistaken, i.e. tap and hold the scroll bar down/up arrow in microb and it
scrolls for ever sometimes.
Comment 12 Mark Ryan 2008-08-26 01:26:50 UTC
I noticed this problem immediately after upgrading my N800 from OS2007 to
diablo. I'm adding my observations below, in the hope that they might help get
a speedy resolution to this bug.

I have a application which displays some data in a gtktreeview.  Typically, I
navigate the tree view pressing the down key.  Sometimes when I do this,
multiple key presses seem to be triggered and I get taken to the bottom of the
treeview.  The only way I can stop this happening is to quickly press the up
button.  Note that this problem is not restricted to the down button or my
application.  I can reproduce the same problem with the up button and I have
also noticed that if I switch applications, e.g., to FBReader, while the key
repeat problem is occurring, the problem persists in the new application.

This problem did not occur on OS2007.  Any idea when it might be fixed?
Comment 13 Ryan Abel maemo.org 2008-09-15 23:54:31 UTC
*** Bug 3714 has been marked as a duplicate of this bug. ***
Comment 14 icebox 2008-10-06 14:58:03 UTC
I experience the same problems under the latest version of Diable. Fresh
install, then update to last SSU. The key repeat issue also manifests its self
under mplayer for me - i.e. one click for a short fast forward keeps forwarding
untill the end of the file. Sometimes pressing the key again and/or the oposite
key makes it stop.
Comment 15 Andre Klapper maemo.org 2008-10-08 14:51:20 UTC
(Removing deprecated "Future" Target Milestone.)
Comment 16 Andre Klapper maemo.org 2008-10-08 16:32:33 UTC
Do all the reporters here use an N800 or is this also an issue for the N810?
Comment 17 urb 2008-10-09 00:19:54 UTC
Same issue here, with PDF reader launched on a N800. Quite uncomfortable as it
sometimes flips a number of pages forward on a single "down" keypress.
Comment 18 Samppa Kytömäki 2008-10-10 10:34:06 UTC
(In reply to comment #16)
> Do all the reporters here use an N800 or is this also an issue for the N810?
> 

N800 here.
Comment 19 Jarmo Lahtiranta 2008-10-10 11:34:27 UTC
N800 here also. The bug is definitely still alive and kicking.
Comment 20 Tony Green 2008-10-10 12:44:46 UTC
(In reply to comment #16)
> Do all the reporters here use an N800 or is this also an issue for the N810?
> 

N800 for me. Still happening, but it doesn't seem quite as frequent as it used
to be. I'm not sure if this is because one of the upgrades pushed out since
reporting this has made it a bit less sensitive or because I'm getting better
at working it.
Comment 21 Eugene 2008-10-10 14:22:13 UTC
(In reply to comment #20)
> N800 for me. Still happening, but it doesn't seem quite as frequent as it used
> to be. I'm not sure if this is because one of the upgrades pushed out since
> reporting this has made it a bit less sensitive or because I'm getting better
> at working it.
I have N800. Just to confirm the same behavior. Yesterday flashed to Diablo and
the issue seems to disappear. I've spent 5 minutes typing for testing - occurs
only from time to time, 1-2 per 100 symbols. It's likely to be be my hand's
trembling causes.
Comment 22 maemo 2008-10-10 23:28:32 UTC
N800: touch screen problem appears most frequently when using Microb scroll
bar.  If I push the touch screen scroll bar once to page down, I get multiple
page downs.
Comment 23 Andre Klapper maemo.org 2008-10-13 14:58:01 UTC
(In reply to comment #21)
> I have N800. Just to confirm the same behavior. Yesterday flashed to Diablo and
> the issue seems to disappear. I've spent 5 minutes typing for testing - occurs
> only from time to time, 1-2 per 100 symbols.

(In reply to comment #19)
> N800 here also. The bug is definitely still alive and kicking.

So this still happens but Diablo has improved this?
Others who can confirm this?

No N810 reports here it seems.
Comment 24 icebox 2008-10-13 15:07:15 UTC
Can't really see an improvement. For me (but that might be that I started using
the tablet more recently) since the last 2 ssu updates it seems to have gotten
worse.
Comment 25 Martin Thierer 2008-10-13 17:26:02 UTC
Same here: N800, but I can't tell there's any improvement.
Comment 26 Joshua Layne 2008-10-13 17:38:01 UTC
I am an N810 owner and for me, it is happening less with diablo than it did
with chinook.  Unfortunately, this has also equated to an overall lack of
responsiveness (sometimes keypresses are not registered now or they have to be
held for a long time to register) - it is almost as if the frequency of
sampling has been slowed and so we are no longer seeing the 'bounce' issue of
multiple presses (single press detected multiple times), but if that's what it
is, the problem was solved the wrong way.

So, for me - double clicks are no longer an issue, but overall screen
responsiveness is.  Not really sure how this can be quantitatively measured -
qualitative bugs are hard to fix.
Comment 27 Timothy 2008-10-13 18:10:19 UTC
I still get this on a N800. There is a possibility the frequency decreased when
I installed Diablo, but certainly not significantly.

I get this occurring not only when I tap the screen, but also when I use the
physical buttons. E.g. when I'm using the D pad to scroll down in the web
browser, it'll sometimes 'catch', and keep scrolling down until I press a key.
Comment 28 Martin Thierer 2008-10-13 19:12:34 UTC
> I get this occurring not only when I tap the screen, but also when I use the
> physical buttons. E.g. when I'm using the D pad to scroll down in the web
> browser, it'll sometimes 'catch', and keep scrolling down until I press a key.

I thought we were only talking about physical keys here? I can confirm that
tapping on the screen sometimes shows the same behaviour, but that might well
be a different issue.
Comment 29 icebox 2008-10-13 19:53:06 UTC
definitively physical keys - at least for me, never had this problem with
software taps...
Comment 30 John Parejko 2008-10-19 22:29:26 UTC
Some more details on this from my N800:

When scrolling down via the d-pad in FBReader, I can always tell when it is
about to start "scrolling madly" (thinking the key is being held down) because
the "click" sound that it normally produces when you press down is either
clipped, or missing.  I.e., 

Standard behavior: Press down button, hear click, page scrolls.

Bug behavior: Press down button, no click (or incomplete click sound), page
begins scrolling multiple times after a short pause.

I filed bug 3714, which was marked as a duplicate.  The behavior there is
similar, in that there is a noticeable pause between the button press and when
it drops to the home page.  This may be because of the way the system is
responding to the multiple inputs that are being sent.

I also have problems with multiple screen presses being sent when tapping
scroll bars.  No noticeable change in behavior since 4.1.1 was released, but
OS2007 did not appear to have this bug.
Comment 31 Mohammad Anwari maemo.org 2008-10-27 11:38:50 UTC
I'm moving this to General as it seems that this is beyond input method
framework.
Comment 32 Neil MacLeod maemo.org 2008-11-10 21:22:57 UTC
(In reply to comment #11)
> This has been around for quite some time and lots of users have reported this
> in one form or another. This is related to the scrollbar issue too if I'm not
> mistaken, i.e. tap and hold the scroll bar down/up arrow in microb and it
> scrolls for ever sometimes.

I wonder if this bug is also at the root of the text-selection bug in MicroB,
where you go to pan the page and instead of the page scrolling as you drag you
end up selecting masses of text. I find it almost impossible sometimes to drag
the page in MicroB, my only partial solution is to click outside of the MicroB
application and then sometimes I am able to drag scroll. It's as if MicroB does
not see the "mouse up" event when I start to drag the page, which might also
explain why the scrollbar scrolls forever.
Comment 33 George Fragos 2008-12-10 22:53:19 UTC
This repeat problem is very bad with the SU-8W bluetooth keyboard. Setting
large values ffor repeat delaat using the configuration editor has no impact. A
similaar problem has poped up on Ubuntu 8.10. The work around there has been
adding a keyboard rate line to rc.local. I'm trying "kbdrate -r 15 -d 1200"
with Ubuntu. N810 doesn't have this file sso I'm not sure how to try this work
around.
Comment 34 N Bloch 2008-12-14 23:56:31 UTC
This problem occurs very frequently on my N800/Diablo. I haven't seen any
change for the better or worse between maemo updates.

The situations in which I currently see it occur are:

Navigating between photos in Mirage (D-Pad - very frequent)
Seeking in Mplayer (D-Pad - frequent)
Scrolling in PDF Reader (D-Pad - occasional)

It used to affect FBReader until the "action on key release" feature was
introduced. In that case it affected page changes whether using D-Pad or the
+/- keys.

Until recently it frequently occurred when zooming (+/- keys) in Maemo Mapper.
It seems to have gone away since the latest MM update.

I don't mean to sound ungrateful for the work that goes on here, but I'm amazed
that this hasn't been fixed earlier. This bug has a huge negative impact on my
maemo experience. I run into it multiple times every day.
Comment 35 urb 2008-12-21 23:52:48 UTC
Confirmed here under 5.2008.43.7 with links2.
Comment 36 Quim Gil nokia 2009-01-25 15:29:41 UTC
Going through the comments it looks like different people is talking about
different issues.

The original report talks about unefficient scrolling due to the fact that
keeping the up/down keys pressed, the scrolling doesn't stop automatically when
the key is released. fwiw I have tried this with Fremantle with browser and PDF
reader and the behavior is correct: scrolling while pressing key and stop when
key is released. For obvious reasons I can't test with FBreader while there is
not a Fremantle version...  :)

Some comments are about getting double characters printed with a single tap.
This looks to me a different problem than the above, that is about keeping a
key pressed. Is it there any bug already open and concentrating on this issue?

And someone mentioned a problem with a bluetooth keyboard, but this looks like
belonging to Bug 2670 (bluetooth keyboard repeat rate control needed).
Comment 37 Neil MacLeod maemo.org 2009-01-25 16:13:11 UTC
Comment 32 relates to bug 3996 which is a very common problem in my experience.
Comment 11 doesn't appear to have a bug, but probably should do as it is also
fairly easy to reproduce.

All these bugs/issues mentiond in this bug seem to be related to roughly the
same thing, "lost" keyboard/touchscreen events.
Comment 38 Quim Gil nokia 2009-02-02 22:51:39 UTC
*** Bug 1680 has been marked as a duplicate of this bug. ***
Comment 39 Andre Klapper maemo.org 2009-09-25 14:54:38 UTC
So if I get this correctly this happens both with the halfsize and fullsize
onscreen keyboards.

So far I haven't seen this with the fullsize onscreen keyboard in Fremantle.

Unfortunately this is a WONTFIX for Maemo4/Diablo as Maemo4/Diablo is in
maintenance mode and Nokia will only provide bugfixes for critical issues if at
all. The Mer project aims to provide a community backport of Maemo5/Fremantle
for N8x0 devices. See http://wiki.maemo.org/Mer for more information.

I'm *very* interested in feedback after the N900 launch and whether someone can
still reproduce this. "moreinfo" state until then.
Comment 40 Scott Allen 2009-09-26 14:00:59 UTC
I have a N800 and had most of the problems being reported, with the d-pad,
on-screen keyboard and bluetooth keyboard. They occurred with FBReader, Microb
and other apps.

I can't recall experiencing any problems after upgrading from Chinook to Diablo
a few months ago.
Comment 41 Quim Gil nokia 2009-10-14 08:19:52 UTC
(In reply to comment #39)
> I'm *very* interested in feedback after the N900 launch and whether someone can
> still reproduce this.

Me too. We left 300 N900s in the wild last weekend. If you got one could you
try to reproduce this? It's the most voted Diablo platform bug. From my own
experience it looks like Fixed in Fremantle.
Comment 42 Eugene 2009-10-14 11:30:08 UTC
(In reply to comment #41)
> Me too. We left 300 N900s in the wild last weekend. If you got one could you
> try to reproduce this? It's the most voted Diablo platform bug. From my own
> experience it looks like Fixed in Fremantle.

Since Friday I've never got the problem I experienced in Chinook/Diablo. Nice
work!
Comment 43 Bjoern Olausson 2009-12-14 02:20:08 UTC
Okay, I just ran into something similar using the xterm on N900.

After pushing the blue "Function" button twice then once and again twice (or
something similar) my keyboard went bonkers.

Pushing a key once resulted in a lower case and upper case char like aA bB.

Playing around with the keyboard did not help restarting the xterm did not
help.
Had to restart the N900


Cheers
Bjoern
Comment 44 Andre Klapper maemo.org 2009-12-30 15:48:11 UTC
So we have one report about the N900 that confirms this, and one report that
says "Not happening".
I'd love to see more feedback here about the N900.
Comment 45 Ralph Angenendt 2009-12-30 17:01:18 UTC
(In reply to comment #44)
> So we have one report about the N900 that confirms this, and one report that
> says "Not happening".
> I'd love to see more feedback here about the N900.

Regarding comment #43 - I've tried (with function key, strg/sym and shift) and
cannot reproduce that at all.
Comment 46 phi 2009-12-30 23:39:22 UTC
I've had it happen on the N900. its not as bad but ever so often, clicking on
the screen will make the click sound fire repeatedly so it sounds like its
stuttering.
Comment 47 Andre Klapper maemo.org 2010-02-04 10:02:13 UTC
Not much feedback, hence I am going to close this report as WORKSFORME for
Maemo5 (and WONTFIX for Maemo4).