Bug 2720 - Modest chooses wrong part as body when message has 2 text/plain parts
: Modest chooses wrong part as body when message has 2 text/plain parts
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: unspecified
: N800 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-06 20:18 UTC by Markus Linnala
Modified: 2009-03-07 10:49 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Markus Linnala (reporter) 2008-01-06 20:18:58 UTC
Mail with 2 text/plain parts, first should be body, not the last one.

STEPS TO REPRODUCE THE PROBLEM:

Try with this test message:
<msg>
From - Sun Jan 06 12:00:00 2008
Return-Path: <from@example.com>
Content-Type: multipart/mixed; boundary="----------=_1199639888-11039-0"
MIME-Version: 1.0
From: from@example.com
To: to@example.com
Subject: Hello
Date: Sun, 06 Jan 2008 12:00:00 +0000

This is a multi-part message in MIME format...

------------=_1199639888-11039-0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit


This is body

------------=_1199639888-11039-0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


-- 
Signature

------------=_1199639888-11039-0--

</msg>


EXPECTED OUTCOME:

Should see as body:

This is body

And maybe:

--
Signature

too.

Thunderbird shows both.

I can't seem to find RFC which says what to do.

RFC 7.2.2 says
...
The primary subtype for multipart, "mixed", is intended  for
use  when  the body parts are independent and intended to be
displayed  serially.
...

http://nwww.faqs.org/rfcs/rfc1341.html

But that is obsolete.

ACTUAL OUTCOME:

-- 
Signature

REPRODUCIBILITY:
(always/sometimes/once)

always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Environment:
OS2008/2.2007.50-2
modest 1.0-2008.02-2

Content-Disposition -header does not seem to have any effect.
Comment 1 Dirk-Jan C. Binnema nokia 2008-01-07 15:04:59 UTC
there was a bug for this, but it has been fixed.
check svn or wait for the next binary update.
Comment 2 Lucas Maneos 2009-03-07 10:18:46 UTC
Doesn't seem to work on 1.0-2008.43-1 (5.2008.43-7).  With the following
message:

--------------------------------------->8------------------
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="LQksG6bCIzRHxTLp"
Content-Disposition: inline


--LQksG6bCIzRHxTLp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

test

--LQksG6bCIzRHxTLp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

foo

--LQksG6bCIzRHxTLp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

bar

--LQksG6bCIzRHxTLp--
--------------------------------------->8------------------

modest only renders the last MIME part ("bar").
Comment 3 Lucas Maneos 2009-03-07 10:49:37 UTC
Although this came first, it looks like the same issue as bug 3607, which is
marked as a dup of bug 3369.

*** This bug has been marked as a duplicate of bug 3369 ***