Bug 2717 - Big oops: N810 french keyboard does not have ampersand
: Big oops: N810 french keyboard does not have ampersand
Status: RESOLVED FIXED
Product: Desktop platform
Input method framework
: 4.0
: All Linux
: High major (vote)
: 4.1
Assigned To: Mohammad Anwari
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-06 03:35 UTC by Laurent GUERBY
Modified: 2008-06-16 11:11 UTC (History)
3 users (show)

See Also:


Attachments
Fixed French special character view layout (324 bytes, application/octet-stream)
2008-01-17 13:20 UTC, Tomas Junnonen
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Laurent GUERBY (reporter) 2008-01-06 03:35:51 UTC
STEPS TO REPRODUCE THE PROBLEM:
On a french keyboard  N810 try entering an URL with the '&' character (quite a
common character in URLs :)

EXPECTED OUTCOME:
Finding a hardware or software (Chr) key for '&'.

ACTUAL OUTCOME:
Found none, had to switch the keyboard to english and type random Fn+key until
I found it then switched back keyboard to french.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Fn+shift+1 for & (like on a real keyboard)
(actually taking all Fn+shift+digit from std french digit layout would be a
good idea)
Comment 1 Jussi Kukkonen 2008-01-06 17:49:57 UTC
severity critical is for crash, data-loss or memory leak bugs.
Comment 2 Roope Rainisto nokia 2008-01-17 12:55:58 UTC
Hmm, you're right about this issue. Let's see if we can put it to the on-screen
characters, I wouldn't go changing the HW side keys, since then the printed
keymat would no longer correspond to the real characters.
Comment 3 Tomas Junnonen nokia 2008-01-17 13:20:37 UTC
Created an attachment (id=701) [details]
Fixed French special character view layout

As a quick fix until the next official software release, I'm attaching here a
revised French special character layout (what you see when you press Chr). It
replaces the # character with &, as # is already available as a physical key on
the French keyboard.

To use, copy the file to the /usr/share/scv_layouts directory.
Comment 4 Laurent GUERBY (reporter) 2008-02-04 22:08:10 UTC
(sorry for the delay I missed the email notification).

I confirm the fr.vkb file solves the issue, thanks!

The shift+space trick to invoke the virtual keyboard kind of work too.
Comment 5 Andre Klapper maemo.org 2008-05-05 16:17:31 UTC
Tomas: when is "the next official software release"? will this be fixed in 4.1?
Comment 6 Andre Klapper maemo.org 2008-06-13 17:54:52 UTC
Tomas: *ping*
Comment 7 Tomas Junnonen nokia 2008-06-16 09:52:40 UTC
Yes, this is fixed in Diablo.
Comment 8 Andre Klapper maemo.org 2008-06-16 11:11:06 UTC
Thanks for updating this ticket.