Bug 2707 - n810 won't power up without the charger being connected
: n810 won't power up without the charger being connected
Status: RESOLVED FIXED
Product: Core
Kernel
: 4.0
: N810 Linux
: High critical with 1 vote (vote)
: ---
Assigned To: unassigned
: linux-kernel-bugs
:
:
: int-79152
:
  Show dependency tree
 
Reported: 2008-01-04 15:10 UTC by Laszlo Marai
Modified: 2008-12-06 16:09 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Laszlo Marai (reporter) 2008-01-04 15:10:07 UTC
STEPS TO REPRODUCE THE PROBLEM:

Switch off the device and then try to switch it back on.

EXPECTED OUTCOME:

The blue led should light up and the 'Nokia' splash screen should appear.

ACTUAL OUTCOME:

Nothing happends, the screen stays black.

REPRODUCIBILITY:

always - on some devices.

OTHER COMMENTS:

The device can eventually be turned on by connecting to the charger and waiting
for several minutes (sometimes half an hour). First it won't even charge then
then it will start charging and then it can be turned on the normal way.
Several people have this problem, a few reports can be found here:
http://www.internettablettalk.com/forums/showthread.php?t=12863 . I contacted
Nokia and they claimed that they were not aware of the problem despite the fact
that it has been already reported by other users. I suspect that this is either
a software bug or something that can be corrected with software becase there is
a way to make the device boot the normal way without using the charger. You
have to remove the main battery for hours, I tried it removing for six hours.
Then you put the battery back and push the power button and it will boot. After
booting the clock will show that it had stopped about 1.5 hours (90 minutes)
after removing the battery. I did this experiment twice. Once I was able to
switch off and on the device once more (normally) for the second time it
wouldn't boot up after the first switch off.

Based on all these it seems to me that after shutting it down (turning it off)
it gets to a bogus state where it can't get out of but by removing the main
battery and letting the internal backup battery run dry it will loose that
state and boot up normally.

We would need someone who knows the hardware internals and how exactly the boot
procedure works to evaluate this problem.
Comment 1 Richard Booth 2008-01-04 15:42:06 UTC
Isn't this a duplicate of bug 2673, 

https://bugs.maemo.org/show_bug.cgi?id=2673
Comment 2 Laszlo Marai (reporter) 2008-01-04 15:52:04 UTC
(In reply to comment #1)
> Isn't this a duplicate of bug 2673, 
> 
> https://bugs.maemo.org/show_bug.cgi?id=2673
> 

I don't know. That is about the n800 this is for the n810. That one has an
unfortunate wording and I think it's not assigned to the right component. That
one seems to have been dismissed as a hardware bug.
Comment 3 Philippe De Swert nokia 2008-02-04 16:35:39 UTC
I saw the same behaviour. However removing the battery for a minute or so and
then trying again works for me. (It is faster than waiting half an hour on
charger at least)
Comment 4 Philippe De Swert nokia 2008-02-05 16:53:17 UTC
Nokia is aware of the problem, and a possible fix is being tested. This problem
is  mostly likely the same as in bug #2673. Stay tuned for more news.
Comment 5 Philippe De Swert nokia 2008-02-21 13:18:16 UTC
There is a new firmware release that fixes the power-up problem and as such
probably your problem. Please check if this works for you. (Also see bug #2673)