Bug 2704 - PDF Reader needs more zoom levels between 50% and 150%
: PDF Reader needs more zoom levels between 50% and 150%
Status: RESOLVED WONTFIX
Product: Utilities
PDF reader
: 5.0-beta
: All All
: Low enhancement with 9 votes (vote)
: ---
Assigned To: unassigned
: pdf-reader-bugs
:
: community-diablo, patch
:
:
  Show dependency tree
 
Reported: 2008-01-04 04:29 UTC by Walt Bilofsky
Modified: 2010-11-29 15:51 UTC (History)
7 users (show)

See Also:


Attachments
diff result for pdfviewer.cc (2.18 KB, patch)
2008-11-24 22:23 UTC, Sandu Gherbe
Details
diff result for pdfviewer.h (503 bytes, patch)
2008-11-24 22:24 UTC, Sandu Gherbe
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Walt Bilofsky (reporter) 2008-01-04 04:29:57 UTC
The user needs to be able adjust the zoom level in PDF reader to make best use
of the limited screen size.

In addition to fit to width and fit to page, Adobe Acrobat on the PC provides
zooms of ... 50%, 66.6%, 75%, 100%, 125%, 150%, 200%, 300%, 400%, ...

The Nokia reader provides only 50%, 100%, 150%, 200%, 250%, 300%, and 400%.

More granularity is needed between 50% and 150%.  At least the zoom levels
afforded on the PC should be provided, and preferably more choices, since
getting the text as large as possible is so important.

I suggest 50%, 66%, 75%, 90%, 100%, 110%, 120%, 130%, 150%, 200%, 300%, 400%

(Ideally the user should be able to enter the zoom level numerically, but to
keep the UI simple I don't propose this.)

Fit to width does not reduce the need for this change; see Bug 761.

See also Bug 2703.
Comment 1 Ustun Ozgur 2008-10-11 19:41:21 UTC
I agree. Maybe the step size might be configurable in the options; %25 step
size is better I suppose.
Comment 2 Andre Klapper maemo.org 2008-10-14 14:42:05 UTC
Advantage: Fits better.
Disadvantage: I'm clicking like mad on the hardware zoom buttons.

I prefer to close this as WONTFIX and fix bug 761 instead.
Comment 3 Sandu Gherbe 2008-10-14 15:26:19 UTC
(In reply to comment #2)
> Advantage: Fits better.
> Disadvantage: I'm clicking like mad on the hardware zoom buttons.
> 
> I prefer to close this as WONTFIX and fix bug 761 instead.
> 

I have added some extra zoom levels like 75%, 125%, 175%, 225%, 275%, 325%,
350% and 375%. So I have the deb file which contains the added code. What
should I do next in order to have fix confirmed?
Comment 4 Andre Klapper maemo.org 2008-10-14 15:32:30 UTC
(In reply to comment #3)
> I have added some extra zoom levels like 75%, 125%, 175%, 225%, 275%, 325%,
> 350% and 375%. So I have the deb file which contains the added code. What
> should I do next in order to have fix confirmed?

Well, bugs are closed as FIXED when the patch has been submitted and included
*upstream*. :)

Can you please provide a clean patch here (see the "diff" command) against the
latest publically available package?
Comment 5 Andre Klapper maemo.org 2008-11-17 00:51:34 UTC
Sandu: Can you please provide the patch here?
Comment 6 Andre Klapper maemo.org 2008-11-17 00:54:02 UTC
Note to myself:
Unfortunately still valid in section 4.5 Document zooming for Fremantle.
Comment 7 Andre Klapper maemo.org 2008-11-17 01:19:19 UTC
Also note that the 3rd party port of Evince provides this functionality:
http://maemo.org/downloads/product/OS2008/evince/
Comment 8 Eero Tamminen nokia 2008-11-24 16:44:49 UTC
(In reply to comment #2)
> Advantage: Fits better.
> Disadvantage: I'm clicking like mad on the hardware zoom buttons.

I'd rather have the steps in a popup/submenu so that I can select suitable zoom
level directly (zooming through steps is tedious/slow).  What Nokia currently
provides is a list that would fit into a one, with the set of levels proposed
set of levels, the selection popup would need to scroll.
Comment 9 Sandu Gherbe 2008-11-24 22:23:31 UTC
Created an attachment (id=1048) [details]
diff result for pdfviewer.cc
Comment 10 Sandu Gherbe 2008-11-24 22:24:24 UTC
Created an attachment (id=1049) [details]
diff result for pdfviewer.h
Comment 11 Sandu Gherbe 2008-11-24 22:26:02 UTC
(In reply to comment #5)
> Sandu: Can you please provide the patch here?
> 

Sorry for the late reply but I've just attached the diff files.
Comment 12 Sandu Gherbe 2008-11-24 22:31:11 UTC
(In reply to comment #5)
> Sandu: Can you please provide the patch here?
> 

 More zoom levels can be added very easily, just modifying a little the code.
Comment 13 Lucas Maneos 2009-10-22 07:56:57 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 14 Jay Gates 2009-12-14 04:22:50 UTC
Is there any reason the zoom level has to max out at 400%?  I have a New York
City subway map saved on my phone, and I would really like to have about 500%
zoom.  See here: http://mta.info/nyct/maps/subwaymap0911.pdf (400KB)  Having
the ability to change the zoom level directly (either by entering it manually,
or selecting it from a list) would save a great deal of time (though not as
good as selecting a rectangle for zooming in this use case).
Comment 15 gs 2010-08-11 21:16:15 UTC
Can we get a new build for the reader with new zooming levels added?
Comment 16 Andre Klapper maemo.org 2010-08-11 21:20:00 UTC
gs: Please ask the Diablo Community Updates team for Maemo4 updates.
In case of Maemo5/N900: No, as there is no patch for that.
Comment 17 gs 2010-08-11 21:25:47 UTC
I was asking the N900 build. It seems like the patch submitted here could be
easily applied to the version provided here:
http://repository.maemo.org/pool/fremantle/free/o/osso-pdf-viewer/

The problem is how to recompile the package? Is there a buildbot around or
someone that I can ask for a rebuild?
Comment 18 Andre Klapper maemo.org 2010-11-29 15:51:03 UTC
This is a WONTFIX.
The aim for Harmattan (the software version after Maemo5) is to provide
stepless zooming in the PDF viewer, as far as I know.
There won't be any percentage zooming levels but instead something like "Fit to
width" or "Fit to Page" by default.