Bug 2703 - Keep Horizontal Position when Changing Page
: Keep Horizontal Position when Changing Page
Status: RESOLVED WONTFIX
Product: Utilities
PDF reader
: 5.0-beta
: All All
: Low enhancement with 7 votes (vote)
: ---
Assigned To: unassigned
: pdf-reader-bugs
:
: easyfix
:
:
  Show dependency tree
 
Reported: 2008-01-04 04:12 UTC by Walt Bilofsky
Modified: 2012-03-24 11:44 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Walt Bilofsky (reporter) 2008-01-04 04:12:53 UTC
When zoomed in so the page is wider than the window, navigating to another page
moves the window to the left margin of the page.  It should leave the
horizontal positioning unchanged.  The PC version of Adobe Acrobat does it that
way.

This is important on the small screen because the user is likely to be zoomed
in on the readable area of the page.  Current behavior forces him to adjust the
centering whenever he moves to another page.

See also Bug 761, which if implemented would benefit from this change.
Comment 1 Walt Bilofsky (reporter) 2008-01-04 07:13:30 UTC
A related problem: At the top of a page, hitting the top four-way key should
scroll up to the bottom of the previous page.

Actually it goes to the top of the previous page.  This IMO is a bug.

If the user is scrolling down using that key, and goes one click too far onto
the following page, they should be able to back up by one scroll-up push.
Comment 2 Jussi Kukkonen 2008-01-05 15:07:05 UTC
(In reply to comment #1)
> A related problem: At the top of a page, hitting the top four-way key should
> scroll up to the bottom of the previous page.
> 
> Actually it goes to the top of the previous page.  This IMO is a bug.


Agreed, but you should file a new bug for that. Combining bugs usually makes
them less likely to get fixed.
Comment 3 Walt Bilofsky (reporter) 2008-01-05 18:52:59 UTC
Thanks for your advice.  Comment withdrawn.  See also Bug 2714,
Comment 4 hyartep 2008-01-29 13:59:30 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Anders Rune Jensen 2008-04-29 20:36:51 UTC
bump because this makes reading books on nokia from a 5 star experience to a 2
star. Please help us save the planet by making it easier to read our books on
tablets instead of wasting paper. :-)
Comment 6 yanghua 2008-07-08 09:49:19 UTC
(In reply to comment #3)
> Thanks for your advice.  Comment withdrawn.  See also Bug 2714,
> 
if i want to fixing this bug,where can download osso-pdf-viewer.deb ?I have
found the source code ,but when i run it present errors:

osso_pdfviewer[6407]: GLIB CRITICAL ** Gtk - gtk_icon_theme_load_icon:
assertion `error == NULL || *error == NULL' failed
osso_pdfviewer[6407]: GLIB ERROR ** default - file ui/interface.c: line 1668
(build_application_area): assertion failed: (app_ui_data->right_image &&
app_ui_data->left_image)
Comment 7 Andre Klapper maemo.org 2008-07-28 13:42:10 UTC
> where can download osso-pdf-viewer.deb ?I have found the source code

That's a contradiction. :)
You're gtk_icon_theme_load_icon problem is a different issue, no idea though -
maybe google can help, it is not Maemo or Hildon specific.
Comment 8 Andre Klapper maemo.org 2008-12-11 18:18:37 UTC
I don't consider this a bug but rather an enhancement.
Comment 9 Andre Klapper maemo.org 2009-06-05 21:03:24 UTC
*** Bug 464 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2012-03-24 11:44:56 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )