Bug 2673 - (int-79152) N800 Power up Drama
(int-79152)
: N800 Power up Drama
Status: RESOLVED FIXED
Product: Desktop platform
general
: unspecified
: N800 Windows
: High critical with 12 votes (vote)
: ---
Assigned To: Carlos Guerreiro
: HAF QA mailing list
:
:
:
: 2707
  Show dependency tree
 
Reported: 2007-12-29 20:16 UTC by Ham Radio
Modified: 2009-05-27 23:53 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ham Radio (reporter) 2007-12-29 20:16:52 UTC
just received a n800 directly from nokia.it shop

After first time battery charging process (where the screen showed the battery
icon) , the n800 did not power up ... any logo any sound ... just a black
screen

so i removed the battery and the memory for a couple of hours

then i tried again without any memory inserted, and finally the n800 power up
and boot process started ..

after 30min of use, and a normal quit, the power up problem is again present..

just a black screen without any attempt of boot ... also without the battery
just with the charger inserted .. the n800 does not power up... 

a great debubt for my n800... sigh!

maybe some1 in salo was sleeping during testing process of the item

any suggestion?
Comment 1 Ryan Abel maemo.org 2007-12-30 05:47:10 UTC
It seems like this issue only affects recent batches of N800s, so this doesn't
look like a software bug. Should this even go here?
Comment 2 Neil MacLeod maemo.org 2007-12-30 23:35:24 UTC
It appears that someone has found a solution[1] which may work for the OP - it
seems the affected N8x0's will only power up 3 minutes (or more) after they
were last powered down. Try and power up within 3 minutes and you have to wait
another 3 minutes before it will switch on... it all seems very bizarre,
perhaps a hardware counter is being corrupted or incorrectly initialised?

1. http://www.internettablettalk.com/forums/showthread.php?t=14107
Comment 3 Neil MacLeod maemo.org 2007-12-31 01:20:15 UTC
I wonder if this is a repeat (ie. regression) or a variation of the N800/OS2006
failure to boot bug which was due to a counter not being reset? (bug 957
comment 10).
Comment 4 Neil MacLeod maemo.org 2007-12-31 01:21:49 UTC
Removing contents of the "Alias" field as this field is used to associate this
public bug with the internal Nokia defect tracking system.
Comment 5 Neil MacLeod maemo.org 2007-12-31 01:22:43 UTC
(In reply to comment #3)
> I wonder if this is a repeat (ie. regression) or a variation of the N800/OS2006
> failure to boot bug which was due to a counter not being reset? (bug 957
> comment 10).
> 

This should have been N800/OS2007! :)
Comment 6 Ham Radio (reporter) 2008-01-01 22:23:29 UTC
the 3min fix seems not working on my n800 -(
Comment 7 Laszlo Marai 2008-01-03 05:06:19 UTC
Is it possible that this bug is related to bug #2290? (The device won't come
back from soft-off mode by a double push on the power button.)

Actually quite a few n810 devices have this problem too. The 'three minutes
fix' does not work. Are there any programmatic way to access and/or configure
the charging/battery monitoring functionality? Just a hint but it may help
fixing the problem.
Comment 8 Laszlo Marai 2008-01-03 13:33:56 UTC
I did some testing and the results indicate that it might be a software related
bug. I removed the batteries for 6 hours and then I put it back and the device
would boot up normally. Then I turned it off and it would turn switch on again
normally. The RTC backup baterry (or whatever it has inside) seems to have
lasted for about 1.5 hours as I removed the battery at around 5:00am and after
the first successful bootup the device time was 6:31am.

I turned it on and off a few times and then for the last try the blue corner
led (it's an n810) would light up then switch off and it wouldn't boot anymore.
I didn't do anything whith the device when it was on. Haven't started any
application manually it didn't connect to the network or a BT keyboard.

I'm sorry but I didn't count the number of sucessfull on-off attempts. It might
have been just two. I might have released the power button 'too early' for the
last attempt just as the LED lit up. Now I'm waiting for the 1.5 hours to pass
so that I could try it again.
Comment 9 justin.jing.cao 2008-01-04 22:40:13 UTC
I have encountered similar problem.

My brand new N800 turns on, I play with it, turn it off normally by holding the
shut down button. Wait a few seconds, try to turn it back on and it refuses.
Wait 1 day, try to turn it back on and it worked!

I opted for an exchange for a second N800 and the SAME thing happened. 
Phoned Nokia, they say it's a software issue and needs to be sent to the
factory for repairs!

Currently I don't know of any other solution but to wait 1 day for my device to
turn on again...
Comment 10 mla 2008-01-09 11:05:10 UTC
I've had the same experience with my N800 that I received in Dec. as a gift.

I sent it to Nokia for repair. They returned it with repair doc stating they
did a "Full Software Upgrade & Phone Reset"

But the problem is still present. I haven't found any way to get it to
consistently turn on. The 3-minute trick doesn't work. I've tried all the
combinations/tricks suggested on the boards and wikis.

I've had it boot up after being shutdown for just a couple minutes, and I've
had it *not* boot up after sitting off for a day.

I've tried pulling the battery and memory card. Nothing seems to work
consistently.

I'd be happy to help debug if there's anything you guys would like me to try.

I doubt there's any point in returning it to Nokia again, and it's too late to
return it to buy.com now.
Comment 11 Douglas McNish 2008-01-11 03:35:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 timeless 2008-01-17 10:28:23 UTC
note: i'm not a hardware engineer, I'm just curious, could people report the
contents of: /proc/component_version?

You should be able to load in in the browser, but if you prefer to use an
xterm, that's fine too. Also, could someone provide temperatures (deg C) for
"working" and "not working")
Comment 13 Eero Tamminen nokia 2008-01-17 11:03:16 UTC
(In reply to comment #3)
> I wonder if this is a repeat (ie. regression) or a variation of the
> N800/OS2006 failure to boot bug which was due to a counter not being reset?
> (bug 957 comment 10).

No, that old bug was an issue in DSME (on initfs) and happened only after
device had ended into reboot loop due to some other failure.


Anyway, a cause for this bug has been found and a fix is in works.
AFAIK it will require updating the device bootloader (can be done
with flasher), but I don't know when the fix will be available.
Comment 14 mla 2008-01-17 11:04:26 UTC
(In reply to comment #12)
> note: i'm not a hardware engineer, I'm just curious, could people report the
> contents of: /proc/component_version?
> 
> You should be able to load in in the browser, but if you prefer to use an
> xterm, that's fine too. Also, could someone provide temperatures (deg C) for
> "working" and "not working")

I browsed into /proc but component_version seems to be empty...at least, I
opened it and don't see anything.
Comment 15 Neil MacLeod maemo.org 2008-01-17 11:14:05 UTC
(In reply to comment #13)
> Anyway, a cause for this bug has been found and a fix is in works.
> AFAIK it will require updating the device bootloader (can be done
> with flasher), but I don't know when the fix will be available.
> 

Great - so what is the advice for people with this problem?

How best should they work around this problem until the fix is available?

Can you (or someone more familiar with the problem) provide more details other
than good news (bug is identified) and bad news (but no ETA for a fix)?
Comment 16 Neil MacLeod maemo.org 2008-01-17 11:15:48 UTC
Assuming this bug has been identified, shouldn't this report now be assigned
and aliased to an internal defect #?
Comment 17 Eero Tamminen nokia 2008-01-17 12:28:24 UTC
(In reply to comment #15)
> (In reply to comment #13)
> > Anyway, a cause for this bug has been found and a fix is in works.
> > AFAIK it will require updating the device bootloader (can be done
> > with flasher), but I don't know when the fix will be available.
> 
> Great - so what is the advice for people with this problem?
>
> How best should they work around this problem until the fix is available?

There's no currently known workaround.

However, if you can reflash the device (can get the device to boot up, you've
taken backup and have nothing else that you would miss, battery is full etc)
with the latest N800 OS2007 or OS2008 release we would be interested about 
whether that has any effect.


> Can you (or someone more familiar with the problem) provide more details other
> than good news (bug is identified) and bad news (but no ETA for a fix)?

The issue seems to be related to SW timings used in Omap initializations.
(that could explain why in some blog post it was claimed that freezing
the device helped i.e. that temperature could affect it.)

If everything works well, the fix could be available in a few weeks.
Comment 18 hfuks 2008-01-17 17:38:39 UTC
I have some observations which may be useful.

On my new N800 running OS2007, I encountered this bug when I loaded
camera_2.9-2video. That application is know to oops the kernel (bug reported).
After the kernel error, the camera application crashed, and it would not close
its window no matter what (kill -9 did not help). So I had to shut N800 down,
and after that I could not turn it on again unless I did the tricks described
elsewhere (removing battery, waiting for some time, etc.).

This was reproducible behavior on my system -each time after camera crash
and turning off I had trouble tunning it on. I tried this several times.
It would turn on normally in other cases (i.e., not following camera-induced
kernel crash).


I reflashed with OS 2008, and camera2.9 no longer works, so I cannot
test this any more.
Comment 19 Eike Hein 2008-01-17 22:08:26 UTC
I have a Nokia N810 running the latest OS 2008 release since last week, and
have been suffering from this issue from day one, albeit not as pronounced as
some people are reporting. For me, whenever I turn the device off, I have to
wait approximately five minutes before I can turn it on again. The duration
appears to be fairly stable, i.e. it's usually not dramatically less or more
than five minutes - that said, the environmental conditions here are also very
stable. 

Notably when I turn it off, I have to take care not to connect it to the
charger within the period in which it wouldn't turn on, since it will not
charge in that case (as it can't boot into charging mode then, presumably).

A reflash had no effect.

The problem is a fairly easy to ignore inconvenience in practice, but still I'm
happy to hear there's a chance for a software fix down the road.
Comment 20 justin.jing.cao 2008-01-21 06:57:46 UTC
(In reply to comment #15)
> Great - so what is the advice for people with this problem?
> 
> How best should they work around this problem until the fix is available?
> 
> Can you (or someone more familiar with the problem) provide more details other
> than good news (bug is identified) and bad news (but no ETA for a fix)?
> 

I can confidently say that an OS upgrade will not help. Both of my dud devices
came with the same version of OS2007 installed (I forgot the version number). I
updated the firmware/OS to 2008 V:2.2007.50-2 and it did not solve my turning
on problem. (If you want to upgrade you got 1 shot per day; which is to turn
off device, wait 1 day and follow turn on instructions to upgrade OS.)

My only way of getting a functional device is to opt for 2 exchanges. My third
device is working properly. I can properly turn on the device at will! woot!

-JC
Comment 21 Laszlo Marai 2008-01-24 23:02:47 UTC
I can also confirm that upgrade doesn't help. (Actually I tried it before
anything else.) My n810 doesn't turn on with 2.20007.50-2, wich is the latest
version as of now.

My /proc/component_version is:
product     RX-44
hw-build    0801
nolo        1.1.7
Comment 22 Eero Tamminen nokia 2008-01-25 10:38:52 UTC
(In reply to comment #18)
> This was reproducible behavior on my system -each time after camera crash
> and turning off I had trouble tunning it on. I tried this several times.
> It would turn on normally in other cases (i.e., not following camera-induced
> kernel crash).

Thanks!  If this happened only after Camera crash, it could be a different
issue though, warranting a separate bug.
Comment 23 michaelwpeterson 2008-01-30 10:23:29 UTC
My wife's shiny new Nokia N800 won't power on. It worked great out of the box
when it arrived today. She came to join me for lunch and brought it along to
show it off. It wouldn't turn on. We took the battery out for several minutes,
put the battery back in, and it turned back on. She played with it all day and
spent hours reading about it online while it was charging. She turned it off
and now it won't turn back on at all, regardless of how often or long we take
the battery out and whether or not it's plugged in. She's near tears that this
thingy is defective after the first day, not to mention the time and expense
required to ship it back for a replacement that might have the same problem.

Please fix this bug.
Comment 24 michaelwpeterson 2008-02-01 00:44:52 UTC
Updated my wife's new N800 to 2008SE_1.2007.50-2 and it seems to have fixed the
problem for her. We turned it off and back on several times last night without
any problems. It's still a bit early to say the problem is gone, but it's at
least greatly improved and we've avoided the several weeks of being without an
N800 while buy.com processes a return.
Comment 25 Eero Tamminen nokia 2008-02-01 11:49:56 UTC
(In reply to comment #24)
> Updated my wife's new N800 to 2008SE_1.2007.50-2 and it seems to have fixed
> the problem for her. We turned it off and back on several times last night
> without any problems. It's still a bit early to say the problem is gone, but
> it's at least greatly improved and we've avoided the several weeks of being 
> without an N800 while buy.com processes a return.

FYI: in general there should be no reason to turn the device off because:
- Turning the device off while you're not using it doesn't usually help you
  to save battery. The reason is that the device power-on uses more power than
  if the device would idle for a few days (idling = all applications are
  closed and there are no Home applets that would poll the network and user
  hasn't installed any 3rd party software that drains battery in the 
  background)
- In the airplanes you can just put the device to "offline" mode from
  the power menu.  This disables all the radios from it

Turning the device off is something you should need to do only if you're not
planning to use it for next week(s).  When the device is idle, it's best to
lock its touchscreen & keys by pressing power + select keys (you can unlock
it the same way and in N810 there's even a special lock key).
Comment 26 michaelwpeterson 2008-02-01 22:41:45 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > Updated my wife's new N800 to 2008SE_1.2007.50-2 and it seems to have fixed
> > the problem for her. We turned it off and back on several times last night
> > without any problems. It's still a bit early to say the problem is gone, but
> > it's at least greatly improved and we've avoided the several weeks of being 
> > without an N800 while buy.com processes a return.
> 
> FYI: in general there should be no reason to turn the device off because:

You'll get no argument from me about this point. That the n800 almost never
needs to be turned off is the reason we haven't RMA'ed it. In day to day usage
it's a tiny enough bug that, since Nokia has acknowledged it and plans to fix
it, we're content to wait for a fix with the current n800 we have rather than
risk getting one that's more or differently borken.

I think we all agree that being able to consistently turn the device back on in
a timely manner if one should turn it off for some reason would be a nice
feature. :)


And the bug still exists on this n800 with the current OS2008. It popped up
last night when my wife turned it off to see if it would turn back on. It was
off the charger at the time. It wouldn't turn back on immediately. After about
30 minutes with the batter out and off the charger, it turned back on.

> - Turning the device off while you're not using it doesn't usually help you
>   to save battery. The reason is that the device power-on uses more power than
>   if the device would idle for a few days (idling = all applications are
>   closed and there are no Home applets that would poll the network and user
>   hasn't installed any 3rd party software that drains battery in the 
>   background)
> - In the airplanes you can just put the device to "offline" mode from
>   the power menu.  This disables all the radios from it
> 
> Turning the device off is something you should need to do only if you're not
> planning to use it for next week(s).  When the device is idle, it's best to
> lock its touchscreen & keys by pressing power + select keys (you can unlock
> it the same way and in N810 there's even a special lock key).
> 

That's exactly how we use it.
Comment 27 Philippe De Swert nokia 2008-02-05 16:50:58 UTC
Nokia is aware of the problem and a possible fix is being tested. Please
stand-by for more news.
Comment 28 John 2008-02-07 00:30:21 UTC
My N800 also has the 3 minute power on delay.

Also, if related, there is a power on problem after charging overnight with
the device plugged in to the AC adapter.
Comment 29 Konstantin Yegupov 2008-02-07 11:18:24 UTC
Confirmed temperature dependency - I have the same bug, and "freezer fix"
worked like a charm.

Still waiting for normal fix - Nokia, please don't disappoint me.
Comment 30 Natalia Dobrovolskaya nokia 2008-02-07 11:46:35 UTC
(In reply to comment #29)
> Confirmed temperature dependency - I have the same bug, and "freezer fix"
> worked like a charm.
> 
> Still waiting for normal fix - Nokia, please don't disappoint me.
> 

Thank you for comment! The bug was fixed and currently we are testing bug fix.
We will inform then fix will be available.
Comment 31 Marcin Juszkiewicz 2008-02-07 16:15:24 UTC
Nice to hear that fix is found as it looks like my n810 has the same problem.
Comment 32 John 2008-02-07 23:05:46 UTC
I'm about to return my N800.  So, before I do, any chance the patch that fixes
this problem can be provided so I can make sure it works for me ?
Comment 33 Natalia Dobrovolskaya nokia 2008-02-08 10:39:34 UTC
(In reply to comment #32)
> I'm about to return my N800.  So, before I do, any chance the patch that fixes
> this problem can be provided so I can make sure it works for me ?
> 
Hi Johan, Let's wait next week. The fix in its way of providing for you. Thank
you for your patience.
Comment 34 Patrick Lau 2008-02-13 02:21:10 UTC
I have the same problem today with my new N800 with OS2008.  The unit was on
all day with screen/key locked and in my shirt pocket.  I heard a sound from
the unit; but didn't notice it was power off by itself. It won't power up
since.  I have not try any of the 3 minutes trick; but tried pulling out the SD
(8GB internal) card, no difference.  Hoping for the fix will be here soon so I
don't have to return the unit.
Comment 35 Patrick Lau 2008-02-14 08:48:02 UTC
Just follow up on my report yesterday.  It turns out the battery on my N800 was
completely drain (only 1 day after fully recharge with minimal usage) and shut
itself off due to battery low condition.  Once I charged it up last night, it
power up with no issue.  However, the battery is running low again within a day
with minimal use.  Will search if anybody else experienced the same battery
drain issue.
Comment 36 Eero Tamminen nokia 2008-02-14 10:47:50 UTC
(In reply to comment #35)
> Just follow up on my report yesterday.  It turns out the battery on my N800
> was completely drain (only 1 day after fully recharge with minimal usage)

In this case the unit screen should still be lit for a second or two when
you press the power button.


> and shut itself off due to battery low condition.  Once I charged it up last
> night, it power up with no issue.  However, the battery is running low again
> within a day with minimal use.

Have you left e.g. some browser page open with flash or javascript
animations or animated images?


> Will search if anybody else experienced the same battery drain issue.

What 3rd party applications, applets or other packages you've installed?
If you start Utilities -> X terminal and then "top", does it show something
else than "top", X terminal (single "maemo-launcher" process) and "Xomap"
taking CPU?

It taking wwhole day to drain battery would indicate that something is not
using CPU that much, just waking too often.
Comment 37 Emre 2008-02-14 18:23:41 UTC
Any news on the fix ? When will it be out?? I have to wait at least 1 hour with
the battery out after switching off the unit to re-power on... It is very
annoying to use the tablet this way.
Comment 38 Tim 2008-02-14 21:40:24 UTC
(In reply to comment #37)
> Any news on the fix ? When will it be out?? I have to wait at least 1 hour with
> the battery out after switching off the unit to re-power on... It is very
> annoying to use the tablet this way.  
> 

I too REALLY want to know when this bug fix will be out.  I sure hope it will
be posted here so I am alerted.

To Emre - Have you tried sticking your N800/810 in the freezer for about 3-5
minutes without the battery, then pop the battery in and power it on?  I was
skeptical that this would work, but every time I do it the unit powers right
on.  And EVERY time I have to shut it down it will not turn back on without
doing the freezer trick.  I never left it sit for more than say 30 minutes when
it wouldn't power on, but the freezer trick has worked every time for me so
far.
Comment 39 Patrick Lau 2008-02-15 04:10:28 UTC
(In reply to comment #36)
> (In reply to comment #35)
> > Just follow up on my report yesterday.  It turns out the battery on my N800
> > was completely drain (only 1 day after fully recharge with minimal usage)
> In this case the unit screen should still be lit for a second or two when
> you press the power button.
> > and shut itself off due to battery low condition.  Once I charged it up last
> > night, it power up with no issue.  However, the battery is running low again
> > within a day with minimal use.
> Have you left e.g. some browser page open with flash or javascript
> animations or animated images?
> > Will search if anybody else experienced the same battery drain issue.
> What 3rd party applications, applets or other packages you've installed?
> If you start Utilities -> X terminal and then "top", does it show something
> else than "top", X terminal (single "maemo-launcher" process) and "Xomap"
> taking CPU?
> It taking wwhole day to drain battery would indicate that something is not
> using CPU that much, just waking too often.

I think I found what the problem is. The "Search Interval" under WLAN
"Connectivity" setting was default to 10 minutes.  It basically wakes up every
10 minutes and try to connect to the Wireless WLAN.  I notice from my router
log, there were multiple entries from my N800 authetication every 10 minutes or
so.  I now changed it to "Never" and only manually enable it when I need to use
it and it seem to solve the problem.  Thank you for taking the time to
response.
Comment 40 Emre 2008-02-15 08:16:40 UTC
Yes Tim, I have tried refrigirator and as you said it works very well 1 minute
in the deep freezer and by magic it powers up again. But I dont have a
refrigirator at work....and mostly I use it at work.... Sometimes when I am on
the car I take the cover and the battery out and hold n800 out of the window
which also works. I am afraid if the fix wont come out soon my n800 will blow
away from my hands or it will be NFrosty someday soon.
Comment 41 Eero Tamminen nokia 2008-02-15 14:20:00 UTC
(In reply to comment #40)
> Yes Tim, I have tried refrigirator and as you said it works very well 1 minute
> in the deep freezer and by magic it powers up again. But I dont have a
> refrigirator at work....and mostly I use it at work.... 

While waiting for the fix release, couldn't you just plug it to charger at
work?
Comment 42 Emre 2008-02-15 14:49:30 UTC
(In reply to comment #41)
> (In reply to comment #40)
> > Yes Tim, I have tried refrigirator and as you said it works very well 1 minute
> > in the deep freezer and by magic it powers up again. But I dont have a
> > refrigirator at work....and mostly I use it at work.... 
> While waiting for the fix release, couldn't you just plug it to charger at
> work?

(In reply to comment #41)
> (In reply to comment #40)
> > Yes Tim, I have tried refrigirator and as you said it works very well 1 minute
> > in the deep freezer and by magic it powers up again. But I dont have a
> > refrigirator at work....and mostly I use it at work.... 
> While waiting for the fix release, couldn't you just plug it to charger at
> work?

Thats what i do usually. I try to keep it charged always and connected to
charge at the office. But the sad thing is, when it powers down for any reason
I realize that it powered down when I need it and at that moment if there is no
refrigirator under my hand I have to wait 1 hour. I dont live in the US and my
friend purchased it for me from Us therfore there is no easy way of returning
it back for me. I can stand this power issue because I love this machine or
else it would have been in the junk way way before. And also the chance of fix
that will be around soon makes it standable.
Comment 43 ciny111 2008-02-17 01:17:29 UTC
so when exactly will the fix come out? anyone have any news?
Comment 44 jdm 2008-02-17 06:47:59 UTC
My N800 / OS2008 will only turn on if it's been in the freezer. Luckily it was
delivered in the middle of a snowstorm, or I would have assumed it was dead on
arrival. But this problem makes changing batteries while traveling quite
difficult. For my trip next week, I'll try carrying a heavy plastic bag with
me, borrowing ice.... The fix can't come soon enough!
Comment 45 Natalia Dobrovolskaya nokia 2008-02-18 12:18:14 UTC
(In reply to comment #43)
> so when exactly will the fix come out? anyone have any news?
> 

I am sorry, I cm not tell you the exact time of the fix come out. It is ready
and management is testing it. I will check and comment here. Sorry agaian :)
Comment 46 Tim 2008-02-18 16:14:59 UTC
(In reply to comment #45)
> (In reply to comment #43)
> > so when exactly will the fix come out? anyone have any news?
> > 
> 
> I am sorry, I cm not tell you the exact time of the fix come out. It is ready
> and management is testing it. I will check and comment here. Sorry agaian :) 
> 

Well, it's good to hear that it's at least to the stage of just being tested
before release, but MAN do I want it bad! ;-)  Last night, in the middle of the
night, my N800 woke me up by making some noises.  I'm still not familiar enough
with the device to know exactly what the sounds signify, and I was too far away
from it to see if anything came up on the screen (I wasn't going to get out of
bed), but I was guessing that it sounded like it was shutting down and the
sounds reminded me of applications closing.

This morning when I went to turn it on, nothing.  Perhaps the battery was
sufficiently drained and it went through the motions of shutting itself down,
but I thought I had enough battery life that it could at least last the night. 
Anyway, I plugged it into the charger and still nothing happened (?).  I'm
guessing that even with this scenario I need to put it in the freezer for a bit
to just get it to charge, but this is making me nervous because it "feels" like
it's a hardware issue rather than a software issue.  I have faith though and
will wait, but I don't want to get outside of my return policy in case the fix
doesn't solve my problem... so hurry please! ;-)

PS - If anyone is interested, I have a blog that I have been trying to track
stuff I find about the N800, as well as Linux/OSes and anything that catches my
fancy.  I'd love visitors and any comments from the community! 
http://tablettypethings.blogspot.com
Comment 47 Neil MacLeod maemo.org 2008-02-19 23:06:27 UTC
New firmware images - 2.2007.51-3 - are now available for both the N800 and
N810 which apparently rectify the power on situation (positive posts on ITT):

N800:
http://tablets-dev.nokia.com/nokia_N800.php?f=RX-34_2008SE_2.2007.51-3_PR_COMBINED_MR0_ARM.bin

N810:
http://tablets-dev.nokia.com/nokia_N810.php?f=RX-44_2008SE_2.2007.51-3_PR_COMBINED_MR0_ARM.bin
Comment 48 Marcin Juszkiewicz 2008-02-19 23:25:24 UTC
Why I am not surprised that there is no informations about what was changed in
rootfs contents? And if there were any why there are no upgradable packages for
it?

Flashing bootloader (NOLO) should be enough to get this bug resolved. So I am
curious how many package updates was added into new rootfs image.
Comment 49 Neil MacLeod maemo.org 2008-02-19 23:43:28 UTC
(In reply to comment #48)
> Why I am not surprised that there is no informations about what was changed in
> rootfs contents? And if there were any why there are no upgradable packages for
> it?

Well it's early days, this firmware has only been available for download for
just over 24 hours so we probably need to give it another few days for official
word to creep out on this new release - no need to rush, as not many people
were affected by this bugfix or in any hurry to receive it. </sarcasm>

As for changes - maemo.org don't do changelogs. Changelogs have been requested
many times with each new release, and promises received that changelogs will be
made available with "the next release", and naturally it never happens. If the
development process were properly coordinated it would be a piece of cake to
produce a changelog cross-referenced with the public bugzilla and other
non-secret changes - just push a button and there's your change log. Draw your
own conclusions as to why it appears impossible for this project to produce
something as basic as a cross-referenced changelog.

Chances are this update only fixes whatever was broken in initfs and rootfs is
identical to 50-2... but that's just a total guess!
Comment 50 camaroer87 2008-02-20 00:09:59 UTC
(In reply to comment #49)
> (In reply to comment #48)
> > Why I am not surprised that there is no informations about what was changed in
> > rootfs contents? And if there were any why there are no upgradable packages for
> > it?
> 
> Well it's early days, this firmware has only been available for download for
> just over 24 hours so we probably need to give it another few days for official
> word to creep out on this new release - no need to rush, as not many people
> were affected by this bugfix or in any hurry to receive it. </sarcasm>
> 
> As for changes - maemo.org don't do changelogs. Changelogs have been requested
> many times with each new release, and promises received that changelogs will be
> made available with "the next release", and naturally it never happens. If the
> development process were properly coordinated it would be a piece of cake to
> produce a changelog cross-referenced with the public bugzilla and other
> non-secret changes - just push a button and there's your change log. Draw your
> own conclusions as to why it appears impossible for this project to produce
> something as basic as a cross-referenced changelog.
> 
> Chances are this update only fixes whatever was broken in initfs and rootfs is
> identical to 50-2... but that's just a total guess!
> 

I agree with you.  If you look at the sizes the new one is not that much bigger
than the previous one.
Comment 51 Tim 2008-02-20 06:16:21 UTC
(In reply to comment #47)
> New firmware images - 2.2007.51-3 - are now available for both the N800 and
> N810 which apparently rectify the power on situation (positive posts on ITT):
> 
> N800:
> http://tablets-dev.nokia.com/nokia_N800.php?f=RX-34_2008SE_2.2007.51-3_PR_COMBINED_MR0_ARM.bin
> 
> N810:
> http://tablets-dev.nokia.com/nokia_N810.php?f=RX-44_2008SE_2.2007.51-3_PR_COMBINED_MR0_ARM.bin
> 

Well, I can confirm that it indeed fixes my N800!!!  I know this because EVERY
time I switched off my device the only way I could get it back on was the
freezer trick... even if it JUST came out of the freezer and I would start it
up and immediately shut it down, it would NOT start up until I put it back in
the freezer for a few more minutes.

So this is HUGE for me.. I won't have to return it now and it was just in time
before I have to travel to a week long conference where I'm sure freezers are
not easily come by. ;-)
Comment 52 John 2008-02-20 23:43:17 UTC
To apply the patch is equivalent to restoring or flashing so that settings,
data are lost?  Thanks
Comment 53 Tim 2008-02-21 01:45:20 UTC
(In reply to comment #52)
> To apply the patch is equivalent to restoring or flashing so that settings,
> data are lost?  Thanks
> 

Yes, you are flashing with a new version of the firmware/OS.  However, you can
backup and restore all your data and even applications during the process.  I
wrote up my experience on my blog at
http://tablettypethings.blogspot.com/2008/02/bug-2673-n800-power-up-drama.html

Please let me know if it's helpful to you and feel free to comment.  I'm hoping
what I post can help someone other than me! ;-)
Comment 54 Philippe De Swert nokia 2008-02-21 12:51:04 UTC
As many people already noticed a new firmware has been released. The only
change is the power-up fix, which is in the bootloader. Just flashing the
bootloader should fix the issue if you prefer to avoid having to make back-ups
etc.
Comment 55 Tim 2008-02-21 18:30:09 UTC
(In reply to comment #54)
> As many people already noticed a new firmware has been released. The only
> change is the power-up fix, which is in the bootloader. Just flashing the
> bootloader should fix the issue if you prefer to avoid having to make back-ups
> etc.
> 

Though I already performed a full update, could someone explain how to flash
only the bootloader (for future reference for me, but any other newb that might
find this bug and solution).  Not having to backup/restore all my stuff would
have been a lot easier... and quicker. ;-)
Comment 56 Laszlo Marai 2008-02-21 19:07:06 UTC
(In reply to comment #54)
> The only change is the power-up fix, which is in the bootloader. 

Are you sure? I sure what all these images are inside the bin file (I can
figure out rootfs and kernel of course), but it seems that 2nd.bin,
secondary.bin, xloader.bin _and_ rootfs.jffs2 has all changed. I haven't
checked the contents, just the images themselves.

> Just flashing the bootloader should fix the issue if you prefer to avoid 
> having to make back-ups

How does one do that? It doesn't seem to be documented anywhere. What I figured
out from the flasher help and error messages is that 
./flasher-3.0-static -F RX-44_2008SE_2.2007.50-2_PR_COMBINED_MR0_ARM.bin
--flash-only nolo -f -R

should work. Can you confirm that? Though it's a bit contradictory because the
help says that "-f" is for "Load and flash all supplied images" which
contradicts with --flash-only.
Comment 57 Laszlo Marai 2008-02-21 19:08:17 UTC
(In reply to comment #56)
> Are you sure? I sure what all these images are inside the bin file (I can

I mean I'm not sure...
Comment 58 Calum Mackay 2008-02-23 06:00:06 UTC
(In reply to comment #55)
> Though I already performed a full update, could someone explain how to flash
> only the bootloader (for future reference for me, but any other newb that might
> find this bug and solution).  Not having to backup/restore all my stuff would
> have been a lot easier... and quicker. ;-)

according to:

http://blog.haerwu.biz/2008/02/22/resolving-power-on-drama/

it is:

flasher –fiasco RX-44_2008SE_2.2007.51-3_PR_COMBINED_MR0_ARM.bin
–flash-only=nolo –flash

but I've not yet tried this.
Comment 59 Benjamin Peterson 2008-02-25 14:18:18 UTC
I still have what I think is the same problem, using the 51-3 firmware on a new
n810.

When bought, it had various issues such as not playing mp3s, so I immediately
reflashed it with 51-3.  This fixed the original issues, but it has the
following problem:

--When left alone sufficiently long, it seems to turn itself off
--It then can't be turned on again -- pressing the button results in the screen
lighting up and saying 'nokia' and then EITHER going dark again OR continuing
to say 'NOKIA' until the battery is removed.
--It can eventually be turned on by various combinations of removing and
replacing the battery, waiting, and bouncing on the on/off button.  However as
of today I've been intermittently trying to turn it on for about 12 hours with
no useful effect.

I'm not sure whether this is the same problem referred to in this issue (in
which case 51-3 has *not* fixed it) or whether its a separate problem (i.e.
defective hardware).
Comment 60 Eero Tamminen nokia 2008-02-25 15:22:00 UTC
> --When left alone sufficiently long, it seems to turn itself off

Have you installed any additional software or do you have any programs
running when this happens?  With full charge (device being charged until
it says that battery is full) and no apps/applets running, it should
last several days.


> --It then can't be turned on again -- pressing the button results in
> the screen lighting up and saying 'nokia' and then EITHER going dark again

This happens when your battery doesn't have enough charge.


> OR continuing to say 'NOKIA' until the battery is removed.

Did you in this case have charger attached?


> --It can eventually be turned on by various combinations of removing and
> replacing the battery, waiting, and bouncing on the on/off button.  However
> as of today I've been intermittently trying to turn it on for about 12 hours
> with no useful effect.

If the screen lighted up for a while earlier, it's possible that you've
drained the battery completely.  Have you charged the device and did it
actually report that it was charging? (we've had reports from people
who've managed to break their charger wire)
Comment 61 Benjamin Peterson 2008-02-25 20:04:41 UTC
(In reply to comment #60)

Thanks for your reply.

> > --When left alone sufficiently long, it seems to turn itself off
> 
> Have you installed any additional software or do you have any programs
> running when this happens?  With full charge (device being charged until
> it says that battery is full) and no apps/applets running, it should
> last several days.

There is no additional software that should be doing that (I put a few dev
tools on it but nothing that should be constantly on).

> > --It then can't be turned on again -- pressing the button results in
> > the screen lighting up and saying 'nokia' and then EITHER going dark again
> 
> This happens when your battery doesn't have enough charge.
> 
> 
> > OR continuing to say 'NOKIA' until the battery is removed.
> 
> Did you in this case have charger attached?
> 

It would make perfect sense if with the charger attached it stayed lit up and
without the charger it faded to black, but strangely there does not seem to be
a correlation.

But yes, it's certainly odd that it powers off so quickly all by itself.  If I
could turn it on, I'd reflash it with 51-3 and no software at all and test it
like that for a day or two.


> 
> > --It can eventually be turned on by various combinations of removing and
> > replacing the battery, waiting, and bouncing on the on/off button.  However
> > as of today I've been intermittently trying to turn it on for about 12 hours
> > with no useful effect.
> 
> If the screen lighted up for a while earlier, it's possible that you've
> drained the battery completely.  Have you charged the device and did it
> actually report that it was charging? (we've had reports from people
> who've managed to break their charger wire)

Originally, it did report that it was charging, then that it was fully charged.
 Interestingly, the last time it did that was also the last time I was able to
turn it on.  Since then, when I connect the charger nothing happens.  If I then
press the on button, it lights up with 'Nokia' but gets no further.

Also, if I turn it on connected to a PC via the USB cable, the USB logo does
not seem to appear in the corner of the screen.

Perhaps this is not the 'power up drama' but a physically defective unit?  If I
think it's 'power up drama' then I'll persevere with it, if not Amazon can have
it back :)
Comment 62 Eero Tamminen nokia 2008-02-26 11:06:38 UTC
(In reply to comment #61)
> Originally, it did report that it was charging, then that it was fully
> charged.  Interestingly, the last time it did that was also the last time
> I was able to turn it on.  Since then, when I connect the charger nothing 
> happens.  If I then press the on button, it lights up with 'Nokia' but gets
> no further.

Please check that your charger works with some other device (N-series phone
for example) or try your device with another compatible charger (if you don't
have one, you might visit a nearby phone shop).  The charger cable is not that
thick and it's possible to physically
break it.


> Also, if I turn it on connected to a PC via the USB cable, the USB logo does
> not seem to appear in the corner of the screen.

Please time how many seconds it takes until it turns off again.
Comment 63 Ed 2008-04-15 23:06:33 UTC
Hi

I got a new n810 today, flashed it with Nokia firmware uploader utility
(Windows) to the latest version and now I got a very expensive brick!

With the previous version it came with, no problem at all. I could power off/on
without problems. With the new one after flashing I switched it off and until
now I haven't been able to power it up again. Tried the fridge trick, etc... no
sign of live.

Are there any other things to try?



(In reply to comment #62)
> (In reply to comment #61)
> > Originally, it did report that it was charging, then that it was fully
> > charged.  Interestingly, the last time it did that was also the last time
> > I was able to turn it on.  Since then, when I connect the charger nothing 
> > happens.  If I then press the on button, it lights up with 'Nokia' but gets
> > no further.
> 
> Please check that your charger works with some other device (N-series phone
> for example) or try your device with another compatible charger (if you don't
> have one, you might visit a nearby phone shop).  The charger cable is not that
> thick and it's possible to physically
> break it.
> 
> 
> > Also, if I turn it on connected to a PC via the USB cable, the USB logo does
> > not seem to appear in the corner of the screen.
> 
> Please time how many seconds it takes until it turns off again.
>
Comment 64 Eero Tamminen nokia 2008-04-16 09:53:16 UTC
(In reply to comment #63)
> With the previous version it came with, no problem at all. I could power
> off/on without problems. With the new one after flashing I switched it off
> and until now I haven't been able to power it up again. Tried the fridge
> trick, etc... no sign of live.

Even the screen doesn't light up?  Does your charger work (e.g. in another
N-series device)?
Comment 65 Ed 2008-04-16 10:16:21 UTC
I have a E61i that has exacly the same battery, tried replacing them...
nothing. With other charger, nothing, no sign of life, completely dead.
What it surprises me is that I had no problem with the original firmware and
neither after coming on first time after flashing. I'm starting to wonder if I
have been unfortunate enough to have a corruption while flashing.

Really fustrating as the unit doesn't do anything. I have left it overnigh with
the battery out and nothing. :(

> 
> Even the screen doesn't light up?  Does your charger work (e.g. in another
> N-series device)?
>
Comment 66 Eero Tamminen nokia 2008-04-16 11:39:07 UTC
(In reply to comment #65)
> I have a E61i that has exacly the same battery, tried replacing them...
> nothing. With other charger, nothing, no sign of life, completely dead.
> What it surprises me is that I had no problem with the original firmware
> and neither after coming on first time after flashing.

You need to take the device to service point so that the reason
for this issue can be determined.  We haven't heard of this kind
of issue after the fix to the bug here was released.


> I'm starting to wonder if I
> have been unfortunate enough to have a corruption while flashing.

That's possible too, but unlikely. The Linux flasher should be doing
verification about the flashing, I would assume the same about the Windows
flasher...
Comment 67 Tim 2008-04-16 16:10:33 UTC
(In reply to comment #63)
> Hi
> 
> I got a new n810 today, flashed it with Nokia firmware uploader utility
> (Windows) to the latest version and now I got a very expensive brick!
> 
> With the previous version it came with, no problem at all. I could power off/on
> without problems. With the new one after flashing I switched it off and until
> now I haven't been able to power it up again. Tried the fridge trick, etc... no
> sign of live.
> 
> Are there any other things to try?
> 
> 
> 
> (In reply to comment #62)
> > (In reply to comment #61)
> > > Originally, it did report that it was charging, then that it was fully
> > > charged.  Interestingly, the last time it did that was also the last time
> > > I was able to turn it on.  Since then, when I connect the charger nothing 
> > > happens.  If I then press the on button, it lights up with 'Nokia' but gets
> > > no further.
> > 
> > Please check that your charger works with some other device (N-series phone
> > for example) or try your device with another compatible charger (if you don't
> > have one, you might visit a nearby phone shop).  The charger cable is not that
> > thick and it's possible to physically
> > break it.
> > 
> > 
> > > Also, if I turn it on connected to a PC via the USB cable, the USB logo does
> > > not seem to appear in the corner of the screen.
> > 
> > Please time how many seconds it takes until it turns off again.
> > 
> 

If it came back on after you flashed it even once, I would say it doesn't have
to do with the flash.

Can you still return it for a replacement?  I think I have read around that
this has happened before with some 810s and people simply had to replace them.
Comment 68 Ed 2008-04-23 14:26:48 UTC
Yes, after flashing it, it did booted up once only. Then nothing.

I got a replacement today with version 1.2007.42-19 and I'm really scare of the
same thing happening again. Is there any special safe way of doing it? I'm
running Windows.

Thanks

(In reply to comment #67)
> (In reply to comment #63)
> > Hi
> > 
> > I got a new n810 today, flashed it with Nokia firmware uploader utility
> > (Windows) to the latest version and now I got a very expensive brick!
> > 
> > With the previous version it came with, no problem at all. I could power off/on
> > without problems. With the new one after flashing I switched it off and until
> > now I haven't been able to power it up again. Tried the fridge trick, etc... no
> > sign of live.
> > 
> > Are there any other things to try?
> > 
> > 
> > 
> > (In reply to comment #62)
> > > (In reply to comment #61)
> > > > Originally, it did report that it was charging, then that it was fully
> > > > charged.  Interestingly, the last time it did that was also the last time
> > > > I was able to turn it on.  Since then, when I connect the charger nothing 
> > > > happens.  If I then press the on button, it lights up with 'Nokia' but gets
> > > > no further.
> > > 
> > > Please check that your charger works with some other device (N-series phone
> > > for example) or try your device with another compatible charger (if you don't
> > > have one, you might visit a nearby phone shop).  The charger cable is not that
> > > thick and it's possible to physically
> > > break it.
> > > 
> > > 
> > > > Also, if I turn it on connected to a PC via the USB cable, the USB logo does
> > > > not seem to appear in the corner of the screen.
> > > 
> > > Please time how many seconds it takes until it turns off again.
> > > 
> > 
> 
> If it came back on after you flashed it even once, I would say it doesn't have
> to do with the flash.
> 
> Can you still return it for a replacement?  I think I have read around that
> this has happened before with some 810s and people simply had to replace them.
>
Comment 69 Ed 2008-04-23 14:30:43 UTC
Forgot to mention that in the first unit whenever I tried to install Skype, I
always got a message saying: "Unable to install Skype. Some application
packages required for the intsllation are missing". Then I though I better
upgrade the OS and then is when the real problem started.

Now with the new unit I get exactcly the same message. A bit worried now...
Sounds familiar to anyone?



(In reply to comment #68)
> Yes, after flashing it, it did booted up once only. Then nothing.
> 
> I got a replacement today with version 1.2007.42-19 and I'm really scare of the
> same thing happening again. Is there any special safe way of doing it? I'm
> running Windows.
> 
> Thanks
Comment 70 Tim 2008-04-23 16:22:52 UTC
Sorry, I can't remember exactly what I had to do to get mine to install Skype,
but I know there are several apps that I have installed that require additional
packages.  I can't look it up right now, but feel free to check out my blog
(http://tablettypethings.blogspot.com) where I posted just about everything I
learned along the way using my n800 (haven't posted in a while).  There are
some posts on there that specifically list all of the repositories where you
can get apps which makes it LOTS easier to find anything you might need/be
missing.

A good thing to do is search on installing Skype on your device and the
specific wording of the error.  

Bottom line, I seriously doubt that has ANYTHING to do with what happened to
your unit.  Also, if you still have a time period where you can return this new
unit if something goes wrong with it, then I say it's the perfect time to flash
that sucker and see if it breaks too.  You can always get a new one.  Just make
sure that you read up as much as possible on how to flash your unit from
Windows.  I would guess that you did it perfectly fine the first time (because
it booted up at least once, so it had to be right), but the more you can read
about it the better off you'll be.  I think I posted on my blog about my
upgrade experience.  The first time I used Windows, the second time I used
Linux.
Comment 71 pepitoe 2008-04-23 17:32:38 UTC
To install Skype you do need to do the firmware update, then it should install
without any trouble.

To flash your device safely all I can say is make sure it is fully charged, and
plug it directly into a usb port on your pc, not through any hubs.
Comment 72 Ed 2008-04-25 11:37:51 UTC
Finally I decided to flash it and this time everything went ok. Skype installed
without problems and so far there's no power up drama (tested only 48h).

It seems that in deed was a faulty unit then.

Thanks everyone for the advice :)


(In reply to comment #71)
> To install Skype you do need to do the firmware update, then it should install
> without any trouble.
> 
> To flash your device safely all I can say is make sure it is fully charged, and
> plug it directly into a usb port on your pc, not through any hubs.
>
Comment 73 MRD 2009-05-27 23:53:10 UTC
This bug is still alive!

I installed the latest build of Diablo on my N810 last night and it ran fine
for an hour.  I installed and tested the camera app and VPNC and then tried to
use the GPS and after waiting for a long time I descided to power it off and
try to reboot.  It would not power on after leaving it for 10 hours and trying
several attempts at removing the battery and plugging in the charger.  This
device worked perfectly on an older OS/Flash for the first week that I had it.