Bug 2670 - bluetooth keyboard repeat rate control needed
: bluetooth keyboard repeat rate control needed
Status: RESOLVED WONTFIX
Product: Settings and Maintenance
Control panel
: 4.1 (4.2008.23-14)
: All Maemo
: Low enhancement with 8 votes (vote)
: ---
Assigned To: unassigned
: control-panel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-29 16:20 UTC by bobvlm
Modified: 2009-09-28 09:36 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description bobvlm (reporter) 2007-12-29 16:20:33 UTC
Default values for bluetooth keyboard repeat delay & rate often yield severe
typing inaccuracies and can not be easily changed.

See discussion at #2166:  https://bugs.maemo.org/show_bug.cgi?id=2166

In comment #8, Austin Che posts a nice workaround, which (under os2008) does
the job until the keyboard has reconnected a few times.  Each time it
reconnects, it is assigned a new /dev/input/event# -- and since there are only
event0 through event5 in initfs' /dev/input, the workaround stops working once
the keyboard is assigned event6.

Control panel -> bluetooth keyboard could benefit from some repeat rate
controls: sliders/inputs for delay & rate, and perhaps a checkbox to disable it
entirely.
Comment 1 bobvlm (reporter) 2008-01-04 17:01:01 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Andre Klapper maemo.org 2008-10-13 12:33:47 UTC
This would most likely work around the issue reported in bug 2166 (and maybe
bug 3532?) and generally decrease the issues with BT keyboards.
Comment 3 Quim Gil nokia 2008-12-15 08:37:03 UTC
But is this a feature to be implemented in the Control Panel only (a UI
improvement) or is it there anything that should be done at a platform level
(that would imply this enhancement request belong to Platform > Connectivity >
Bluetooth?).
Comment 4 Andre Klapper maemo.org 2009-03-24 15:39:03 UTC
Low priority currently.
Comment 5 Jarmo Lahtiranta 2009-03-24 17:18:02 UTC
That's a shame. For me one of the key advantages of my tablet is that I can
expand it to better fit my needs.

Adding a bluetooth keyboard makes the tablet a perfect tool for taking notes in
meetings because it's small, but I can still write as fast as with any
keyboard. I think that these sort of features should be supported and brought
forward, but I guess that's just me.
Comment 6 bugzilla 2009-09-08 22:53:21 UTC
Jarmo Lahtiranta: you're absolutely right! A bluetooth-keyboard make the Nokia
a perfect laptop-substitute on travels, in meetings and so on.
I would like to see this toppic getting a higher priority cause I think many
people are fighting with this problem.
Meanwhile the workarround mentioned https://bugs.maemo.org/show_bug.cgi?id=2166
 (the .deb-package) works pretty good. But thats for nerds again, a easy
customizable gui is essential to ajust repeat-rate to individual needs.
Comment 7 Quim Gil nokia 2009-09-28 09:36:46 UTC
Bluetooth profiles are not officially supported in Maemo 5, even if they can be
activated through community or thrid party enhancements. See
http://wiki.maemo.org/Fremantle_Unsupported_Bluetooth_profiles

For this reason this enhancement request is resolved as WONTFIX. You are
invited to user the Maemo Brainstorm to push the idea further.
http://maemo.org/community/brainstorm/