Bug 2640 - (int-78952) Can no longer pair bluetooth keyboard after upgrade to OS 2008 with restore
(int-78952)
: Can no longer pair bluetooth keyboard after upgrade to OS 2008 with restore
Status: RESOLVED WONTFIX
Product: Connectivity
Bluetooth
: 4.1.3 (5.2008.43-7)
: N800 other
: Low major with 12 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-22 18:55 UTC by senshi_s
Modified: 2009-06-22 23:32 UTC (History)
16 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description senshi_s (reporter) 2007-12-22 18:55:27 UTC
STEPS TO REPRODUCE THE PROBLEM:
After upgrading to OS2008 and performing a restore, I can no longer pair my
Bluetooth Keyboard. The dialog box for entering the pairing code comes up, and
when I click OK, there is immediately an error code stating pairing failed.
EXPECTED OUTCOME:
There should be time for the pairing code to be entered before a failed dialog
appears
ACTUAL OUTCOME:
pairing failed dialog immediately appears with no time to enter code on
keyboard

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Has been reported by others at internet table talk forum. Also confirmed that
upgrade without restore does not cause this bug and pairing can be completed
Comment 1 Timothy 2007-12-23 10:59:07 UTC
I also have this bug, with 100% recurrence.  When I first flashed my n800 my
thinkoutside would automatically connect, as I had paired it under OS2007. I
got a message each time asking to allow access to the keyboard.  This got
annoying, so I tried to pair the device, but I cannot get this to work due to
this bug. Now my keyboard will not auto connect (due to the failed pairing
attempt).
Comment 2 Johan Hedberg nokia 2007-12-23 13:34:44 UTC
I don't know why the dialog shows only for such a long time, but this issue
will not exist in the future since starting with OS2008 the linkkeys (i.e.
pairings) are also backed up so there will be no need to enter any pin code
after a backup-restore operation.
Comment 3 Johan Hedberg nokia 2007-12-23 13:35:18 UTC
(In reply to comment #2)
> I don't know why the dialog shows only for such a long time, but this issue

And I meant of course "short" and not "long" :)
Comment 4 Guillermo Narváez 2007-12-24 02:37:56 UTC
I too am having this problem while trying to pair either an apple bt keyboard
or a Stowaway. Both of these keyboards worked well with OS2007 and OS2008 beta
(RX-34_2008SE_1.2007.44-4_PR_COMBINED_MR0_ARM.bin). 

I do not have problems pairing with the GPS or with the desktop, it only seems
to affect the keyboards. 

A prompt resolution would be nice (actually, more than "nice" it is what is
expected).
Comment 5 Stefano Z. 2007-12-24 11:16:46 UTC
confirmed also here... Apple wireless keyboard, i was able to pair it only
after many tries.
Comment 6 maemo 2007-12-24 14:16:57 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Neil MacLeod maemo.org 2007-12-24 17:12:12 UTC
I'm not disputing that others are having problems, but I just wanted to say I
had no problem pairing a Think Outside Sierra (the fold-up keyboard) with OS
2008 (2.2007.50-2) on N800.

In my case I installed OS 2008 without restoring a backup, but I then
experienced a problem with the pdflush process (bug 2615) so took a full
backup, re-flashed again with OS 2008 and then restored the backup - this
restored my Phone pairing, and I then went on to pair the keyboard without
incident (I didn't try pairing it the first time I installed OS 2008).
Comment 8 Neil MacLeod maemo.org 2007-12-26 03:04:49 UTC
*** Bug 2654 has been marked as a duplicate of this bug. ***
Comment 9 Panu Puro 2007-12-27 09:18:17 UTC
(In reply to comment #8)

I figured out a workaround for this. It was so annoying without the keyboard I
had to take a look at this.

I just report what worked for me and not recommending this to anybody.

Steps:
1. Added a line with the bluetooth address into /var/lib/bluetooth/.../linkkeys
file. Other three args were just copied from the previous line.
2. Tried to connect now, but that failed. I guess this could be skipped.
3. Deleted the keyboard from the list of the bluetooth devices.
4. Paired the keyboard again, and it worked.

So, I guess that the ui, or system, was out of sync from the flashing and
restoring the backup.
Comment 10 Timothy 2007-12-27 10:17:13 UTC
I can confirm that this method has solved the problem for me (typed on my
keyboard).
Comment 11 Douglas Rausch 2007-12-28 00:03:50 UTC
(In reply to comment #9)
> I can also confirm above procedure. I was able to pair my keyboard after following steps 1, 3 and 4
>
Comment 12 Mika M 2007-12-28 20:14:03 UTC
I had same problems with Apple BT keyboard. But got it working after all. 

OS2008 did find Apple keyboard, but after it did give code (other settings) and
start pairing (at right up corner) it did give error. What did finally help was
that when pairing text was at upcorner, I did enter code with BT keyboard and
press enter many times. Pairing did work. Even it looked that nothing happend
when I did press keyboard keys. Enter code with keyboard and press enter
manytimes. When pairing text is at right upcorner.
Comment 13 Tony Thomas 2008-01-03 19:04:18 UTC
I had the pairing problem with the iGo Stowaway UltraSlim and the aluminum
Apple BT keyboard. The only solution I found that works is to downgrade to the
OS2008 beta and all seems to be well.

The thing is, all I restored after reflashing was bookmarks and application
list. Other than that, it was clean install. I still couldn't get pairing
working with version 2.2007.50-2. Pairing worked perfectly with version
1.2007.50-2. Anybody else up to testing this?
Comment 14 Mike Hoye 2008-01-03 19:05:48 UTC
I've had the same pairing-after-a-restore problem that other people here have
described, specifically the immediate "pairing failed" error you get trying to
pair a BT keyboard. It's fixable without downgrading or reflashing, but you've
got to get root access and be comfortable using vi (or any other in-terminal
text editor) to do it.

The trick seems to be that after restoring, /var/lib/bluetooth/-your bt mac
address-/ is populated with your old pairing data. I've fixed the problem by
opening each of the files in that directory in turn and deleting any line that
references my keyboard's mac address. Also, if they're there, any empty blank
lines at the beginning of the file.

Log out, power down and restart the n800. Now the pairing process should work
as advertised, allowing you time to type in a pairing code.

I suspect, though I have no proof, that the problem is that the restore process
adds a blank line to the beginning of several of the bluetooth configuration
files, breaking their parser in some unexpected way.
Comment 15 Tony Thomas 2008-01-04 05:04:25 UTC
See correction to original post and update below:

(In reply to comment #13)
> I had the pairing problem with the iGo Stowaway UltraSlim and the aluminum
> Apple BT keyboard. The only solution I found that works is to downgrade to the
> OS2008 beta and all seems to be well.
> 
> The thing is, all I restored after reflashing was bookmarks and application
> list. Other than that, it was clean install. I still couldn't get pairing
> working with version 2.2007.50-2. Pairing worked perfectly with version
> 1.2007.44-4. (beta). Anybody else up to testing this?
> 
Update: After successfully pairing using 1.2007.44-4. (beta), I upgraded to
2.2007.50-2 and restored settings, bookmarks and applications lists.  Pairing
now works under 2.2007.50-2.
Comment 16 Toby Knudsen 2008-01-08 07:44:13 UTC
(In reply to comment #9)
Thank you, Panu.  I'll keep trying.

I was so happy when my Nokia paired with the Apple BT keyboard and the Apple
Store geeks admired my N800 and were very helpful (but I only run Linux and
BSD).  When I think about this bug I begin to twitch uncontrollably.  I also
own a StowAway keyboard.

Please contact me regarding any testing of the N800.  I'll sign up for the
test/dev list.  Somehow, I feel like this bug is karmically my fault.  I'm
sorry I didn't help with testing sooner!!

Cheers,
Toby
Comment 17 Christian Blessing 2008-01-09 12:28:28 UTC
I have tried all of the suggestions here, to no avail. I note that in Panu
Puro's comment #9 that he references a "linkkeys" file in
/var/lib/bluetooth/~mac address directory. I don't see that file. I have
removed the MAC from the other files, but no dice.
Comment 18 robert boucher 2008-01-10 00:00:45 UTC
(In reply to comment #14)
I have one of the new Apple BT keyboard, and this approach did not work for me.

In my case, I need to boot the N800 with a root OS2008Beta filesystem -- pair
the keyboard, save the content of the /var/lib/bluetooth/<your:bt:mac:address>/
folder.  Reboot with a root OS2008 filesystem and copy the files over.

Robert B.
Comment 19 Tony Thomas 2008-01-10 07:14:20 UTC
Another strange twist....

I have been using the N800 successfully for the last few days with no problems
with both the Apple Bluetooth Keyboard and the Think Outside Stowaway.

Tonight, I went to use the Stowaway again and it was recognized by the N800 but
would not work.  I decided to try deleting the profile and try pairing the
keyboard.  No dice.  I could not get pairing to work.  

Then, I tried the same thing with the Apple Bluetooth keyboard.  At first, I
had problems but I tried shutting down the unit.  After turning it back on, I
was able to pair it with the N800 with no problem.  However, I am not able to
pair the Stowaway no matter what I try.  The system does not give me time to
enter the code.  It goes straight to "pairing failed - try again".
Comment 20 Christian Blessing 2008-01-10 08:18:28 UTC
Addendum to comment 17...(pairing Think Outside Stowaway)

After numerous attempts at pairing, following comment # 9 suggestions, I
finally met success by leaving the MAC in place and just removing the empty
lines above. Previously I had deleted all lines of all other files, but after
each attempted pairing the MAC plus 3 empty lines appeared in all but the hidd
and classes files.

I should note that I currently have the following files in my
/var/lib/bluetooth/00... directory: classes, config, features, names, lastused,
lastseen, hidd and trusts. The trusts file was only created after a successful
pairing. I'm guessing it is the reason that the keyboard is recognized without
re-pairing each time.

It would be interesting if those who can successfully pair but must pair for
each session could create the trust file. The contents are just the MAC
followed by [all].
Comment 21 Sean Luke 2008-01-13 01:09:25 UTC
I had a much simpler approach to fixing the problem:  I simply moved away the
/var/lib/bluetooth/<your:bt:mac:address>/  folder.  Then when repairing with
the keyboard, the bluetooth driver rebuilt the missing folder fresh and clean. 
Seems to have worked fine.
Comment 22 Tony Thomas 2008-01-13 02:31:23 UTC
(In reply to comment #21)
> I had a much simpler approach to fixing the problem:  I simply moved away the
> /var/lib/bluetooth/<your:bt:mac:address>/  folder.  Then when repairing with
> the keyboard, the bluetooth driver rebuilt the missing folder fresh and clean. 
> Seems to have worked fine.
> 
That seems to imply that you can just delete that folder without any negative
repercussions.  In that case, a script file can be created to delete that
directory and used when needed.
Comment 23 Christian Blessing 2008-01-13 08:18:36 UTC
(In reply to comment #21) and follow up to #20

I just updated my wife's new n800 to os2008 and encountered the same issues. No
backup was restored. I first used the approach offered by #21 but still found
that when the files were (re)created if there was an extra line above the MAC
entry pairing wouldn't occur. This time, I made a note of the contents of each
file and found that there seemed no pattern to when the line was added. The
first pairing attempt adds all the files. I checked the contents of each file
for the entry and everything looked in order. Only after several more
unsuccessful attempts did I find a file with the added line. Once having
removed the line, in this case from the "features" file, I was able to
successfully pair, with no further issue. This has proven to be the case for me
on two N800s.
Comment 24 Dafydd Gibbon 2008-01-27 16:16:32 UTC
(In reply to comment #21)
> I had a much simpler approach to fixing the problem:  I simply moved away the
> /var/lib/bluetooth/<your:bt:mac:address>/  folder.  Then when repairing with
> the keyboard, the bluetooth driver rebuilt the missing folder fresh and clean. 
> Seems to have worked fine.

This method worked fine for me. Thanks! But I don't see how a non-Linux-aware
user could solve the problem.
Comment 25 Roope Rainisto nokia 2008-01-28 10:44:54 UTC
Adding CC.
Comment 26 garys 2008-02-01 09:42:51 UTC
I am having the same issue with an Apple bt keyboard after upgrading to OS2008.
I tried the suggestion of comment #21 but that did not work. I've looked
through all the files and don't see any spaces before lines. 

I did notice that if I click on the bluetooth icon in the status bar it says
"Disconnect Apple wireless keyboard" even though the keyboard is not paired?

My free time to play with this is limited at the moment - I'm contemplating
reverting to an earlier version of the OS.
Comment 27 Christian Blessing 2008-02-01 11:12:38 UTC
(In reply to comment #26)
> I am having the same issue with an Apple bt keyboard after upgrading to OS2008.
> I tried the suggestion of comment #21 but that did not work. I've looked
> through all the files and don't see any spaces before lines. 
> 
> I did notice that if I click on the bluetooth icon in the status bar it says
> "Disconnect Apple wireless keyboard" even though the keyboard is not paired?
> 
> My free time to play with this is limited at the moment - I'm contemplating
> reverting to an earlier version of the OS.

Please look at posts 20 and 23. I also tried the suggestion in comment 21 but
found that when the folder was re-created with its enclosed files, the problem
persisted. Only after systematically going through each file and watching for
the added blank line, and deleting it when I found it, did I have success. Keep
in mind that it may take several attempts at pairing before the file(s) in
question are modified with the added line, but I believe you will find it. As I
noted in post 23, I did this on two different N800s and two BT keyboards, and
the solution worked. Additionally I did it to my N800 after two re-flashes to
OS2008. Now the keyboard is always recognized within seconds of being opened.

I know this approach is time-consuming and frustrating, but it has worked for
me. Perhaps if anyone else has tried this approach they can post their results.

Chris
Comment 28 garys 2008-02-01 16:59:03 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > I am having the same issue with an Apple bt keyboard after upgrading to OS2008.
> > I tried the suggestion of comment #21 but that did not work. I've looked
> > through all the files and don't see any spaces before lines. 
> > 
> > I did notice that if I click on the bluetooth icon in the status bar it says
> > "Disconnect Apple wireless keyboard" even though the keyboard is not paired?
> > 
> > My free time to play with this is limited at the moment - I'm contemplating
> > reverting to an earlier version of the OS.
> 
> Please look at posts 20 and 23. I also tried the suggestion in comment 21 but
> found that when the folder was re-created with its enclosed files, the problem
> persisted. Only after systematically going through each file and watching for
> the added blank line, and deleting it when I found it, did I have success. Keep
> in mind that it may take several attempts at pairing before the file(s) in
> question are modified with the added line, but I believe you will find it. As I
> noted in post 23, I did this on two different N800s and two BT keyboards, and
> the solution worked. Additionally I did it to my N800 after two re-flashes to
> OS2008. Now the keyboard is always recognized within seconds of being opened.
> 
> I know this approach is time-consuming and frustrating, but it has worked for
> me. Perhaps if anyone else has tried this approach they can post their results.
> 
> Chris
> 

Christian,

Many thanks for your reply. I have tried the approach you mentioned. In
addition to #21 I deleted all references to the MAC from the files, tried
pairing, subsequently deleted blank lines (in every file that contained the MAC
address) and still no success. It was clear to me that this whole affair is hit
and miss from the reports here and so I invested several hours before posting.
I'm curious as to your definition of persevere ;-)
I apologise that when I said no free time in my last post I should have made it
clear that it was because I had already consumed several hours of it!
Comment 29 garys 2008-02-03 09:38:49 UTC
(In reply to comment #28)
I finally resolved this issue for myself. After repeated attempts at pairing I
finally pulled the battery from the N800 and waited a few minutes before
putting it back in. After which pairing occured smoothly and without issue. No
editing of files or any of the suggestions here were required.

Gary
Comment 30 John 2008-02-09 06:47:32 UTC
(In reply to comment #29)
> (In reply to comment #28)
> I finally resolved this issue for myself. After repeated attempts at pairing I
> finally pulled the battery from the N800 and waited a few minutes before
> putting it back in. After which pairing occured smoothly and without issue. No
> editing of files or any of the suggestions here were required.
> 
> Gary
> 
As a non-techie user I appreciated this suggestion.  It has failed to work for
me.  Any detailed suggestions appreciated.  I've stopped using the N800 and I'm
so sad.  I will eventually revert to the 2007 if something doesn't happen here.
 Shouldn't this be a no-brainer for the Nokia programmers?  Is it a matter of
priority?  Is there a link to info on the steps required to edit the files
mentioned in the previous suggestions?  I don't find them with the file
manager.

Thanks all,

John
Comment 31 garys 2008-02-09 17:42:08 UTC
John,
You can not get at these files through filemanager you have to do it through
the underlying Linux operating system. In order to do that you need to install
some tools - an X terminal, ssh and an editor such as Vim. I hope you have some
idea as to what these tools are - I (or perhaps someone else) will post step by
step instructions later but I have to run out the door for a wireless free
location.

Gary
Comment 32 jdm 2008-02-12 07:25:48 UTC
I am new to linux, and to nokia.

The BT keyboard pair procedure finds the BT keyboard (new Stowaway Sierra, not
otherwise tested) but cannot pair to it. I think I've tried all the workarounds
already mentioned; none have helped. At no point did any of the bt config files
have any blank lines in them.

First I renamed the <bt mac address> folder and tried to pair, no improvement;
it just recreated the same config files which still did not work.

The trusts and linkkeys files did not exist, presumably because I had still
paired no BT devices.

So then I paired a Treo 680 as a BT modem, at which point the two missing files
came into existence, and the other 6 files added one extra line each for the BT
modem.

Then I added a line for the BT keyboard to each of the trusts and linkkeys
files, copying from the line already there for the PDA. I was quite dubious
about adding the line to the linkkeys file, since one of the tokens which I
copied was some 32-digit hex key, and it's hard to imagine that it should
actually be the same for the PDA as for the keyboard, but that is what #9 said
worked.

After I did this, the system acted as though the kbd was paired (it showed up
in the list of BT devices, as a trusted keyboard. But typing on the keyboard
(for example in Xterm or Note) produces nothing.

I then tried removing the part of the line in linkkeys after the Kbd mac, but
then I was back to square one... could not pair.

Can anyone offer any other suggestions?

FWIW, this seems unconscionable to me. Support for a BT kbd is a core consumer
function for a device without a keyboard, not some esoteric add-on! And it is
advertised as available.
Comment 33 jdm 2008-02-12 08:20:20 UTC
(In reply to comment #32)

In standard noob fashion, I wrote too quickly (though after hours of struggle).
I tried again with another blank slate (i.e. after again renaming the BT MAC
directory), this time paying more attention to the timing of typing in the
passkey, and lo, it worked! 

So my vote for the easiest solution is with comment #21.
Comment 34 Ryan Abel maemo.org 2008-02-26 02:53:47 UTC
*** Bug 2980 has been marked as a duplicate of this bug. ***
Comment 35 Andre Klapper maemo.org 2008-07-01 15:08:14 UTC
Maybe bug 3359 is another duplicate of this.
Comment 36 a.meinusch 2008-07-01 16:02:50 UTC
I had this bug too.
My Solution is:
Start xterm
$ cd /var/lib/bluetooth/XX:XX..XX:XX/
$ grep SU-8W names
then delete in all files entrys (I mean lines) with bid XX:XX:XX:XX:XX of your
keyboard. Don't delete files. It's not necessary.
Pair again ... :)
Comment 37 manager 2008-07-05 01:18:17 UTC
(In reply to comment #36)
> I had this bug too.
> My Solution is:
> Start xterm
> $ cd /var/lib/bluetooth/XX:XX..XX:XX/
> $ grep SU-8W names
> then delete in all files entrys (I mean lines) with bid XX:XX:XX:XX:XX of your
> keyboard. Don't delete files. It's not necessary.
> Pair again ... :)
> 
For a Linux newbie like me can you explain what is the XX:XX..XX:XX/ stand for?
I've manage to get in xterm to the cd /var/lib/bluetooth directory but once
there I can get any list or dir command.

A step by step would be much appreciated
Comment 38 Andre Klapper maemo.org 2008-07-05 01:37:39 UTC
(In reply to comment #37)
> > $ cd /var/lib/bluetooth/XX:XX..XX:XX/
> > $ grep SU-8W names
> > 
> For a Linux newbie like me can you explain what is the XX:XX..XX:XX/ stand for?
> I've manage to get in xterm to the cd /var/lib/bluetooth directory but once
> there I can get any list or dir command.

"dir" is "ls" under linux. XX:XX is probably an identifier or MAC address or
whatever, X is just a placeholder for any number or letter.
Comment 39 Andre Klapper maemo.org 2008-08-08 12:50:13 UTC
Forwarding a comment from the internal ticket:
"This bug affects the restoration of backups created with Bora. In other words,
if it were to be fixed for Fremantle, the only people it would benefit would be
those who have completely skipped the Chinook release and are going directly
from Bora to Fremantle. With this in mind I don't think the bug should be
considered as critical as it is now."

There is also a workaround mentioned in comment 21, hence lower priority.

I assume this might become a WONTFIX later.
Comment 40 Ryan Abel maemo.org 2008-09-14 16:02:47 UTC
*** Bug 3709 has been marked as a duplicate of this bug. ***
Comment 41 David Mann 2008-09-15 01:27:24 UTC
(In reply to comment #40)
> *** Bug 3709 has been marked as a duplicate of this bug. ***
>

Still not sure if 3709 is the same problem or not, but these are the steps I
took to (hopefully) resolve the issue.
Worked through all the suggestions above.
A) Full powerdown and reboot: failed
B) Delete /var/lib/bluetooth: failed
C) Check all /var/lib/bluetooth/<macid>/ files for erroneous newlines: failed

Tested bluetooth pairing on 2008.51-3 (clean install).  Sync failure
Tested bluetooth pairing on 2008.50-2 (clean install).  Sync failure
Tested bluetooth pairing on 2008.44-4 (clean install).  Sync successfully
completed

Perform backup on 2008.44-4.  Install Diablo 2008.23-14.  Restore backup.  N800
shows keyboard in bluetooth paired list but still fails to connect.  Reboot
N800: keyboard works!
Comment 42 Andre Klapper maemo.org 2008-11-18 19:29:10 UTC
A few people in here have commented that they have an Apple Wireless keyboard.
Can someone of you running the latest software (4.2008.36-5) please try to
reproduce bug 3358 and add a comment in bug 3358
 - whether the Modest (Email) menu also disappears,
 - about the exact model and firmware of the keyboard,
 - whether it's about an N800 or N810.

Thanks a lot in advance!
Comment 43 ubIx 2008-12-24 00:00:04 UTC
I've the same problem after a reconnect of my Bluetooth Keyboard "Stowaway
Ultra-Slim Keyboard (iGo ANYCOM)" after a reconnect after a buttery change. I
use it on my N800 since OS2007 without any problems including pairing. OK,
sometimes only with the not exact keymapping - not with functional things.
Comment 44 ubIx 2008-12-24 00:07:30 UTC
OK, I forgot, that I use the newest DIABLO 5.2008.43-7 build.
Comment 45 Andre Klapper maemo.org 2009-06-22 23:32:35 UTC
So, let's give some realistic feedback here: WONTFIX. :-/

This is a OS2008 (Maemo4) specific issue.
It will not happen in Maemo5 (Fremantle).

Unfortunately it is a WONTFIX for Diablo (as I expected in comment 39, sigh) as
Diablo is in maintenance mode and Nokia will only provide bugfixes for critical
issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.

A workaround for Chinook/Diablo is mentioned in comment 21.