Bug 2632 - Chinook SDK download is broken
: Chinook SDK download is broken
Status: RESOLVED FIXED
Product: maemo.org Website
Repositories
: 4.0
: All Linux
: High normal (vote)
: ---
Assigned To: unassigned
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-22 05:59 UTC by Gene Cash
Modified: 2008-01-02 00:25 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Gene Cash (reporter) 2007-12-22 05:59:44 UTC
STEPS TO REPRODUCE THE PROBLEM:

Run maemo-sdk-install_4.0.sh as described in the Chinook SDK README

EXPECTED OUTCOME:

SDK downloads and installs.

ACTUAL OUTCOME:

It looks like it's successfully fetching the .deb files, but then reports
errors of the form: "Failed to fetch
http://repository.maemo.org/pool/maemo4.0/free/d/db4.2/libdb4.2_4.2.52-18osso_i386.deb
 Size mismatch" for most of the files. (Obviously the filename/path will be
different for each file)

It only takes 5 minutes to fetch all the files over my broadband connection.

When I look at any of the listed .deb files, it actually contains:
<html>
 <head>
  <title>index page</title>
 </head>
 <body>
  <center><h2>The service is temporarily unavailable. We are very sorry for the
inconvinience it may cause.</h2></center>
 </body>
</html>

This happens for both the ARMEL and X86 targets.

(Also, you'll notice the error is misspelled, but this is not an important
issue)

There is no outage message that I can find on maemo.org, downloads.maemo.org,
or maemo.org/development.

REPRODUCIBILITY:
(always/sometimes/once)

Always. I've been trying all day today (21-DEC-2007) to do the SDK install.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I believe this is a duplicate bug, but I tried quite a few searches and didn't
turn up anything.

If the server is down, there needs to be some sort of outage notice. It also
looks like the server is giving an inappropriate success code for the error
message.
Comment 1 Petteri Kettunen nokia 2007-12-27 07:07:24 UTC
Confirmed on 26 Dec 2007.

Running apt-get update on 'CHINOOK_ARMEL'.
Ign http://repository.maemo.org chinook Release.gpg
Get:1 http://repository.maemo.org chinook Release [218B]
Get:2 http://repository.maemo.org chinook/free Packages [134kB]
Get:3 http://repository.maemo.org chinook/non-free Packages [604B]             
Get:4 http://repository.maemo.org chinook/free Sources [199B]                  
99% [4 Sources gzip 0]                                               4109B/s 0s
gzip: stdin: not in gzip format
Err http://repository.maemo.org chinook/free Sources                           
  Sub-process gzip returned an error code (1)
Fetched 135kB in 12s (10.4kB/s)                                                
Failed to fetch
http://repository.maemo.org/dists/chinook/free/source/Sources.gz  Sub-process
gzip returned an error code (1)
Reading package lists... Done
E: Some index files failed to download, they have been ignored, or old ones
used instead.
E: Unable to run 'apt-get update' on the target.
E: Please correct any network problems.
E: Scratchbox login returned error 100.

The installation process was unable to run 'apt-get update' inside
the installed targets in order to update the local package database.
This could be due to an error in network configuration inside scratchbox.
Common causes are incorrect proxy       settings and the 'hosts' line in
/scratchbox/etc/nsswitch.conf.
For the 'hosts' line in /scratchbox/etc/nsswitch.conf the following
should usually be enough:
hosts:          files dns

Once network issues have been resolved, you should run the installer again.

lynx -source http://repository.maemo.org/dists/chinook/free/source/Sources.gz
<html>
 <head>
  <title>index page</title>
 </head>
 <body>
  <center><h2>The service is temporarily unavailable. We are very sorry for the
inconvinience it may cause.</h2></center>
 </body>
</html>
Comment 2 pgruebele 2007-12-28 00:47:37 UTC
I have the same problem.  I tried many times and always get the same results...
Comment 3 Mike Nelson 2007-12-28 19:34:22 UTC
I've been getting this for the last few days. It's usually different files.
Sometimes .deb files but most often it's a Sources.gz file.
Comment 4 Mike Nelson 2007-12-28 19:35:13 UTC
Right now it's http://repository.maemo.org/dists/chinook/free/source/Sources.gz
that is the problem.
Comment 5 Mike Nelson 2007-12-29 16:53:17 UTC
(In reply to comment #4)
> Right now it's http://repository.maemo.org/dists/chinook/free/source/Sources.gz
> that is the problem.
> 
Used Rob's magic incantation patch
https://bugs.maemo.org/attachment.cgi?id=685&action=edit to fix this
temporarily.
Comment 6 pgruebele 2007-12-29 23:42:43 UTC
i did not try this, but i create a host entry which made repository.maemo.org
resolve to the same address as repostory.maemo.org and the sdk install still
failed the same way.  so, i dont see how the post above mine would work.
Comment 7 Mike Nelson 2008-01-01 17:18:23 UTC
(In reply to comment #6)
> i did not try this, but i create a host entry which made repository.maemo.org
> resolve to the same address as repostory.maemo.org and the sdk install still
> failed the same way.  so, i dont see how the post above mine would work.
> 

That's a good idea about the host entry. I didn't try that myself so I don't
know if that works, but I'd think that it would. Did it get into your
scratchbox environment (/scratchbox/etc/hosts) as well? You might try the ip
address for stage.maemo.org.
Comment 8 pgruebele 2008-01-01 19:49:40 UTC
i did not try 'stage' and it did not work so i gave up on installing the sdk.  
i downloaded the vmware virtual machine instead.  it has the sdk preinstalled.
Comment 9 Gene Cash (reporter) 2008-01-02 00:25:38 UTC
I fetched a new copy of
http://tablets-dev.nokia.com/4.0/maemo-sdk-install_4.0.sh and it worked! The
SDK installed just fine w/o any issues at all.