Bug 2624 - Keys with type slide don't work in stylus virtual keyboard
: Keys with type slide don't work in stylus virtual keyboard
Status: RESOLVED FIXED
Product: Desktop platform
Internationalization
: unspecified
: N800 Linux
: High normal (vote)
: ---
Assigned To: unassigned
: user-interaction-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-21 22:31 UTC by mikmach
Modified: 2008-12-06 18:32 UTC (History)
3 users (show)

See Also:


Attachments
Virtual keyboard layout file (1.51 KB, application/octet-stream)
2007-12-21 22:31 UTC, mikmach
Details
XML version of vkb file (16.23 KB, text/xml)
2007-12-21 22:32 UTC, mikmach
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mikmach (reporter) 2007-12-21 22:31:17 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. Create vkb file with types of slide in normal (aka stylus) keyboard
2. Example to download from: http://www.witkacy.hg.pl/vkb/pl_PL.vkb ,
http://www.witkacy.hg.pl/vkb/pl_PL.vkb
3. Install it in /usr/share/keyboards
4. Change layout of virtual keyboard to Polski
5. Activate stylus keyboard
6. tap 'a', it will change its label to 'ą' (aogonek).
7. Instead of waiting for second tap or finally insert single 'a' it inserts
'aa', after second tap it inserts 'aąą' (a-aogonek-agonek)

EXPECTED OUTCOME:
Insert single 'a' or 'ą' (aogonek)

ACTUAL OUTCOME:
Inserts 'aa' or 'aąą'. This apply to all other keys: eoaslzxcn.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Fixing this or adding good documentation for modifier (AltGr) or multiply type
keys is critical for creation of good virtual keyboards for Central European
languages.
Comment 1 mikmach (reporter) 2007-12-21 22:31:59 UTC
Created an attachment (id=678) [details]
Virtual keyboard layout file
Comment 2 mikmach (reporter) 2007-12-21 22:32:35 UTC
Created an attachment (id=679) [details]
XML version of vkb file
Comment 3 Roope Rainisto nokia 2008-01-02 10:08:51 UTC
Adding CC's.
Comment 4 Andre Klapper maemo.org 2008-06-16 18:02:49 UTC
Mikmach: So this is basically a request for better documentation on how to
create VKBs, or how to wrokaround the issues you have run into?
I wonder if other contributed VKBs, e.g. Czech, have the same issues.
Comment 5 mikmach (reporter) 2008-06-16 20:56:09 UTC
I am expecting it to be fixed: there is no mention in docs about slides not
working in virtual keyboard mode so it should work there.

I mentioned about AltGr because it is more natural way of inserting diacritics.
Comment 6 Andre Klapper maemo.org 2008-06-20 13:31:31 UTC
Closing as fixed as per last comment (not setting target milestone). Please do
reopen this ticket if you still face those problems. Thanks!
Comment 7 Łukasz Derkacz 2008-08-20 11:36:36 UTC
What else is needed to have this pl_PL keyboard working?
I've installed locale-polish and the vkb key but still can't select Polish
keyboard in the layout.