Bug 2597 - No stylus keyboard when restoring N810 backup on N800
: No stylus keyboard when restoring N810 backup on N800
Status: RESOLVED WORKSFORME
Product: Desktop platform
Virtual keyboard (halfscreen)
: unspecified
: All Windows
: Medium normal with 1 vote (vote)
: ---
Assigned To: unassigned
: vkb-bugs
: http://www.maemoapps.com/2007/12/19/n...
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-12-19 20:39 UTC by Jonathan Greene
Modified: 2008-12-04 16:23 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jonathan Greene (reporter) 2007-12-19 20:39:01 UTC
I don't have access at all to the stylus keyboard on my N800 in OS2008.  It is
not an option I can enable ... As noted at the URL above.

The thumbboard also does not activate all the time so text entry can become
impossible.  Resets / reboots do fix this though the problem seems to creep
back.

I had noted this in the beta / developer release and thought it would be fixed
for the release version, but seems to have made it through.

I'm also not seeing the predictive text for words I am typing with the
thumbboard and believe it to be related.
Comment 1 Ryan Abel maemo.org 2007-12-19 21:20:46 UTC
I'm not sure what issue you're actually describing. Any steps to reproduce? All
4 input methods work fine for me over here (vkb/stylus keyboard, thumbboard,
handwriting, and Bluetooth keyboard).
Comment 2 Jonathan Greene (reporter) 2007-12-19 21:50:44 UTC
I have NO stylus input.
Thumbboard does not activate 100% of the time by tap or use of the D-Pad.
At times, the thumbboard refuses to activate at all - requiring a reset to fix.

I do not see suggested words when typing - at all.
Comment 3 Jonathan Greene (reporter) 2007-12-19 22:40:55 UTC
I had auto-complete off.  It's on and works.  My bad.

The other details still stand as not working.
Comment 4 Ryan Abel maemo.org 2007-12-19 23:16:24 UTC
Odd. Did you restore a backup when you flashed?
Comment 5 Jonathan Greene (reporter) 2007-12-19 23:18:23 UTC
I did.  Thinking that's the issue.  But can't confirm until tonight when I can
re-flash.

I had an N810 pre-production model which I backed up and restored on the N800
when that was updated to OS2008.  Perhaps that's the issue ... not sure what
was different at the time I initially did that, but I thought the two devices
were in sync now.
Comment 6 Aniello Del Sorbo 2007-12-20 13:47:51 UTC
I am piping stuff up: the finger keyboard (aka thumbboard) does not appear when
finger-tapping a text entry box.
The Text Input Settings->Launch finger keyboard with finger tap, is active.

Rebooting, reflashing, cleaning the device did not help at all.

I am posting it here as I've also commented it on the same post (URL above) on
Jonathan's blog.
I also posted some more info on the MaemoUI blog at this post:
http://maemointeraction.wordpress.com/2007/12/19/improving-text-input-n810-with-its-hardware-keyboard/

Also other people on the Internet Tablet forum describe this very same issue:

http://www.internettablettalk.com/forums/showthread.php?p=110251#post110251
Comment 7 Jonathan Greene (reporter) 2007-12-20 16:22:19 UTC
I can confirm that a restore is causing the issue.  There was no mention of
this problem from beta to current release and there are quite a few people who
were doing the same ... 

I've been able to restore my bookmarks and app listing, but am afraid if I add
more from the restore I'll hit the corruption and have to start again - which
I've already done three times now.
Comment 8 Mohammad Anwari maemo.org 2007-12-21 11:47:51 UTC
The problem is you restore the N800 backup to a N810 device. Yes this kind of
thing shall be fixed.

Try this as a workaround in xterm:
gconftool-2 -t bool -s /apps/osso/inputmethod/enable-stylus-im TRUE
Comment 9 Tomas Junnonen nokia 2007-12-21 12:26:01 UTC
(In reply to comment #8)
> The problem is you restore the N800 backup to a N810 device. Yes this kind of
> thing shall be fixed.

The problem is actually only happening the other way around, when restoring
from N810 to N800. N800 to N810 works OK as that is the logical progression.

The thumb keyboard being hard to launch is an entirely different issue related
to the touch screen.
Comment 10 Jonathan Greene (reporter) 2007-12-21 16:28:44 UTC
actually -- the other way.  N810 to N800 ...
Comment 11 Eero Tamminen nokia 2007-12-21 16:40:19 UTC
(In reply to comment #10)
> actually -- the other way.  N810 to N800 ...

Does changing this either to TRUE or FALSE help also in that case:
  gconftool-2 -t bool -s /apps/osso/inputmethod/enable-stylus-im TRUE
?
Comment 12 Jonathan Greene (reporter) 2007-12-21 16:59:11 UTC
I am unable to flash and restore from work ... will have to try and test later,
though I've been happily restoring my device for the past day+ and not really
looking forward to starting again.  Though it would be nice to confirm the fix
...  all in the name of community!
Comment 13 Andre Klapper maemo.org 2008-06-13 16:49:17 UTC
Jonathan, any news to update comment #11 here?
Comment 14 Jonathan Greene (reporter) 2008-06-13 16:55:46 UTC
I am sorry to say I can't recall... I ended up starting fresh which easily
fixed the problem.
Comment 15 Andre Klapper maemo.org 2008-06-13 17:41:08 UTC
Ah, OK.
Anybody else (Aniello) able to answer this?
Comment 16 Andre Klapper maemo.org 2008-12-04 16:23:00 UTC
No answer to Comment 11 for more than half a year - closing as WORKSFORME.

Please reopen when providing the requested info.