Bug 2583 - (ShowAccounts) Show all accounts in the folder view
(ShowAccounts)
: Show all accounts in the folder view
Status: RESOLVED WONTFIX
Product: Email
General
: 5.0-beta
: All Linux
: Low enhancement with 8 votes (vote)
: ---
Assigned To: modest-bugs
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-17 21:26 UTC by Walther
Modified: 2012-03-24 11:45 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Walther (reporter) 2007-12-17 21:26:38 UTC
I expected to see all my IMAP accounts in the sidepane of the folder view (like
Evolution does it). Instead, I need to go into the menu to switch accounts.

Showing all accounts in the folder view would help me to see in one glance how
many e-mails I have and in which accounts. It would also help me to switch
between accounts quickly.
Comment 1 Ryan Abel maemo.org 2008-06-26 16:19:48 UTC
*** Bug 3294 has been marked as a duplicate of this bug. ***
Comment 2 Sergio Villar Senin 2009-05-22 10:05:33 UTC
This is not valid for Fremantle as the UI is totally different.

In Fremantle you'll have

Accounts window -> Folders window -> Mails window

So once you select a folder in the first window, you'll be redirected to a
second window with only the folders of that account.

There is no sidepane at all
Comment 3 Quim Gil nokia 2009-05-22 10:36:17 UTC
Thanks Sergio,

Still is this possible in Fremantle?

> see in one glance how many e-mails I have and in which accounts

It is unclear (to me) whether this is possible with the current versio of
Modest in Fremantle.
Comment 4 Sergio Villar Senin 2009-05-22 10:48:02 UTC
(In reply to comment #3)
> Thanks Sergio,
> 
> Still is this possible in Fremantle?
> 
> > see in one glance how many e-mails I have and in which accounts
> 
> It is unclear (to me) whether this is possible with the current versio of
> Modest in Fremantle.

As I said, Quim, it's not possible because of the window flow. You click on an
account and you see the folders of that account. I wouldn't make sense to show
the folders of all accounts when you had previously selected one.
Comment 5 Quim Gil nokia 2009-05-22 10:54:19 UTC
The request is not about seeing how many emails are pending in each FOLDER but
in each ACCOUNT. 

The default screen of Modest has the account view but at least in the current
version it shows only "Last updated" for every account. There is plenty of
space there and it would be useful to see how many pending emails are there in
each account. Otherwise the user needs to go to each and check.
Comment 6 Sergio Villar Senin 2009-05-22 10:57:46 UTC
Ah, I understand. Well that could be done, but it'd imply starting a connection
for each account to check that, and will slow the startup of Modest
significantly...

Anyway we could take a look at other possibilities
Comment 7 Quim Gil nokia 2009-05-22 11:02:23 UTC
You can start showing the last values cached not to delay the startup if the
user wants to go somewhere, and then update the values as soon as they are
available. This still saves significant time to the user compared to visit the
accounts one by one.

Also normally what happens is that Modest sends you notifications of new emails
received because is still running in the background, so I guess there is a way
to have those values quite up to date.
Comment 8 Andre Klapper maemo.org 2012-03-24 11:45:46 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )