Bug 2573 - (int-85654) Navigating between IMAP folders lands on random message
(int-85654)
: Navigating between IMAP folders lands on random message
Status: RESOLVED FIXED
Product: Email
General
: 4.0
: N800 Maemo
: Low enhancement with 1 vote (vote)
: 4.1.3
Assigned To: modest-bugs
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-17 11:53 UTC by Martin Lucina
Modified: 2008-12-22 21:55 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Martin Lucina (reporter) 2007-12-17 11:53:00 UTC
STEPS TO REPRODUCE THE PROBLEM:
- Create an IMAP account in Modest with more than one subfolder and many
messages (I have at least 500 in each subfolder)
- Modest set to retrieve headers only, no retrieve limit
- Navigate between folders (e.g. tap on Inbox, then on a subfolder with some
messages, then back to Inbox)

EXPECTED OUTCOME:
Modest retrieves all headers in folder, and when navigating between folders the
same message according to sort order is shown

ACTUAL OUTCOME:
Status bar shows retrieving (sometimes) even though no change to folder
Initial message shown in message list is random, although all messages are
eventually downloaded at which point the scroll bar in the message list
reflects this (i.e. moves to show actual position in folder)

REPRODUCIBILITY:
Sometimes (Most of the time)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Modest 1.0-2007.51-1
Using IMAP4S against Dovecot 1.0.7
Comment 1 Martin Lucina (reporter) 2007-12-17 12:23:30 UTC
Why has this been tagged as 'enhancement'? It makes the UI unpredictable since
you have to keep scrolling back to the top of the folder when you navigate
between folders.
Comment 2 Matt Johnston 2008-08-18 05:12:11 UTC
It's not only when switching between folders - the current view position isn't
preserved when you hide/show the list of folders on the left hand side (using
the toolbar button).
Comment 3 Quim Gil nokia 2008-12-17 18:19:39 UTC
I´m also wondering whether this is a bug or an enhancement...
Comment 4 Andre Klapper maemo.org 2008-12-17 18:47:04 UTC
> the current view position isn't preserved when you hide/show the list of 
> folders on the left hand side (using the toolbar button).

I've never seen this myself.
Even with IMAP folders I've never entered before with Modest the focus is set
to the top message here.
Comment 5 Daniel Martin Yerga 2008-12-17 19:30:44 UTC
Definitively it *was* a bug, not very important but an annoying one.
(Un)fortunately I can't reproduce  with the last update.

Martin could you try it with the last update (5.2008.43-7)?
Comment 6 Daniel Martin Yerga 2008-12-17 20:18:24 UTC
This bug was fixed in Modest 1.0-2008.43-1

The new code is in src/widgets/modest-header-view.c, in function
modest_header_view_on_expose_event


Possibly this fix is one of the following fixes in the Modest changelog:
NB#89670, NB#88553, NB#89910, NB#87102, NB#89027, NB#85528, NB#85654, 
NB#85852, NB#86208, NB#86800, NB#85757, NB#84845, NB#86564, NB#86719, 
NB#86471, NB#87102, NB#86408, NB#86810, NB#86828, NB#85194, NB#87844, 
NB#88016, NB#88648, NB#86905, NB#86743, NB#88031, NB#88246, NB#86831, 
NB#86996, NB#85924, NB#87412

Could someone who knows to speak that language translate it for the humans,
please?
Comment 7 Andre Klapper maemo.org 2008-12-17 20:36:53 UTC
(In reply to comment #6)
> Could someone who knows to speak that language translate it for the humans,
> please?

You look at me, eh? :-)

Do you refer to *all* the bug numbers (hence this is a complaint that the
ChangeLog is totally useless for people not having access to Nokia's internal
bugtracker) or do you just refer to this specific fix?

If it's about the specific fix, I guess that it's ticket 85654, quoting:

"------- Comment #0 -------
1.Launch Modest
2.Define a Gmail IMAP account with more than 50 messages in it(so that the
scrollbar appears).
3.Check the availabality of the passive focus and the scrollbar position in the
message list view of the main view.

EXPECTED OUTCOME:
As with other accounts, the passive focus should be shown over the first
message in the message list and the scrollbar should be positioned at the top.

ACTUAL OUTCOME:
Instead, the passive focus is shown over the second last message in the message
list and the scrollbar is positioned accordingly at the end of the message
list.

------- Comment #2 -------
I've implemented a fix that manages properly the cursor so that we update the
cursor when we get new headers on the view. This way we finally get the proper
selection for big folders.
Committed fix to modest svn r5078.

------- Comment #4 -------
Merged to Diablo branch in r6020

------- Comment #11 -------
Now passive focus is on first message and scroll bar is placed at the top.
Hence marking as Verified."
Comment 8 Daniel Martin Yerga 2008-12-17 21:06:12 UTC
(In reply to comment #7)
> You look at me, eh? :-)

Hehe, not really it was more a philosophical complaint than other thing, but
thanks anyway for the comment. I appreciate it :)

> Do you refer to *all* the bug numbers (hence this is a complaint that the
> ChangeLog is totally useless for people not having access to Nokia's internal
> bugtracker) or do you just refer to this specific fix?
> 
> If it's about the specific fix, I guess that it's ticket 85654, quoting:

Both ;)
It was a small note about that useless changelog, and the difference with other
changelogs (even with closed source packages as mce). Fortunately, we have the
code (well written btw) that never lies.


Thanks Andre.
Comment 9 Andre Klapper maemo.org 2008-12-22 19:08:33 UTC
(In reply to comment #6)
> Possibly this fix is one of the following fixes in the Modest changelog:
> NB#89670, NB#88553, NB#89910, NB#87102, NB#89027, NB#85528, NB#85654, 
[...]
> Could someone who knows to speak that language translate it for the humans,
> please?

Dyerga: Please do file a seperate bug report about the useless ChangeLog.
I just discussed this with developers but the issue requires discussion with
Product Managers. Hence I like to track it correctly so we can improve that.
Comment 10 Quim Gil nokia 2008-12-22 21:16:52 UTC
> Dyerga: Please do file a seperate bug report about the useless ChangeLog.
> I just discussed this with developers but the issue requires discussion with
> Product Managers. Hence I like to track it correctly so we can improve that.

With product managers? Then please assign the new enhancement request to me.
Comment 11 Andre Klapper maemo.org 2008-12-22 21:55:28 UTC
(In reply to comment #9)
> Please do file a seperate bug report about the useless ChangeLog.

Done: bug 3952