Bug 2565 - (int-92143) Media Player repeatedly forgets how to play an AVI file
: Media Player repeatedly forgets how to play an AVI file
Product: Media player
: 4.1.2 (4.2008.36-5)
: ARM Linux
: Low major with 1 vote (vote)
: ---
Assigned To: unassigned
: media-player-bugs
: http://bleb.org/misc/Ghostbusters.avi
: moreinfo
  Show dependency tree
Reported: 2007-12-15 16:22 UTC by Andrew Flegg
Modified: 2010-01-05 17:20 UTC (History)
3 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Andrew Flegg (reporter) maemo.org 2007-12-15 16:22:00 UTC
1) Download the above AVI (warning: 712MB)
2) Save to an external MiniSD card on an N810 running OS2008, in a "Video"
directory under the root.
3) Open Media Player.
4) Select "Ghostbusters" in the library and click on the play button.
5) Seek to some point about 3/4 of the way through after the file starts
6) Wait for the file to continue playing and then drag the position bar to the
rightmost edge.
7) Wait for the file to stop.
8) Press "Play" again.

The file starts playing again.

Media Player thinks for a while, but then stops, showing the file's icon in the
content area.


This happened before extra software was installed, but reproducibility has only
been tested with mplayer, Canola2 and LXDoom installed.

The file has not yet finished uploading, it should be uploaded by
2007-12-15T17:00Z (i.e. 5pm UTC)
Comment 1 Andre Klapper maemo.org 2008-11-06 21:01:27 UTC
is that still in issue in latest Diablo? I'm somehow unwilling to remove half
of my MP3s to create enough free space to test this... :-P
Comment 2 Andrew Flegg (reporter) maemo.org 2008-11-09 00:18:00 UTC
(In reply to comment #1)
> Andrew,
> is that still in issue in latest Diablo? I'm somehow unwilling to remove half
> of my MP3s to create enough free space to test this... :-P

Heh. Yeah, this - and similar effects which are probably manifestations of the
same problem still occur.

For example, I was just at 21:17 of a 30 min, very low quality, 3GP file when
it just stopped. It would, in this circumstance, start playing but any
positioning on the scrollbar just moved it forward about 1min, making getting
back into position frustrating (actually, the whole scroll to position thing
doesn't cover any of my use cases, but that's a different issue).

Irritatingly, it stopped again at the same position, but the file plays
perfectly on my desktop Linux system.
Comment 3 Andre Klapper maemo.org 2009-09-28 17:37:33 UTC
Hi Andrew, is this still an issue in Fremantle?

(WONTFIX for Diablo as Diablo is in maintenance mode and Nokia will only
provide bugfixes for critical issues if at all.)
Comment 4 Andrew Flegg (reporter) maemo.org 2009-09-28 18:20:17 UTC
I will investigate.
Comment 5 Andrew Flegg (reporter) maemo.org 2009-10-26 08:38:26 UTC
Cannot reproduce in Fremantle (1.2009.41-10)
Comment 6 Alex 2009-11-26 20:56:48 UTC
I ran into what could to be this same (or related) issue yesterday on N900
1.2009.42-11.002. It isn't clear if your inability to play the file persisted
after the initial try, in my case it does.

I was watching a movie (stored on the internal memory):

format : AVI
video : XviD at 1 896 Kbps (0.232BPP), 632*518 (1.220AR), 25.000 fps
audio #0 : MPEG-1 Audio layer 3 at 128 Kbps, 2 channels, 48.0 KHz

I paused the movie and left the media player to see something on youtube (via
web browser). When I closed that out and went back to the media player it said
'Unable to play media. Media format not supported.' I continued to get that
message the few times I tried to play the file again last night (persisted
after device reboot).

Just now I attempted to play the file again and it worked, even resumed from
where I left off. Not sure what triggered that behavior, but going through the
same process left me with the format not supported message:

1: Pause movie.
2: Opened browser window, watched a youtube video.
3: Closed browser window.
4: Returned to media player to resume playback.
5: Format not supported.
Comment 7 Andre Klapper maemo.org 2010-01-05 17:20:38 UTC
Alex: Your issue is bug 7211. Unrelated to this report though :)