Bug 2534 - No menu when clicking on connectivity applet, or just first menu
: No menu when clicking on connectivity applet, or just first menu
Status: RESOLVED WORKSFORME
Product: Connectivity
ICD
: 4.0
: N810 Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: icd-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-12-13 05:29 UTC by johnnynokia
Modified: 2009-02-02 13:36 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description johnnynokia (reporter) 2007-12-13 05:29:38 UTC
Sometimes I get no menu when I click on the connectivity applet. Other times I
get just the first menu, choose select connection and never get any other menu.

STEPS TO REPRODUCE THE PROBLEM:
Phone disconnecting abruptly from internet multiple times seems to incur it, or
a lot of disconnects/switching between wlan and phone. I'm not positive on how
to reproduce but it happens almost daily on my train commute.

EXPECTED OUTCOME:
Should get select connection menu, the be able to select from available
connection.

ACTUAL OUTCOME:
No menu, or only the select connection menu then never any other.

REPRODUCIBILITY:
sometimes

EXTRA SOFTWARE INSTALLED:
pidgin & plugins, lxdoom, claws mail, garnet vm, gainroot.

OTHER COMMENTS:
To resolve have to do /etc/init.d/osso-ic restart or power cycle

Yet for both of those I've had it initially work, but then immediately happen
again.
Comment 1 Klaus Anderson nokia 2007-12-18 21:55:11 UTC
Are you able to launch the connection selection dialog from the Connection
Manager? And do you always get the first menu (i.e. the menu that appears when
you tick the connectivity status bar applet)?
Comment 2 johnnynokia (reporter) 2007-12-20 01:33:22 UTC
>>Are you able to launch the connection selection dialog from the Connection
Manager?


oh via the menu vs the applet, haven't tried I will try


>>And do you always get the first menu (i.e. the menu that appears when
you tick the connectivity status bar applet)?

No not always.

note I'm upgrading to latest firmware tonight also..
Comment 3 johnnynokia (reporter) 2007-12-21 21:32:57 UTC
Okay I updated to the latest firmware and have run into this again.

regarding:

>>Are you able to launch the connection selection dialog from the Connection
Manager? 

I was able to try this now, and no, not via the applet nor via the menu
navigating to connection manager. I hit Select connection in connection manager
and nothing happens just like when I try via the applet.

I don't see anything pertinent to IC when I do say dmesg either as far as
errors. 

As an aside, we could probably help you guys out more if there were at least
normal --debug --verbose type switches for some of your closed source stuff.
Compiled with -g and debug symbols left in would be nice :-D

thanks
Comment 4 Aapo Makela nokia 2008-01-23 11:08:22 UTC
Thanks for the information. I would still like to ask few things: 

1) What "connect automatically" settings do you have? Always ask, WLAN, phone
or both?

2) Does the data connection usually work with phone or it is normal for it to
disconnect/reconnect often?

3) Do you have multiple WLANs and 1 phone connection configured?

If you can install syslog to the device and get an excerpt when this issue
happens (and preferably few minutes before it), that might be helpful too.
Comment 5 Marius Gedminas 2008-05-24 23:07:52 UTC
I'm not the original reporter, but I have also seen this issue a few times, in
locations with poor WiFi connectivity.  Usually it happens after the WiFi
connection is lost several times, and then I can no longer access the "Select
connection" dialog, even if I move to a location with good WiFi connectivity. 
The last time this happened for me was today, and the fix described in this bug
(sudo /etc/init.d/osso-icd restart) worked.

My device is a N810 with the latest firmware (OS 2008 ver 2.2007.51-3).  I have
it configured to connect automatically to WLAN connections with a 5 minute
search interval.  Question (2) is not really relevant -- I've seen this bug at
times when I didn't use a phone connection, although I have one configured.  As
for (3), yes, I have multiple WLANs and 1 phone connection configured.

I'm afraid I didn't have syslog installed.  dmesg shows this around the time
when I last had a working connection:

[3305272.898437] cx3110x: associated to 00:18:39:2e:42:fa (bcn 100 msec, DTIM
1).
[3305283.531250] cx3110x: PSM dynamic with 200 ms CAM timeout.
[3305338.804687] cx3110x: deauthenticated from 00:18:39:2e:42:fa.
[3305338.804687] cx3110x: active scanning on 'coffee inn'.
[3305340.421875] cx3110x: scanned 11 channels.
[3305340.921875] cx3110x: WARNING sm_drv_transmit: prism_softmac_frame_tx() 
returned error -9.
[3305341.921875] cx3110x: WARNING sm_drv_transmit: prism_softmac_frame_tx() 
returned error -9.
[3305342.921875] cx3110x: WARNING sm_drv_transmit: prism_softmac_frame_tx() 
returned error -9.
[3305348.718750] cx3110x: disassociated from 00:18:39:2e:42:fa.
[3305349.046875] cx3110x: shut down softmac.
[3305349.476562] DSP Pausing failed, skipping OP change!
[3305349.539062] EAC mode: play enabled, rec enabled
[3305349.695312] cx3110x: loading 3826.arm firmware.
[3305349.937500] (c)opyright 2004 Conexant
[3305349.937500] 
[3305349.937500] build info: PRISM SoftMAC
[3305349.937500]   creator: [kvalo]
[3305349.937500]   date: [07/10/05-11:45]
[3305349.937500] 
[3305349.945312] cx3110x: MAC address XX:XX:XX:XX:XX:XX.
[3305349.953125] cx3110x: libumac version 2.12.0.0.a.9.15-5
[3305349.953125] cx3110x: lmac version 2.13.0.0.a.22.8
[3305350.156250] cx3110x: shut down softmac.

There were no more cx3110x messages until after I did the 'sudo
/etc/init.d/osso-icd restart', when the following appeared:

[3312295.757812] cx3110x: loading 3826.arm firmware.
[3312296.000000] (c)opyright 2004 Conexant
[3312296.000000] 
[3312296.000000] build info: PRISM SoftMAC
[3312296.000000]   creator: [kvalo]
[3312296.000000]   date: [07/10/05-11:45]
[3312296.000000] 
[3312296.007812] cx3110x: MAC address XX:XX:XX:XX:XX:XX.
[3312296.015625] cx3110x: libumac version 2.12.0.0.a.9.15-5
[3312296.015625] cx3110x: lmac version 2.13.0.0.a.22.8
[3312296.015625] cx3110x: PSM disabled.
[3312297.867187] cx3110x: scanned 11 channels.
[3312299.890625] cx3110x: scanned 11 channels.
[3312301.882812] cx3110x: scanned 11 channels.
[3312303.804687] cx3110x: scanned 11 channels.
[3312306.125000] cx3110x: associated to 00:18:f8:f1:bd:52 (bcn 100 msec, DTIM
1).
[3312307.187500] cx3110x: PSM dynamic with 200 ms CAM timeout.

I had the icd process running during the time when I was unable to get the
connectivity dialog (I ran 'pidof icd' from the xterm), but I hadn't thought to
run strace or gdb on it.
Comment 6 Andre Klapper maemo.org 2008-07-31 16:25:28 UTC
Aapo: Was the last comment helpful?

Marius: I assume this is also stil an issue with Diablo?
Comment 7 Marius Gedminas 2008-07-31 16:28:13 UTC
Well, I haven't exactly seen this issue on Diablo, but I once saw something
similar: my "select connection" dialog kept showing the same two networks (one
wifi, one my phone's gprs) for two days everywhere, and never did any scanning.
 sudo /etc/init.d/icd2 restart fixed the situation.
Comment 8 Aapo Makela nokia 2008-08-11 12:09:50 UTC
(In reply to comment #7)
> Well, I haven't exactly seen this issue on Diablo, but I once saw something
> similar: my "select connection" dialog kept showing the same two networks (one
> wifi, one my phone's gprs) for two days everywhere, and never did any scanning.
>  sudo /etc/init.d/icd2 restart fixed the situation.
> 

AFAIK, that is a different issue (int-82482 as a reference for aklapper).
Comment 9 johnnynokia (reporter) 2008-08-12 15:13:57 UTC
hi

(In reply to comment #4)
> Thanks for the information. I would still like to ask few things: 
> 
> 1) What "connect automatically" settings do you have? Always ask, WLAN, phone
> or both?
> 

WLAN

> 2) Does the data connection usually work with phone or it is normal for it to
> disconnect/reconnect often?
> 

With my previous tmobile connect it disconnected often, meaning the phone
disconnected, not the tablet to the phone connect.  With my new provider it
doesn't disconnect very often.

> 3) Do you have multiple WLANs and 1 phone connection configured?
> 

Yes

> If you can install syslog to the device and get an excerpt when this issue
> happens (and preferably few minutes before it), that might be helpful too.
> 

Haven't noticed syslog in any of the repositories if you want to send me a link
I'd be happy to.

But again since switching to my new phone carrier I almost never see this
problem now, becuase my new phone carrier is so much better. The other one the
phone constantly disconnected.

thanks
Comment 10 Andre Klapper maemo.org 2008-08-12 17:48:05 UTC
(In reply to comment #9)
> (In reply to comment #4)
> > If you can install syslog to the device and get an excerpt when this issue
> > happens (and preferably few minutes before it), that might be helpful too.
> 
> Haven't noticed syslog in any of the repositories if you want to send me 
> a link I'd be happy to.

See http://maemo.org/development/tools/doc/diablo/syslog/ and
http://maemo.org/development/documentation/man_pages/sysklogd/

> But again since switching to my new phone carrier I almost never see this
> problem now, becuase my new phone carrier is so much better. The other one the
> phone constantly disconnected.

Good for you, bad for tracking this down. :-D
Comment 11 Andre Klapper maemo.org 2009-02-02 13:36:07 UTC
No news for 5 months - closing, feel free to reopen if this becomes an issue
again.
Thanks!