Bug 2531 - unable to download maemo 4.0 firmware for N800
: unable to download maemo 4.0 firmware for N800
Status: RESOLVED FIXED
Product: maemo.org Website
Downloads
: 4.0
: All Linux
: High critical with 11 votes (vote)
: ---
Assigned To: Ferenc Szekely
: downloads@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-12 18:33 UTC by Hubert Figuiere
Modified: 2007-12-22 03:04 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Hubert Figuiere (reporter) 2007-12-12 18:33:05 UTC
STEPS TO REPRODUCE THE PROBLEM:
Try to download the 4.0 firmware from
http://tabletsdev.maemo.org/nokia_N800.php

EXPECTED OUTCOME:
Download successful

ACTUAL OUTCOME:
Hang (timeout) in the middle of the download at around 18% (24MB). no way to
resume. the download system does not allow using tools like wget or curl that
can resume the download after a timeout.

REPRODUCIBILITY:
Always. Just checked again. Has been for a few weeks.

EXTRA SOFTWARE INSTALLED:
Client = Firefox 2.0 on Linux
Comment 1 Hubert Figuiere (reporter) 2007-12-12 18:42:13 UTC
the firmware I'm trying to download is this one:

http://tabletsdev.maemo.org/nokia_N800.php?f=RX-34_2008SE_1.2007.44-4_PR_COMBINED_MR0_ARM.bin
Comment 2 Quim Gil nokia 2007-12-13 07:37:19 UTC
Weird, worksforme. I just tried with Epiphany & Gutsy and I got it in less than
a minute. Alright, I have good connection here but this should affect only the
speed, not the fact of getting the whole file or not.

We did receive reports about slow downloads but none about interruptions. We
have taken measures for the speed and this download under a minute proves it
(it was slow for me as well weeks ago).

Can it be something at your end? Coudl you try in another computer/connection?
Any other ideas? Anybody else experiencing this? Please reopen if you find
something wrong in our side.
Comment 3 Hubert Figuiere (reporter) 2007-12-13 16:09:21 UTC
(In reply to comment #2)
> Weird, worksforme. I just tried with Epiphany & Gutsy and I got it in less than
> a minute. Alright, I have good connection here but this should affect only the
> speed, not the fact of getting the whole file or not.

Less than a minute, I can't even do that here. I'm not local, like you.

> 
> We did receive reports about slow downloads but none about interruptions. We
> have taken measures for the speed and this download under a minute proves it
> (it was slow for me as well weeks ago).

It is actually timeout/stall. It stayed that way overnight.

> 
> Can it be something at your end? Coudl you try in another computer/connection?

I could try that, but only if it was not required to click click to access the
download link like it is being done.
I guess our priorities are not the same.

> Any other ideas? Anybody else experiencing this? Please reopen if you find
> something wrong in our side.

I can download SUSE boot cds, OpenOffice source tarballs and other stuff
without problem.
Comment 4 t3st3r 2007-12-19 02:05:51 UTC
Download is AWFULLY slow and tends to timeouts.I see few options:
 1) Setup some lightweight and fast server like lighttpd or nginx on a fast
channel which can cope with a really decent load.
 2) Use bittorrent, after all. After authentication, allow us to fetch just a
small torrent file and then let's peers to do the rest.To join download they
should have .torrent file anyway so auth scheme will work as well as for easy
downloads.At least with pretty same efficiency.Torrent is hard to jam with
traffic.The more users downloading, the more powerful and fast downloads will
be as well.For example Ubuntu is distributed over torrent and it's pretty handy
when their WWW servers are overloaded few days after release.I'm preferring to
fetch torrent from trusted site to ensure OS image is original one.However
since up to date there is no such option, I have to download from unofficial
bittorent shares and then check if MD5 matches to officially published.This
will give some level of trust to download while having it at DECENT speed, not
2.5 kb/sec with timeouts like Nokia's site provides today.
Comment 5 t3st3r 2007-12-19 02:39:24 UTC
I just tried with Epiphany & Gutsy and I got it in less than
> a minute.
Maybe you're fetching via inrtanet?Your servers are overloaded and people over
whole world having troubles with downloading.As for me (Russia, Moscow, 6Mbit
channel) your server usually times out but sometime is able to send something
at a unacceptably low speed.Looks like your channel connecting to external
worls is jammed with uploads or server can't handle so much clients.Other sites
are browsable at full speed so it is your issues, not mine.You can ignore issue
of course with worksforme but this will cause poor user experience.You better
ask some dozen of people over globe to measure their download speeds and give
it to you.You will be surprised.Actually Nokia's download service is *worst* I
ever seen, sorry.I did not seen such slow downloads for several years.

> Alright, I have good connection here but this should affect only the
> speed, not the fact of getting the whole file or not.
Downloading takes too long, often all timeouts due to lack of data.Also my ISP
for example changes my IP each 24 hours (PPPoE session length is 24 hours).

> We did receive reports about slow downloads but none about interruptions.
This is related.Slow downloads are tend to abort due to timeouts.In fact, when
data rate drops below several kbytes/sec there is high chance that it will
never resume at all and all will time out.

> Can it be something at your end? Coudl you try in another computer/connection?
My one with 6Mbps is ok I hope?I can surf at decent speed.And n800 firmware
downloaded via bittorrent at some decent ~400kbytes/sec speed.Now, compare with
2-3 kbytes/sec from your downloads.Argh and it timouts without starting
download most of time.

> Any other ideas? Anybody else experiencing this? Please reopen if you find
> something wrong in our side.
I'm having this issue, too.Your upload capacity not seems to be enough for this
amount of downloads - my download experience is MORE THAN AWFUL (never seen
such d\load speeds since dial-up times!).I guess that either you should set up
a bunch of mirrors or maybe use torrent.Or better, both.Also official IT OS
2008 repositories are seems to be jammed as well.They're usually timing out
today when I'm trying to fetch list of updates...

P.S. I'm surprised Nokia can't monitor their servers and channels load
properly.You have to monitor servers availability from several points in the
world, let's say several points in Europe, Asia, USA, ... - then you will have
an overall idea about how your server looks for others, it's performance,
responsiveness, etc.Maybe there is some bottleneck not directly on Nokia's
servers and channels but close enough to slow things down.
Comment 6 Juha Tukkinen nokia 2007-12-19 10:58:00 UTC
tablets-dev.nokia.com is verified to be inadequately slow to provide the latest
OS2008 50-2 images for N810 and N800.
Comment 7 BenoƮt HERVIER 2007-12-19 11:07:42 UTC
Samething for repository.maemo.org !
Comment 8 Neil MacLeod maemo.org 2007-12-19 11:54:04 UTC
Confirmed.

The application manager is also now hanging (09:49 GMT 19 Dec) while trying to
update catalogues (same with apt-get update - it's taking forever, 10+ minutes
and still not completed). So, not only are firmware downloads badly affected
whenever there is a new firmware release, the rest of the tablet software
download infrastructure is rendered unusable too which will no doubt confuse
users who are simply trying to install new applications blissfully unaware a
new firmware has been released.

Nokia desperately need a scalable distribution infrastructure to avoid the
situation where the standard repositories are rendered inaccessible whenever
new firmware is released. At the very least the main repositories (inc. extras
and extras-devel) should be hosted on different servers and pipes to the main
firmware download server/pipe.
Comment 9 Neil MacLeod maemo.org 2007-12-19 12:20:57 UTC
After about 20 minutes (possibly longer) the "apt-get update" failed with the
following output:

/home/user # apt-get update
Hit http://catalogue.tableteer.nokia.com chinook Release.gpg
Hit http://catalogue.tableteer.nokia.com chinook Release.gpg
Ign http://catalogue.tableteer.nokia.com ./ Release.gpg
Hit http://catalogue.tableteer.nokia.com chinook Release
Hit http://catalogue.tableteer.nokia.com chinook Release
Ign http://catalogue.tableteer.nokia.com ./ Release
Ign http://catalogue.tableteer.nokia.com chinook/user Packages/DiffIndex
Ign http://catalogue.tableteer.nokia.com chinook/user Packages/DiffIndex
Ign http://catalogue.tableteer.nokia.com ./ Packages/DiffIndex
Hit http://catalogue.tableteer.nokia.com chinook/user Packages
Hit http://catalogue.tableteer.nokia.com chinook/user Packages
Hit http://catalogue.tableteer.nokia.com ./ Packages
Ign http://repository.maemo.org chinook Release.gpg
Ign http://repository.maemo.org chinook Release.gpg
Hit http://repository.maemo.org chinook Release
Hit http://repository.maemo.org chinook Release
Ign http://repository.maemo.org chinook/free Packages/DiffIndex
Ign http://repository.maemo.org chinook/non-free Packages/DiffIndex
Ign http://repository.maemo.org chinook/free Packages/DiffIndex
Ign http://repository.maemo.org chinook/non-free Packages/DiffIndex
Hit http://repository.maemo.org chinook/free Packages
Err http://repository.maemo.org chinook/non-free Packages
  Connection failed [IP: 84.45.224.23 80]
Hit http://repository.maemo.org chinook/free Packages
Hit http://repository.maemo.org chinook/non-free Packages
Failed to fetch
http://repository.maemo.org/extras/dists/chinook/non-free/binary-armel/Packages.gz
 Connection failed [IP: 84.45.224.23 80]
Reading package lists... Done
E: Some index files failed to download, they have been ignored, or old ones
used instead.

It's been failing this way since yesterday evening (18 Dec, 18:00-ish).

I guess this is the price to be paid for popularity; maybe now is the time to
invest some serious money and resources in infrastructure, before the next
firmware release. The current infra is simply not up to the job of providing a
dependable firmware/software download service 24x7, 365 days of the year which
is what I as a consumer expect having paid for the device and the promise of
easy software downloads.
Comment 10 Manuel Segura 2007-12-19 12:28:19 UTC
(In reply to comment #8)
> Confirmed.
> 
> The application manager is also now hanging (09:49 GMT 19 Dec) while trying to
> update catalogues (same with apt-get update - it's taking forever, 10+ minutes
> and still not completed). So, not only are firmware downloads badly affected
> whenever there is a new firmware release, the rest of the tablet software
> download infrastructure is rendered unusable too which will no doubt confuse
> users who are simply trying to install new applications blissfully unaware a
> new firmware has been released.
> 

I agree.

I don't understand why I have to download the N800's image from particulars
servers because the Nokia's servers are down. 

I am very disappointed.
> Nokia desperately need a scalable distribution infrastructure to avoid the
> situation where the standard repositories are rendered inaccessible whenever
> new firmware is released. At the very least the main repositories (inc. extras
> and extras-devel) should be hosted on different servers and pipes to the main
> firmware download server/pipe.
>
Comment 11 Laurent GUERBY 2007-12-19 14:13:00 UTC
Indeed, I had to download the firmware from an individual web site, and after
flash the application manager can't update repository.maemo.org.

Any known mirror for repository?
Comment 12 Chris 2007-12-19 18:59:27 UTC
This is insane, its the next day with nothing working, It took few tries to
download my stuff back ....the download speed is worse then dailup, plus my fav
app kagu takes forever to download and keeps saying download failed..I hope
this is fixed , asap
Comment 13 Tony Green 2007-12-19 21:26:45 UTC
As well as screwing image downloads, this is also fouling up repositories such
as repository.maemo.org/extras/. Which is a serious problem because when you
finally manage to get the N800 flashed, you need to install all the
applications again. I'm currently stuck on several important applications (such
as Kagu and gpe-calendar)
Comment 14 phaoost 2007-12-20 01:48:58 UTC
I confirm timeouts and slow page loading on
http://tabletsdev.maemo.org/nokia_N800.php

Stopped trying to get to download page, so can't say anything regarding dl
speed. Suppose it's unacceptable
Comment 15 Simon80 2007-12-20 05:51:15 UTC
This also affects developers - I decided to install the SDK on my machine again
recently, having sworn off development after trying to port a Telepathy backend
early this year, and I can't install the SDK because the install script doesn't
cope with failure very well, and the repositories are offering very flaky
service.
Comment 16 t3st3r 2007-12-21 03:26:31 UTC
http://tablets-dev.nokia.com/nokia_N800.php
Failed to load page at all with following error:

An error occurred while processing your request.

Reference #97.b3979bd5.1198200278.1b45b849 

Repositories are still down.This is not funny.
Comment 17 julien.cayzac 2007-12-21 16:56:31 UTC
I am in the same case as SImon80: this thing is blocking me as I can't install
the SDK at all :-(
Comment 18 julien.cayzac 2007-12-21 17:38:49 UTC
*** Bug 2617 has been marked as a duplicate of this bug. ***
Comment 19 Ferenc Szekely maemo.org 2007-12-21 21:06:22 UTC
Firmware d/l seems to be solved, the download speed is back to normal. Many
thanks to the guys at Nokia Download Services, Akamai and Ixonos! 

One cosmetic issue:
files for N800 will be named nokia_N800.php and files for N810 will be called
nokia_N810.php after successful download. You can feed the linux flasher with
these files despite of their names.
Comment 20 Michael Wiktowy 2007-12-22 02:48:46 UTC
(In reply to comment #19)
> Firmware d/l seems to be solved, the download speed is back to normal.

The problem getting apt updates remains though since your servers are not
returning http error codes when bogged down but rather html messages explaining
that the service is down which apt dutifully caches and uses to try to install
the package ... resulting in update/installation chaos ... that is still
on-going as of this time.
Comment 21 Neil MacLeod maemo.org 2007-12-22 03:04:00 UTC
Refer to bug 2620 for repository.maemo.org problems.