Bug 2474 - Shift-space on BT keyboard disables virtual keyboard, requires reboot
: Shift-space on BT keyboard disables virtual keyboard, requires reboot
Status: RESOLVED WONTFIX
Product: Desktop platform
Virtual keyboard (halfscreen)
: 4.1.2 (4.2008.36-5)
: N800 Linux
: Low major with 2 votes (vote)
: ---
Assigned To: unassigned
: vkb-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-12-04 05:44 UTC by Austin Che
Modified: 2009-04-29 17:03 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Austin Che (reporter) 2007-12-04 05:44:40 UTC
STEPS TO REPRODUCE THE PROBLEM:
Connect a bluetooth keyboard. Go to some text box, type shift-space. This
brings up an extra bar at the bottom of the screen with 'abc' on the lower
right. Word completions of what's typed on the keyboard is shown there. After
disconnecting the bluetooth keyboard, the virtual keyboard won't come up. Upon
activation of a text field, only the same 'abc' bar as above shows up.

EXPECTED OUTCOME:
Upon disconnecting the bluetooth keyboard, the virtual keyboard should come
back.

ACTUAL OUTCOME:
There's no apparent way to bring back the virtual keyboard short of system
reboot.

REPRODUCIBILITY:
always
Comment 1 Jake Kunnari 2007-12-04 09:42:23 UTC
Hi, which IT OS version you are using? And what HW? Thanks.
Comment 2 Austin Che (reporter) 2007-12-04 16:18:26 UTC
OS2008 on N800
Comment 3 Jason Carter 2007-12-05 15:59:46 UTC
Can you please get the full firmware version from Control Panel -> About
product, please?
Comment 4 Austin Che (reporter) 2007-12-05 16:24:51 UTC
The version under control panel->about says unknown. /etc/osso_software_version
is RX-34+RX-44_2008SE_1.2007.44-4_PR_MR0
Comment 5 Ryan Abel maemo.org 2007-12-15 01:05:42 UTC
I haven't had it disable the virtual keyboard, but this "feature" is a major
pain when typing on a Bluetooth keyboard, as there doesn't seem to be a way to
get rid of it easily (I've had some success switching applications) and it
absorbs a lot of screenspace.

Anybody know of an easy way to disable this complete on an N800?
Comment 6 Jake Kunnari 2008-01-25 13:43:29 UTC
Please updat your IT OS to this version: Software Edition 2008 version
2.2007.50-2 for Nokia N800

And try again.
Comment 7 Austin Che (reporter) 2008-01-27 17:59:55 UTC
Problem is still there on a cleanly flashed N800 with 2.2007.50-2
Comment 8 Ryan Abel maemo.org 2008-02-24 16:06:05 UTC
*** Bug 2975 has been marked as a duplicate of this bug. ***
Comment 9 Frantisek Dufka maemo.org 2008-04-17 23:16:21 UTC
According to Tomas shift-space behaviour is a feature. Well, at least with
N810, see
http://lists.maemo.org/pipermail/maemo-users/2008-February/009257.html

IMO it is quite useful feature but can be confusing. Maybe it can be tied to
more unusual shortcut. Or maybe it should apply to N810 keyboard only, not BT
or USB ones, but I like having the way to enable virtual keyboard even with
physical keyboard attached (and more so with N810 slide keyboard opened).
Comment 10 Ryan Abel maemo.org 2008-05-18 13:53:39 UTC
The behavior seems to be a little better in Diablo. Shift-space will now
reliably disable the auto-complete bar, but allowing the Bluetooth keyboard to
sleep with the bar up will still result in a text-entry bringing up the
auto-complete bar instead of a keyboard.

Can we just have the option to disable this "feature" entirely on an N800? . .
.
Comment 11 Andre Klapper maemo.org 2008-06-10 00:31:18 UTC
This is not a critical bug by definition - setting severity to normal.
Comment 12 Frantisek Dufka maemo.org 2008-06-12 14:17:23 UTC
(In reply to comment #10)
> Can we just have the option to disable this "feature" entirely on an N800? . .

Maybe this is not exactly what you want. Please correct me if I am wrong but
what you want is that virtual keyboard should come back when physical
(bluetooth) keyboard is disconnected, correct?

Here is my theory - shift+space switches between two input methods, one method
is real virtual keyboard with all keys (the old one, available in OS2007 too),
second method is new one added in OS2008 mainly for N810, this one is available
if you open/slide out the keyboard on N810 and allows word autocompletion. This
second method is equally (i.e. not much for someone :-) useful with bluetooth
keyboard on N800 just like with N810 one and can be disabled, see the mailing
list link in my previous comment.

But maybe there is a bug because N810 keyboard cannot be really disconnected so
the code handling this is missing ==> when bt keyboard is disconnected input
method is not switched back to vkb.
Comment 13 Ryan Abel maemo.org 2008-06-12 14:20:12 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > Can we just have the option to disable this "feature" entirely on an N800? . .
> 
> Maybe this is not exactly what you want. Please correct me if I am wrong but
> what you want is that virtual keyboard should come back when physical
> (bluetooth) keyboard is disconnected, correct?
> 

I'd don't ever want to see the auto-complete bar when using a Bluetooth
keyboard. Ever. Period. ;)
Comment 14 Craig Miller 2008-07-25 05:08:42 UTC
I have seen this "bug/feature" 

Here is how to disable it.

1) Go to Control Panel -> Test Input Settings
2) Click on "Languages" Tab
3) Under the 1st Language, click on the "Settings" button
4) Uncheck ALL of the boxes
5) click OK

You will never see this ABC box again.
Comment 15 Andre Klapper maemo.org 2008-10-31 19:30:38 UTC
Hmm, I should get a bluetooth keyboard for testing purposes...
Is this still an issue in Diablo?
Is this a bug at all, or is it a feature? ;-)
Comment 16 Andre Klapper maemo.org 2008-11-20 23:55:21 UTC
If it can be disabled as described in comment 14, I don't see a reason to keep
this report open. Anyone contradicting?
Comment 17 Jarmo Lahtiranta 2008-11-21 00:44:19 UTC
What? Yes! I don't think you can expect people to figure out this "fix" by
themselves. Documenting it somewhere might help, but still - the fix disables
all text input helpers (word completion etc.) which are quite useful when using
the on screen keyboard. It's not really a fix, rather than a poor workaround.

It would be great to have a checkbox to enable/disable just the abc-box at the
location mentioned in comment 14.
Comment 18 Neil MacLeod maemo.org 2008-11-21 17:26:19 UTC
(In reply to comment #16)
> If it can be disabled as described in comment 14, I don't see a reason to keep
> this report open. Anyone contradicting?

Andre, I think you are confusing what this bug report is about - according to
the initial comment the problem is not that the ABC box appears, the problem is
that the virtual keyboard is permanently disabled once a Bluetooth keyboard is
disconnected.

I haven't tested this in 4.2008.36-5 but if the vkb remains disabled after
disconnecting a BT keyboard on which shift-space has been pressed then a) this
bug is *very* much valid and should not be closed but instead fixed, and b)
severity should be set to at least major since a reboot may be required to
resolve the bug if you have a N800 (but not N810) and don't have access to a BT
keyboard when you realise the virtual keyboard has been disabled during an
earlier typing session.

Seperate bugs should be raised for the ABC box functionality and also to
suggest alternatives to shift-space, IMHO. They have nothing to do with this
bug.
Comment 19 Neil MacLeod maemo.org 2008-11-22 00:42:09 UTC
I can reproduce this bug on a N810/4.2008.36-5 with a Thinkoutside Stowaway BT
keyboard - obviously I can recover the situation by sliding open the N810
keyboard but an N800 in this state without an available BT keyboard would
probably require a reboot in order to re-enable the vkb.

Setting severity to major as this bug renders the device significantly unusable
and in need of a reboot, although it has to be said the chances of the bug
happening on a regular basis is extremely unlikely (though it could happen
without the user realising, and wondering "WTF?")
Comment 20 Andre Klapper maemo.org 2008-12-16 19:32:42 UTC
Thanks for clarifying. Got it.

Desktop bug => Need to ping the developers, and not many Diablo resources left
at Nokia... :-/
Comment 21 Andre Klapper maemo.org 2009-03-11 00:28:22 UTC
The stylus/virtual/halfscreen keyboard has been dropped in Fremantle and Nokia
does not plan to fix this in Diablo. Therefore this is a WONTFIX (like the rest
of open bugs involving the stylus keyboard).

The fullscreen (finger keyboard) will continue to exist.

Is this also an issue for the finger keyboard?
If so please explicitly note by leaving a comment here, so I can move this
report to the finger keyboard component.
Comment 22 Andre Klapper maemo.org 2009-04-29 17:03:17 UTC
No feedback -> closing.

> The stylus/virtual/halfscreen keyboard has been dropped in Fremantle
Correction: "The stylus/virtual/halfscreen keyboard will not be officially
supported in Fremantle and hence no bugfixes are planned."