Bug 2464 - (int-74211) DHCP does not work with Telefonica/Zyxel AP
(int-74211)
: DHCP does not work with Telefonica/Zyxel AP
Status: RESOLVED FIXED
Product: Connectivity
Networking
: unspecified
: N800 Linux
: Low major with 3 votes (vote)
: 4.0
Assigned To: unassigned
: wifi-bugs
: http://james.nerdiphythesoul.com/drup...
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-12-02 22:27 UTC by James
Modified: 2009-07-23 18:06 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description James (reporter) 2007-12-02 22:27:15 UTC
I get this error when I try to connect to my WiFi access point, when it worked
fine with previous operating systems and works again if I downgrade. It also
works with the router in my other house. I have tried disabling WPA, using
static DHCP, changing the SSID etc but nothing works. It happens with both the
official N800 beta and the N810 image on the N800. My router is a ZyXEL
Prestige 660HW-61 (Telefonica branded).
Comment 1 James (reporter) 2007-12-02 22:29:16 UTC
Screenshot: http://james.nerdiphythesoul.com/drupal/images/sillywifi.png
Comment 2 Klaus Anderson nokia 2007-12-03 12:54:37 UTC
This looks very much like an internal bug that we have fixed for the final
Chinook version.
Comment 3 James (reporter) 2007-12-03 17:41:45 UTC
Any way to get it working in the meantime, or that I can test a newer version
to see if it is really fixed?
Comment 4 SpiralBrain 2007-12-24 01:27:00 UTC
(In reply to comment #3)
> Any way to get it working in the meantime, or that I can test a newer version
> to see if it is really fixed?



try a manual ip address it worked for me :
my routers ip is 192.168.1.1
i used ip addres : 192.168.1.16
subnet mask: 255.255.255.0
router: 192.168.1.1
primary DNS: same as router id
secondary DNS: 0.0.0.0
Comment 5 SpiralBrain 2007-12-24 16:34:27 UTC
can someone reopen teh bug? i didnt realise i set it to resolved(In reply to
comment #4)
> (In reply to comment #3)
> > Any way to get it working in the meantime, or that I can test a newer version
> > to see if it is really fixed?
> try a manual ip address it worked for me :
> my routers ip is 192.168.1.1
> i used ip addres : 192.168.1.16
> subnet mask: 255.255.255.0
> router: 192.168.1.1
> primary DNS: same as router id
> secondary DNS: 0.0.0.0

i set the bug as resolved by mistake, but it isnt actually resolved,
its just a way aroung the problem
Comment 6 Walt Bilofsky 2007-12-26 05:36:17 UTC
I tried connecting to half a dozen random unsecured WiFi access points, and a
couple of them gave this same error message.  The others all gave a more
general error message.  I have no trouble connecting to my router at home with
WEP.  I'm running system version 2.2007.50-2 which I downloaded and installed
last night.  Second the motion to reopen this bug.
Comment 7 Neil MacLeod maemo.org 2007-12-26 19:57:01 UTC
Reopening, this bug doesn't appear to be fixed in OS 2008 (2.2007.50-2), so
either the internal bug (comment #2) wasn't the cause or it didn't make it into
the final build. More details on the bug and of course a changelog would allow
us to determine this for ourselves, but currently we're left to guess.

More discussion here:
http://www.internettablettalk.com/forums/showthread.php?p=115428#post115428
Comment 8 cooper.lau 2008-03-19 02:27:20 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 cooper.lau 2008-03-19 02:29:42 UTC
This bug seems to be in the same category as bug id 3027.
Comment 10 Andre Klapper maemo.org 2008-06-06 15:20:01 UTC
Hmm... contradictions.

According to the internal ticket, this bug has been fixed in udhcp
0.9.8cvs20050303-2osso4 which was released in build 2.2007.46.

According to comment 7, this has not been fixed in 2.2007.50-2.
Can someone please post the version of udhcp(c) installed? Thanks.
Comment 11 Andre Klapper maemo.org 2008-06-17 17:42:02 UTC
(definitely removing the ancient 4.0 target milestone - this is ancient past)
Comment 12 Andre Klapper maemo.org 2008-10-10 16:59:21 UTC
Guys, is this still an issue in Diablo with updates installed (4.2008.36-5)?
If yes:
    *  What AP you have?
          o Make and model?
          o Firmware version?
          o Hardware revision?
          o What are the encryption settings? (open/WEP/WPA-PSK/WPA-EAP) 
    * What's the distance to the AP?
    * How many APs do you have? 

A ZyXEL Prestige 660HW-61 was mentioned in this report - I wonder whether it's
the same for the other reporters too.
Comment 13 Andre Klapper maemo.org 2009-02-11 19:06:11 UTC
No feedback for 4 months. Assuming that this was FIXED for Chinook as per
Klaus' comment.
Comment 14 Chrisboff 2009-07-18 14:36:10 UTC
I am having this problem with my Nokia n810 running the latest version of
Diablo when trying to connect to a linksys WRT54GS v6 router with the latest
standard firmware. The only way I can connect is by manually assigning an IP
address.
Comment 15 Chrisboff 2009-07-23 18:06:23 UTC
I have reflashed my linksys WRT54GS with ddwrt v24-sp2 micro generic and now I
have no trouble connecting using dhcp.