Bug 2442 - Longer and more flexible application list on download site
: Longer and more flexible application list on download site
Status: RESOLVED FIXED
Product: maemo.org Website
Downloads
: unspecified
: All All
: High enhancement (vote)
: 4.1
Assigned To: Niels Breet
: downloads@maemo.org
: http://maemo.org/downloads/OS2008
:
: 1661
:
  Show dependency tree
 
Reported: 2007-12-01 00:40 UTC by tim_mueller
Modified: 2008-08-25 19:22 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description tim_mueller (reporter) 2007-12-01 00:40:26 UTC
STEPS TO REPRODUCE THE PROBLEM:

Go to http://maemo.org/downloads/OS2008 and try to find out what the 6th most
popular, highly rated, or recent application is.

EXPECTED OUTCOME:

When I first saw the site, I clicked on the "Stars" title, thinking it would
take me to a page with all applications listed, sorted by ratings.  Same for
the  "Fresh" and "Popular" titles.  In reality, one master list, sortable by
column, would work.

ACTUAL OUTCOME:

There is no way to see all available applications, and no way to see any but
the top five applications sorted.

REPRODUCIBILITY:

Always

EXTRA SOFTWARE INSTALLED:

None

OTHER COMMENTS:

If a sortable list is implemented, perhaps a filter can be implemented as well?
 For example, applications could be filtered by category or OS.
Comment 1 Quim Gil nokia 2007-12-03 07:32:09 UTC
Agreed. Related somehow to Bug 1661 ?
Comment 2 Niels Breet maemo.org 2008-01-22 17:29:05 UTC
This was already on my todo list. Looks like I can work on this soon.
Comment 3 Niels Breet maemo.org 2008-02-25 22:16:00 UTC
I finally managed to push the code I had in my local repository. You can now
click on Stars,Pearl,Fresh and Popular to see a list of the top 25 items.
Comment 4 Andre Klapper maemo.org 2008-08-25 19:22:31 UTC
(Removing deprecated target milestone)