Bug 2435 - Cannot remove install Skype icon from the application menu
: Cannot remove install Skype icon from the application menu
Status: CLOSED FIXED
Product: Desktop platform
Application Menu
: 4.0
: N800 Linux
: Low normal with 3 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: Quim Gil
: task-navigator-bugs
:
:
: 3602
:
  Show dependency tree
 
Reported: 2007-11-30 16:51 UTC by Tyler Willingham
Modified: 2009-10-21 09:34 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tyler Willingham (reporter) 2007-11-30 16:51:41 UTC
STEPS TO REPRODUCE THE PROBLEM:
Attempted to remove the "Skype" icon from the apps menu using organize
applications. At this point, I have not installed skype, nor do I intend to. I
would like it removed since there is little space for icons on a submenu
without scrolling in OS2008. There is no (visible) way to remove this via the
application manager either.

EXPECTED OUTCOME:
Delete button in organize to be functional, or allow one to remove the
application install link via application manager.

ACTUAL OUTCOME:
No way to remove the icon

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I appreciate the easy link to allow a user to click and install something, but
if there is no intention to do so, it should allow to be removed. (I opt to use
gizmo instead, and have no desire or need to have both on my n800)
Comment 1 Marko Vertainen 2008-03-30 12:29:26 UTC
It's possible to remove Skype installer as well Gizmo installer using X
terminal.  You need to get root and then just run commands:

apt-get remove skype-installer
apt-get remove gizmo-installer 

This is probably possible also with red-pill mode but I haven't tried it. I
would appreciate more easier way to do this though.
Comment 2 Ryan Abel maemo.org 2008-08-18 04:22:58 UTC
(In reply to comment #1)
> It's possible to remove Skype installer as well Gizmo installer using X
> terminal.  You need to get root and then just run commands:
> 
> apt-get remove skype-installer
> apt-get remove gizmo-installer 
> 
> This is probably possible also with red-pill mode but I haven't tried it. I
> would appreciate more easier way to do this though. 
> 

Please don't do this, as it will remove osso-software-version-rx*4, too, which
will leave you high-and-dry for future SSU updates.

Delete the .desktop files for the Skype, Gizmo and Rhapsody installers from
/usr/share/applications/hildon/ instead.
Comment 3 Ryan Abel maemo.org 2008-08-18 04:35:41 UTC
*** Bug 3299 has been marked as a duplicate of this bug. ***
Comment 4 Jianjun Yu 2008-09-01 11:35:25 UTC
I think this is a enhancement. The nokia consider this for the user who are not
famillar with n810. you could choose to install or not install. If you remove
the "Skype" icon . Some time you want to install the application . how to do
this ?
Comment 5 Ryan Abel maemo.org 2008-09-01 16:51:34 UTC
(In reply to comment #4)
> I think this is a enhancement. The nokia consider this for the user who are not
> famillar with n810. you could choose to install or not install. If you remove
> the "Skype" icon . Some time you want to install the application . how to do
> this ?
> 

Through the Application manager like every other application.
Comment 6 Quim Gil nokia 2009-05-21 14:33:36 UTC
It looks like this won't be an issue in Fremantle. Working on it...
Comment 7 Hubert Figuiere 2009-05-30 21:10:06 UTC
Also another acceptable option would be do be able to remove the icon from the
configuration of the menu. This can't be done for anything.
Comment 8 Quim Gil nokia 2009-09-21 08:28:21 UTC
Fixed in Fremantle as there is no Skype icon in the application menu.

I'm marking this as FIXED since the ground problem (being able to remove icons
of apps you haven't installed yet) is also fixed because there are not such
"icons to install apps" anymore.
Comment 9 Lucas Maneos 2009-10-20 17:49:37 UTC
(In reply to comment #8)
> I'm marking this as FIXED since the ground problem (being able to remove icons
> of apps you haven't installed yet) is also fixed because there are not such
> "icons to install apps" anymore.

There were many of those on the loan devices actually, but I'm happy to report
they could all be removed.
Comment 10 Quim Gil nokia 2009-10-21 09:34:25 UTC
Yes, I got to know about them few days before the Summit actually since they
hadn't been in previous internal releases. I was relieved when I saw they could
be de-installed easily.  ;)