Bug 2398 - (int-72242) OS2008Beta browser crashes when accessing pages with rss feeds
(int-72242)
: OS2008Beta browser crashes when accessing pages with rss feeds
Status: RESOLVED FIXED
Product: Browser
MicroB engine
: 4.0
: N800 Maemo
: Medium major (vote)
: 4.0
Assigned To: unassigned
: microb-bugs
: http://maemo.org/downloads/OS2007
: crash
:
:
  Show dependency tree
 
Reported: 2007-11-27 10:00 UTC by blade1683
Modified: 2008-05-18 17:46 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description blade1683 (reporter) 2007-11-27 10:00:41 UTC
STEPS TO REPRODUCE THE PROBLEM:OS2007 launch backup/restore utility. Create new
backup. Download and flash OS2008 Beta to N800 IT. After flash, restore backup
made prior to update. After backup is complete, load web browser and contact
www.maemo.org. Page loads and all links work except for
http://maemo.org/downloads/OS2007 which causes mozilla browser to close every
time. Directly typing in http://maemo.org/downloads/OS2007 into the address bar
also causes browser to self-terminate. 

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always/sometimes/once)Always

EXTRA SOFTWARE INSTALLED:Nothing that didn't come with OS2008 beta

OTHER COMMENTS:I can't install anything from the respositories or maemo
downloads. Help!
Comment 1 timeless 2007-11-27 10:34:43 UTC
afaiu the backup file is a zip file, please copy it to a normal computer.
examine its contents to determine there's nothing confidential, and then attach
it.

actually, it's best if you would reflash, make a backup, compare the two
backups, make a modified backup based on the clean backup and slowly integrate
files from the crashy backup and restore until you trigger the crash.

one's you've limited it to a single file (ideally), you can try limiting it by
lines. the smaller the testcase, the easier it'd be for someone to resolve it
(if you're lucky, the problem could be resolved by someone working outside
Nokia).
Comment 2 timeless 2007-11-27 15:20:45 UTC
we have an internal fix for problems that match this description. without
receiving the actual crashing data, i can't be sure.

I'm adapting the summary, reporter (and other person from irc...) please see if
this appears to match your experience.

if we're right, the problem should be caused by:
$ grep engine ~/.browser
engine=opera

it should say (if it doesn't want to crash)
engine=microb
Comment 3 blade1683 (reporter) 2007-11-27 20:04:51 UTC
(In reply to comment #0)
> STEPS TO REPRODUCE THE PROBLEM:OS2007 launch backup/restore utility. Create new
> backup. Download and flash OS2008 Beta to N800 IT. After flash, restore backup
> made prior to update. After backup is complete, load web browser and contact
> www.maemo.org. Page loads and all links work except for
> http://maemo.org/downloads/OS2007 which causes mozilla browser to close every
> time. Directly typing in http://maemo.org/downloads/OS2007 into the address bar
> also causes browser to self-terminate. 
> 
> EXPECTED OUTCOME:
> 
> ACTUAL OUTCOME:
> 
> REPRODUCIBILITY:
> (always/sometimes/once)Always
> 
> EXTRA SOFTWARE INSTALLED:Nothing that didn't come with OS2008 beta
> 
> OTHER COMMENTS:I can't install anything from the respositories or maemo
> downloads. Help!
> 

(In reply to comment #2)
> we have an internal fix for problems that match this description. without
> receiving the actual crashing data, i can't be sure.
> 
> I'm adapting the summary, reporter (and other person from irc...) please see if
> this appears to match your experience.
> 
> if we're right, the problem should be caused by:
> $ grep engine ~/.browser
> engine=opera
> 
> it should say (if it doesn't want to crash)
> engine=microb
> 

Not sure if this is the right spot to place the response. I did the grep engine
command and it reports Opera. So it seems some file in the restore carried some
opera identifier that is confusing mozilla, err MicroB
Comment 4 timeless 2007-12-04 09:03:45 UTC
*** Bug 2476 has been marked as a duplicate of this bug. ***
Comment 5 Ryan Abel maemo.org 2008-05-18 13:12:42 UTC
This one seems to be fixed, should it be resolved?