Bug 2392 - Virtual keyboards closes when the toolbar Ctrl button is pressed
: Virtual keyboards closes when the toolbar Ctrl button is pressed
Status: RESOLVED FIXED
Product: Utilities
X Terminal
: 4.0
: N800 Maemo
: Medium normal with 3 votes (vote)
: 4.1
Assigned To: unassigned
: osso-xterm-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-27 02:54 UTC by Ryan Abel
Modified: 2008-12-06 15:07 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2007-11-27 02:54:38 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Open xterm.
2. Open the virtual keyboard.
3. Press the Ctrl button on the toolbar to bring up the Control + [Text input]
prompt.

EXPECTED OUTCOME:
Prompt will open and virtual keyboard will be available to enter the desired
key.

ACTUAL OUTCOME:
Prompt opens and closes the virtual keyboard, requiring the user to tap the
text entry field in the prompt to bring it back up.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Not really a HUGE problem, but it is rather cumbersome and a bit of a usability
reducer.
Comment 1 Ryan Abel (reporter) maemo.org 2007-11-30 16:01:11 UTC
*** Bug 2416 has been marked as a duplicate of this bug. ***
Comment 2 Ryan Abel (reporter) maemo.org 2007-12-01 09:46:11 UTC
*** Bug 2445 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Abel (reporter) maemo.org 2007-12-01 09:52:08 UTC
*** Bug 2444 has been marked as a duplicate of this bug. ***
Comment 4 Marius Gedminas 2007-12-30 02:07:38 UTC
Please port the feature from the maemo-hackers.org version of osso-xterm, where
the Ctrl button in the toolbar acts like a toggle for the virtual keyboard, and
does not open any popup windows.
Comment 5 Austin Che 2007-12-30 21:01:30 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Ryan Abel (reporter) maemo.org 2008-05-22 05:26:43 UTC
Fixed in Diablo (3.2008.20-4).