Bug 2374 - Misleading repository description
: Misleading repository description
Status: RESOLVED FIXED
Product: maemo.org Website
Repositories
: 4.0
: All Linux
: High normal (vote)
: ---
Assigned To: Marcell Lengyel
: repositories@maemo.bugs
: http://repository.maemo.org/dists/chi...
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-11-24 14:49 UTC by Aleksandr Koltsoff
Modified: 2008-05-15 11:24 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Aleksandr Koltsoff (reporter) 2007-11-24 14:49:56 UTC
STEPS TO REPRODUCE THE PROBLEM:

See URL.

EXPECTED OUTCOME:

Description field should probably mention 'maemo' instead of 'Debian Nokia
repository'

ACTUAL OUTCOME:

Contents of the file as of this moment:

Archive: maemo4.0
Origin: Nokia
Label: maemo4.0
Suite: maemo4.0
Codename: maemo4.0
Date: Thu Nov 22 15:52:47 EET 2007
Architectures: armel i386 all
Components: free non-free extras
Description: Debian Nokia repository

REPRODUCIBILITY:
(always/sometimes/once)

Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

You might want to re-evaluate the contents of 'Codename' and 'Suite' as well.

At the moment there is a small inconsistency:
- the sources.list that SDK is installed with will use 'chinook' as the source.
- the Release file however points to 'maemo4.0'
- doing a coherent mirror will lead to the funny situation of having:
  - /dists/chinook
  - /pool/maemo4.0
(no other links will be created)
The above probably requires some thought to fix properly. Feel free to separate
this issue into a separate bug from the description field.
Comment 1 Aleksandr Koltsoff (reporter) 2007-11-24 14:58:29 UTC
Just an example, the following fields are from Feisty Release:
( http://fi.archive.ubuntu.com/ubuntu/dists/feisty/Release )

Origin: Ubuntu
Label: Ubuntu
Suite: feisty
Version: 7.04
Codename: feisty
Date: Tue, 17 Apr 2007 18:14:27 UTC
Architectures: amd64 hppa i386 ia64 powerpc sparc
Components: main restricted universe multiverse
Description: Ubuntu Feisty 7.04
Comment 2 Andre Klapper maemo.org 2008-05-13 17:35:19 UTC
aleksandr, this has been worked on in the meantime, can you check this again
please and tell us if it now fits your needs? thanks in advance!
Comment 3 Aleksandr Koltsoff (reporter) 2008-05-13 19:09:42 UTC
(In reply to comment #2)
> aleksandr, this has been worked on in the meantime, can you check this again
> please and tell us if it now fits your needs? thanks in advance!

It's better. Although no reason why one couldn't use spaces :-) :
"maemo 4.0.1". Also IMHO there's no reason to have the word repository in
there, since it's pretty self-evident.

If you feel particularly lazy, the current form is ok to me. Feel free to do a
FIX and I'll confirm.
Comment 4 Marcell Lengyel maemo.org 2008-05-15 11:24:36 UTC
Ok, then I am feeling particularly lazy. :) Actually, the Release files are
generated by the queue manager we are using to maintain the repositories. If
the current format is acceptable for you, then I would rather not mess with the
scripts and regenerate all the repositories and stuff. I know that this is not
a really good argument, but I would rather spend that time with fixing
something else.