Bug 2363 - Limit the size of articles appearing in Maemo Planet
: Limit the size of articles appearing in Maemo Planet
Status: RESOLVED FIXED
Product: maemo.org Website
News
: unspecified
: All Windows
: High normal (vote)
: ---
Assigned To: Henri Bergius
: news@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-23 00:35 UTC by Neil MacLeod
Modified: 2008-05-27 10:22 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neil MacLeod (reporter) maemo.org 2007-11-23 00:35:39 UTC
Please limit the size of Maemo Planet articles - some articles are mini
novels[1] that take up an inordinate amount of space on Maemo Planet.

I would suggest that when importing the articles, maemo.org should truncate the
articles at somewhere between 500-1000 words (perhaps quick analysis of past
articles would allow a suitable limit to be determined?) On truncated articles
lace a link at the end of the last paragraph with the title "Read more..." or
similar. Obviously if the article is short enough to avoid truncation then
don't provide the link!

If the article is interesting and I want to read more I'll follow the link to
the original article, but if it's not relevant to me I can scroll past the
article quite quickly. With these current mini-novel articles appearing in
Planet they simply go on and on and on... this is almost an impossible
situation when viewing Planet on the Tablet itself - the size of the page seems
to cause MicroB to bog down (memory overload?)


1.
http://ianlawrence.info/random-stuff/fosk-certificate-development-at-linux-professional-institute
Comment 1 Quim Gil nokia 2007-11-23 13:59:37 UTC
We have discussed about the possibility of cutting news. A problem in Planet is
to keep the HTML formatting when cutting, this is not always easy.

Planets in general (at least the ones I use) tend to show the posts entirely,
so I don't consider this as a top priority or even a "bug" for maemo.org...
Comment 2 Neil MacLeod (reporter) maemo.org 2007-11-23 14:17:36 UTC
(In reply to comment #1)
> We have discussed about the possibility of cutting news. A problem in Planet is
> to keep the HTML formatting when cutting, this is not always easy.

Then perhaps consider dropping entirely (or creating a placeholder with a link
for) those excessively long articles which make Planet a pain to read on the
device (and only slightly less pleasant on the desktop).

> 
> Planets in general (at least the ones I use) tend to show the posts entirely,
> so I don't consider this as a top priority or even a "bug" for maemo.org...
> 

While reproducing articles in their entirety is generally a good idea (ie. when
the articles are short and to the point) these excessively long articles really
do cause problems for Planet.

The article I linked is just one example, there have been many others in the
past and there will be many more in future. These long articles make the
reading of Maemo Planet on the device next to impossible - I gave up today
because a) the device became largely unresponsive and b) scrolling past the
offending article would have taken the best part of 5 mintues.

Reproducing articles in their entirety means the Planet page will balloon out
of control on those occasions when excessively long articles appear - worst
case, there may be several such articles on the page together.

Imposing some sort of limit such as word count truncation or replacing too-long
articles with a placeholder should ensure that Planet remains accessible at all
times - a Planet for Nokia Tablets that can't be viewed easily on Nokia Tablets
is most definately a bug (of sorts)! :)
Comment 3 eero.afheurlin 2008-05-08 17:22:44 UTC
If post is longer than 450 words (value adjustable if needed) only the first
paragrap is shown along with link to the full post. If system cannot determine
what constitutes the "first paragraph" or it's too long only the link is shown.
Comment 4 Neil MacLeod (reporter) maemo.org 2008-05-08 21:23:52 UTC
(In reply to comment #3)
> If post is longer than 450 words (value adjustable if needed) only the first
> paragrap is shown along with link to the full post. If system cannot determine
> what constitutes the "first paragraph" or it's too long only the link is shown.
> 

Eero - you marked this bug "resolved fixed" so is your comment above describing
how the Planet is supposed to be working today, because that isn't how it works
at all (have you deployed your changes yet? That might explain the lack of any
obvious improvement). As things stand today, some articles are cut at the first
paragraph while others go on and on and on...

I'm not sure that a link needs to be added as the title for the article is a
hyperlink to the real deal - just append elipses (ie. [...] which already
appears for _some_ articles) or the message "Click title to read full article"
to the end of the shortened article.
Comment 5 Neil MacLeod (reporter) maemo.org 2008-05-13 15:20:50 UTC
(In reply to comment #3)
> If post is longer than 450 words (value adjustable if needed) only the first
> paragrap is shown along with link to the full post. If system cannot determine
> what constitutes the "first paragraph" or it's too long only the link is shown.

I think you're referring to News articles on the Maemo home page (maemo.org)
and not the Planet page - articles appearing on Maemo Planet
(http://maemo.org/news/planet-maemo/) page do not appear to be truncated as you
describe.

Reopening, as this bug relates to Maemo Planet which still contains excessively
long articles. Close this bug as "WONT FIX" if necessary, but marking it as
"resolved fixed" when the fix in comment #3 is to a page other than Maemo
Planet is not the correct resolution. :)
Comment 6 Henri Bergius 2008-05-27 10:22:31 UTC
It seems the size limiter is now operational on Planet Maemo.

"Click to read 642 more words"