Bug 2347 - Non-tablet software related to Maemo should be available through downloads
: Non-tablet software related to Maemo should be available through downloads
Status: RESOLVED FIXED
Product: maemo.org Website
Downloads
: unspecified
: All Windows
: High enhancement (vote)
: ---
Assigned To: Niels Breet
: downloads@maemo.org
: http://lists.maemo.org/pipermail//mae...
:
:
:
  Show dependency tree
 
Reported: 2007-11-22 11:31 UTC by Andrew Flegg
Modified: 2008-03-31 22:40 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2007-11-22 11:31:42 UTC
EXPECTED OUTCOME:
* Going to http://downloads.maemo.org/ should show a "PC" tab next to OS2006,
OS2007 and OS2008 to allow the download of non-tablet software such as:
   * tablet-encode
   * mediaserv
   * Nokia Internet Tablet Video Converter
   * 770Flasher.app
   * Media Converter
   * 0xFFFF
   * Maemo SDK VMware Image
   * etc.

See the attached URL for more details.

ACTUAL OUTCOME:
* Only software which *runs* on Maemo releases can be added to the downloads
site.
Comment 1 Quim Gil nokia 2007-11-22 12:28:49 UTC
Yes, as agreed in maemo-developers.

Let's see when Nils has the time. I'm looking at the layout and it seems that
we will need to resize buttons to find a place for "PC" to the right of OS2006.
Comment 2 Niels Breet maemo.org 2007-11-22 17:22:52 UTC
Ok, will draft something up when I can find some time.
Comment 3 Andrew Flegg (reporter) maemo.org 2008-03-23 09:51:12 UTC
Is there any progress on this?

Anything I can do to assist?
Comment 4 Niels Breet maemo.org 2008-03-25 10:35:15 UTC
(In reply to comment #3)
> Is there any progress on this?
> 
> Anything I can do to assist?
> 

It is almost done. I'm testing it on our internal test machine.

I still need the PC icon for the site and need to make a list of categories we
want to support. Feel free to suggest other ones ;)

At the moment I have these categories:
- Multimedia
- Software Development
- Synchronization
Comment 5 Andrew Flegg (reporter) maemo.org 2008-03-25 11:35:55 UTC
The categories should probably be as close to the maemo ones. Ones I think are
missing from your list:

- Flashing/Upgrading/some better term (e.g. pancake's 0xFFFF)
- Desktop Environment (e.g. Urho Kontorri's Theme Maker)

Thinking ahead, things like noBounds-like software might need to go somewhere.
"Remote Control", perhaps? This bridge can be crossed when we get to it if it's
easy to add new categories, and there's no conflict with the existing ones.
Comment 6 Niels Breet maemo.org 2008-03-31 14:11:41 UTC
PC downloads are now available at:
https://maemo.org/downloads/PC/

Please test if everything works for you.

I have disabled the 'PC' icon, because I'm still testing things before I want
to open it to the general public. If everything works OK, I will enable the
icon and announce the availability of the new feature.
Comment 7 Andrew Flegg (reporter) maemo.org 2008-03-31 14:18:14 UTC
Thanks.

I'll give it a test. One immediate minor niggle is that the <title /> is
"maemo.org - PC PC" which looks a bit weird.
Comment 8 Andrew Flegg (reporter) maemo.org 2008-03-31 14:37:34 UTC
Thanks.

I'll give it a test. Some comments so far:

* The <title /> of the category page is "maemo.org - PC PC" which looks a bit
weird.

* Adding an application: it's not clear what the distinction between "name" and
"title" is when uploading screenshots. Clicking the only toolbar item which
might open help opens the Midgard about page, losing all the data entered.

* Problem with uploading screenshots:
1) Created an entry for tablet-encode and uploaded
http://mediautils.garage.maemo.org/images/gui1.png as the first screenshot with
name: gui1, title: "Selecting an image in the GUI" and clicked "Upload image".
It seemed to work correctly.

2) Entered name: gui2, title: "Progress reporting in the GUI" and uploaded
http://mediautils.garage.maemo.org/images/gui2.png. Thumbnail for first
screenshot disappeared, replaced with a small blue box; second image was not
seen.

3) No screenshots on resulting entry:
https://maemo.org/downloads/product/325f8ffeff1611dcbaea41b18ece57115711/

* Clicking "Click to install" green arrow gives a server error:

--------8<--------
Server Error

Error 500
maemo.org
Mon, 31 Mar 2008 14:34:10 +0300
Apache

Stacktrace:
1: /var/cache/midgard/midgard/9-49-31-0.php:0 {main}
2: /var/cache/midgard/midgard/9-49-31-0.php:246 midcom_application::codeinit
3: /usr/share/php/midcom/lib/midcom/application.php:543
midcom_application::_process
4: /usr/share/php/midcom/lib/midcom/application.php:1094
midcom_application::_handle
5: /usr/share/php/midcom/lib/midcom/application.php:1198
midcom_application::generate_error
-------->8--------

[from
https://maemo.org/downloads/product/raw/325f8ffeff1611dcbaea41b18ece57115711/?get_installfile
]
Comment 9 Andrew Flegg (reporter) maemo.org 2008-03-31 14:42:11 UTC
Now product is created, I tried re-adding the screenshots:

1) First uploaded fine.

2) Second image uploaded fine.

Clicked "Save" and the page is now showing the screenshots correctly.
Comment 10 Andrew Flegg (reporter) maemo.org 2008-03-31 14:43:23 UTC
This may be related to the lack of enablement for the "PC" button, but:

https://maemo.org/downloads/product/325f8ffeff1611dcbaea41b18ece57115711.html

...has "OS2008" highlighted on the right-hand side navigation and shows an
OS2008 tag cloud.
Comment 11 Niels Breet maemo.org 2008-03-31 14:47:43 UTC
(In reply to comment #9)
> Now product is created, I tried re-adding the screenshots:
> 
> 1) First uploaded fine.
> 
> 2) Second image uploaded fine.
> 
> Clicked "Save" and the page is now showing the screenshots correctly.
> 
There is a problem with the images datatype in datamanager, will look into
that.
Comment 12 Niels Breet maemo.org 2008-03-31 14:51:27 UTC
(In reply to comment #10)
> This may be related to the lack of enablement for the "PC" button, but:
> 
> https://maemo.org/downloads/product/325f8ffeff1611dcbaea41b18ece57115711.html
> 
> ...has "OS2008" highlighted on the right-hand side navigation and shows an
> OS2008 tag cloud.
> 
No, this is a bug. When using the non-guid type url, it works fine.
https://maemo.org/downloads/product/PC/tablet-encode/

The problem is that the sidebar has no knowledge of the product's group
displayed in the content portion. With guids it can't get it from the url. I'm
working on a fix for this.
Comment 13 Andrew Flegg (reporter) maemo.org 2008-03-31 14:54:55 UTC
"Download" statistics should be disabled for non-tablet software (since it
won't be in extras(-devel)). Ideally, it would link in download statistics to
garage releases if the download URL is a garage.maemo.org one.
Comment 14 Niels Breet maemo.org 2008-03-31 14:59:57 UTC
(In reply to comment #13)
> "Download" statistics should be disabled for non-tablet software (since it
> won't be in extras(-devel)). Ideally, it would link in download statistics to
> garage releases if the download URL is a garage.maemo.org one.
> 

I've already disabled that in svn, I still need to pull that to the live
website.

We might want to think about the garage statistics as a feature request.
Comment 15 Niels Breet maemo.org 2008-03-31 22:15:47 UTC
(In reply to comment #10)
> This may be related to the lack of enablement for the "PC" button, but:
> 
> https://maemo.org/downloads/product/325f8ffeff1611dcbaea41b18ece57115711.html
> 
> ...has "OS2008" highlighted on the right-hand side navigation and shows an
> OS2008 tag cloud.
> 

This bug has been fixed now.
Comment 16 Niels Breet maemo.org 2008-03-31 22:40:46 UTC
This is now live on maemo.org.