Bug 2326 - Add option to add only online contacts
: Add option to add only online contacts
Status: RESOLVED WONTFIX
Product: Desktop Widgets
Contacts
: 4.1 (4.2008.23-14)
: All Linux
: Low enhancement with 3 votes (vote)
: Harmattan
Assigned To: unassigned
: speed-contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-19 17:06 UTC by Daniel Martin Yerga
Modified: 2009-05-25 10:34 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Daniel Martin Yerga (reporter) 2007-11-19 17:06:56 UTC
EXPECTED OUTCOME:
Speed contacts applet has an option to add only online contacts.

ACTUAL OUTCOME:
Speed contacts applet lets you choose only certain contacts, even if they are
connected or disconnected.

OTHER COMMENTS:
Well, the feature request is quite clear and I don't think we need any further
comment. Only to say that it would be a feature that people would appreciate,
and that doesn't seem very complicated to make, since the Contacts application
already has support for this.
Comment 1 Philippe 2007-12-03 22:04:44 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Jussi Kukkonen 2008-02-03 00:29:31 UTC
*** Bug 2872 has been marked as a duplicate of this bug. ***
Comment 3 Roope Rainisto nokia 2008-12-03 17:12:29 UTC
Not in plans for Fremantle, but should be possible in Harmattan with current
understanding. Assigning as UI enhancement.
Comment 4 Quim Gil nokia 2009-05-21 14:20:18 UTC
To be more precise, in Fremantle the 'Speed Contacts' widget has been dropped
in favor of the possibility to have direct shortcuts to your preferred contacts
showing their status. The rationale behind this is that normally people have
preferred contacts and being online or not is _a side effect_. If you want to
contact them you still have other means e.g. email.

Since all the information is available, someone still could develop such widget
showing e.g. the most recent contacts online.

In Harmattan there are more complex plans for 'connecting people', but they are
not going to be the same 'Speed Contacts' widget anymore.

After saying al this, I'm not sure what is the status of this enhancement
request...  :)
Comment 5 Andre Klapper maemo.org 2009-05-21 15:38:06 UTC
Dyerga: Are you fine with this?
(If so, WORKSFORME is probably more appropriate than FIXED).
Comment 6 Daniel Martin Yerga (reporter) 2009-05-21 16:19:39 UTC
(In reply to comment #5)
> Dyerga: Are you fine with this?
> (If so, WORKSFORME is probably more appropriate than FIXED).
> 

Yeah, but IMHO it would be WONTFIX/INVALID, more than WORKSFORME or FIXED.

Also, though I am the reporter, there are votes from other people so I am not
the only person to decide this ;)
If nobody says something against the resolution, go with it.
Comment 7 Roope Rainisto nokia 2009-05-25 10:34:48 UTC
Yes to comment #4: It describes the Fremantle approach. For Harmattan, there
are ways to do things, but... I'd narrow this down to the specific issue of
Speed contacts applet, and as a request for that specific applet I'd say
wontfix: we're not planning to improve that applet in that specific way.  

(That is not to say that you couldn't easily do a new applet that does whatever
you want...)