Bug 2321 - Profile has been wiped out
: Profile has been wiped out
Status: RESOLVED FIXED
Product: maemo.org Website
Profile
: unspecified
: All Windows
: High major (vote)
: ---
Assigned To: eero.afheurlin
: profile-bugs
: https://maemo.org/profile/view/jaffa
:
:
: 2323
  Show dependency tree
 
Reported: 2007-11-19 12:50 UTC by Andrew Flegg
Modified: 2008-12-06 18:45 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2007-11-19 12:50:18 UTC
EXPECTED OUTCOME:
Going to my profile page shows my karma (last seen at around 75), profile
picture and profile information.

ACTUAL OUTCOME:
Going to my profile page shows a blank profile with 0 karma.

STEPS TO REPRODUCE THE PROBLEM:
Go to https://maemo.org/profile/view/jaffa

OTHER COMMENTS:
Also affecting kulve, see https://maemo.org/profile/view/kulve
Comment 1 Niels Breet maemo.org 2007-11-19 12:56:13 UTC
Cron was down over the weekend. So the karma didn't get recounted. I've
restarted cron on maemo.org, so that should fix the karma count.


I can't explain why the other info in your account is gone. (Website and
picture)
Comment 2 Henri Bergius 2007-11-19 13:05:13 UTC
[12:54] bergie: X-Fade: yes... it seems the user export from Garage produced a
feed with lots of users missing
[12:54] bergie: so the users were marked as removed
[12:54] bergie: and then next export created new user records
[12:56] Jaffa: Sounds fairly fatal.
[12:56] bergie: Jaffa: no data was deleted so we can recover
[12:57] X-Fade: bergie: garage was down this weekend for some time. Maybe that
is why the userfeed was empty ;)
[12:57] bergie: the gforge exporter will need some auditing, though
[12:57] bergie: X-Fade: could be, yes
[12:57] Jaffa: bergie: cool - although it's only a few URLs and a picture, I'm
a lazy individual :)
[12:58] bergie: Jaffa: it is a bit more than that... favs, dev program etc
[12:58] bergie: Jaffa: now they all belong to "your former self"... we just
need to reassign them to the active account
[12:59] Jaffa: bergie: ah, good point. ta.
[13:00] X-Fade: Jaffa: You got cloned over the weekend ;) But something went
horribly wrong. Frankenstein style...
Comment 3 Graham Cobb maemo.org 2007-11-19 17:27:00 UTC
Same for me (gcobb).  Do I need to do something to get it restored?

I notice that the Application Catalogue pages which have me as Owner or Author
are also screwed up (so screwed up that the UI has broken and no more authors
can be added).  I presume these have links to some internal ID for my account. 
Will these be fixed by the restoration?

Graham
Comment 4 eero.afheurlin 2007-11-19 17:34:53 UTC
A script to fix these issues is running on the live server now, will probably
take a while.
Comment 5 Quim Gil nokia 2007-11-20 07:56:09 UTC
This is not fixed yet. See http://maemo.org/profile/view/andy80 (he complained
via email)

Clicking randomly at
http://maemo.org/news/announcements/view/500_fortunate_applicants.html is
enough to see that there are still many problems (404 in some cases, Midgard
errors in some other)

Please don't solve as fixed until you can check is fixed. ("fixed" bugs don't
appear in default searches, for instance)
Comment 6 Quim Gil nokia 2007-11-20 07:56:42 UTC
*** Bug 2330 has been marked as a duplicate of this bug. ***
Comment 7 eero.afheurlin 2007-11-20 10:00:57 UTC
The script had aborted when kernel had refused to give it more memory (juggling
7500+ accounts and all their dependencies can take some...), made some
adjustments and restarted.

Some things cannot be undeleted, we're (still, asked for it already yesterday)
waiting for info from the ISP regarding that days backups (we can set up
another DB from the backup data and then replicate things that cannot be
undeleted).
Comment 8 mike morrison 2007-11-21 11:33:52 UTC
It appears that my account was affected as well. I can't log in and my profile
page cannot be found:

http://maemo.org/profile/view/mike_morrison

I think this also affects the user comments in the downloads pages (correct me
if I'm wrong). If you take a look at some of the comments you'll see stuff like
this (notice the blank where the username should be):

Rated ***** by  (2007-11-16 13:17):
Comment 9 Graham Cobb maemo.org 2007-11-21 12:43:28 UTC
Some improvement, thanks.  My profile is now correctly linked to the
application download pages for which I am an Author.  But all the Owners seem
to have disappeared (Florian Boor was the Owner of many of the pages on which I
am an Author and he is no longer mentioned).

Also, my "Alter Egos" information is still missing.

But I have got my karma back -- I can sleep quietly again :-)
Comment 10 Andrea Grandi 2007-11-22 10:20:25 UTC
I confirm that my profile is still "deleted".
Comment 11 Jake Kunnari 2007-11-22 14:09:49 UTC
*** Bug 2349 has been marked as a duplicate of this bug. ***
Comment 12 eero.afheurlin 2007-11-23 15:48:24 UTC
Status update: We got some data from backups from the ISP today, will look into
what can be restored ASAP.
Comment 13 Andrea Grandi 2007-11-23 15:51:20 UTC
Is it better if, for the moment, I (andy80) don't try to subscribe again to
maemo.org website? I hope you can recover all my data (profile, posted
documents, karma ecc...).

Thanks!
Comment 14 mike morrison 2007-11-30 03:41:05 UTC
Is there any progress being made with the backup data? I would sure like to be
able to log in. If it is turning out to be too much effort to restore the lost
data, would it be easier to simply recreate the accounts? (I'm not aware of any
critical information held within these accounts)
Comment 15 eero.afheurlin 2007-11-30 13:17:39 UTC
I fixed some final weirdnesses when fixing depedencies (multiple person objects
that belong to same real-world person), and what could be restored has been
restored.

Karma might be slightly off for some people but it's recalculated nightly, so
tomorrow it should be fine.

As stated earlier we no longer delete anything based on stuff missing from
garage dumps (since this incident proved for good that we cannot trust garage
to always give us good data), this means that if someone wants to remove their
account they must ask maemo.org admins to remove it manually (Ferenc/Quim: This
needs to be stated somewhere).

We also have setup local database backups on the server itself so that if we
need to restore data in the future we don't have to wait for the ISP for what
they happen to have (also the resolution for local backups is 4 hours).
Comment 16 Andrea Grandi 2007-11-30 13:39:34 UTC
I confirm that my profile (andy80) is back, but I cannot upload a pic of myself
anymore, like in the old profile. And I look like I wasn't part of the "N810
discount program" (don't worry... I already got my discount code.. it's just to
tell what is missing).

Thanks :)
Comment 17 eero.afheurlin 2007-11-30 14:09:50 UTC
> I confirm that my profile (andy80) is back, but I cannot upload a pic of myself
anymore, like in the old profile.

Error message ? or is it the overflow: hidden in the layout that at least for
me messes up the "publish account details" -form.

> And I look like I wasn't part of the "N810
discount program" (don't worry... I already got my discount code.. it's just to
tell what is missing).

Some dependencies are wrong, one possible reason is that you have two accounts:
andy80 and andreagrandi with same email (which we use as a way to find all the
person objects in the DB that belong to same real-world person).
Comment 18 Andrea Grandi 2007-11-30 14:16:44 UTC
The field that let me upload PIC in my profile is simply MISSING. No errors...

About the other profile "andreagrandi" PLEASE delete it. I don't use it. It was
just a test when I tried to subscribe ad I didn't remember my password. You can
delete "andreagrandi" (I hope it has not been assigned any karma).

Thanks!
Comment 19 eero.afheurlin 2007-11-30 14:24:13 UTC
> The field that let me upload PIC in my profile is simply MISSING. No errors...
>

See "publish account details" from toolbar for the place where to upload photo.

> About the other profile "andreagrandi" PLEASE delete it. I don't use it. It just a test when I tried to subscribe ad I didn't remember my password. You can
delete "andreagrandi" (I hope it has not been assigned any karma).

Seems andreagrandi has most of the interesting stuff (like photo), I'll move
the data to andy80 and delete andreagrandi.

On a general note: This might not be an isolated case and I'm pretty sure the
only way to fix this properly is for each person who has created another (or
more...) account to do it separately and semi-manually after they tell which
account they intend to actually use.
Comment 20 Andrew Flegg (reporter) maemo.org 2007-12-01 15:44:06 UTC
My karma has dropped rapidly (overnight?) and is being totalled incorrectly:

( from http://maemo.org/profile/view/jaffa )
Karma              77
Software     30
Bugs             64
Wiki            0
News             33
Discussion     92
Comments     0
Rating             10
--------------------
TOTAL           229

77 may have been a very old karma score whilst things weren't being counted
right (it may also have been the karma score I had when garage blanked
everything out).
Comment 21 eero.afheurlin 2007-12-13 13:58:02 UTC
After nightly karma recount you karma is correct and totalled correctly.
Comment 22 Ferenc Szekely maemo.org 2007-12-21 21:07:54 UTC
Can y pls verify and close this?
Comment 23 mike morrison 2007-12-21 21:15:50 UTC
My profile works again but my karma is not being totalled correctly:

Karma      0
Software   125
Bugs       16
Wiki       0
News       0
Discussion 22
Comments   2
Rating     0