Bug 2296 - Karma not counted in ITt feed
: Karma not counted in ITt feed
Status: RESOLVED WORKSFORME
Product: maemo.org Website
Profile
: unspecified
: All Windows
: High normal (vote)
: ---
Assigned To: Henri Bergius
: profile-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-16 17:40 UTC by Roger Sperberg
Modified: 2008-12-06 18:45 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Roger Sperberg (reporter) 2007-11-16 17:40:46 UTC
EXPECTED OUTCOME:
Posts to different blogs or websites or bugzilla ought to be counted, even
though my login is different at different places

ACTUAL OUTCOME:
I log in as RogerS at ITT, but as rsperberg@gmail.com at bugzilla and as
rsperberg in some other sites.

STEPS TO REPRODUCE THE PROBLEM:

OTHER COMMENTS:

As one of the earliest users at ITT, I was able to choose my first name and
last initial, RogerS, as my username. Usually though this name is taken (eg, at
gmail), and so I end up as rsperberg elsewhere.

My posts in the news feed at ITT are identifed as
<dc:creator>RogerS</dc:creator>.

There ought to be some way for those posts to go into the right place -- for me
to specify that username at that website in the Karma stuff.
Comment 1 Quim Gil nokia 2007-11-19 11:48:24 UTC
I have renamed the bug since this is the only issue addressed here.

About the rest: currently maemo karma is being counted on your maemo userId.
Your activity in bugs.maemo.org and the maemo mailing lists is counted as well
if you are using the same email address (see Bug 2212 for adding more email
addresses).

Your karma will be affected also by blog posts published in a feed aggregated
in maemo planet (it should work also for your posts in the ITt feed, otherwise
file bug).

Currently there is no karma for ITt activity, this is being discussed at Bug
2303 and Bug 2304
Comment 2 Roger Sperberg (reporter) 2007-11-19 21:17:55 UTC
Not sure the issue is addressed by your response.

I do use the same email address in maemo.org and bugs.maemo.org, just different
usernames.

But the Karma from Bugzilla is zero.

Perhaps bugs are counted differently from enhancements?
Comment 3 Quim Gil nokia 2007-11-20 09:20:06 UTC
For issues wityh bug activity not being counted in karma see Bug 2196

Let's look here at why your posts in the ITt feed are not counted in your
karma.
Comment 4 Quim Gil nokia 2008-10-01 10:28:31 UTC
Changed priority to HIGH since this seems related to the ITt integration tasks
Henri has committed for the October sprint.
Comment 5 Henri Bergius 2008-10-29 15:55:38 UTC
This is little different from counting ITT feeds and thanks, as those are
handled by separate custom Karma plugins.

Blog karma counting is based on RSS importer setting the correct user to the
article.

If the ITT blog feed uses the <dc:creator /> field, then the value of that
field must be either the user's full name or username matching to the ones in
maemo.org database.

Marking WORKSFORME as this is better solved on the ITT end. If some custom
solution like username mapping between ITT and maemo.org is needed, please
reopen.