Bug 2290 - Double-keypress on power key can enter soft poweroff mode, but not exit
: Double-keypress on power key can enter soft poweroff mode, but not exit
Status: RESOLVED WONTFIX
Product: System software
Device lock
: 4.0
: All Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: device-lock-bugs
:
:
:
: 3462
  Show dependency tree
 
Reported: 2007-11-16 01:37 UTC by Ryan Abel
Modified: 2008-12-06 17:03 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2007-11-16 01:37:10 UTC
EXPECTED OUTCOME:

A double-keypress on powerkey (with edited mce.ini) will put the device into
sof poweroff mode, and a second double-keypress will wake the device from soft
poweroff mode.

ACTUAL OUTCOME:

A double-keypress puts the device into soft poweroff mode, but a second
double-keypress (in soft poweroff mode) will not wake the device, requiring the
user to enable soft poweroff on a long-press to wake it.

STEPS TO REPRODUCE THE PROBLEM:

1. Edit /etc/mce/mce.ini to enable soft poweroff for a double keypress on the
power key (also enable soft poweroff on a long press to allow you to wake the
device).
2. Restart to load settings.
3. Double-keypress on the powerkey to enter soft poweroff mode.
4. Do a second double-keypress on the powerkey while in soft poweroff mode
(which will not wake the device; use long keypress to wake).
Comment 1 Laszlo Marai 2008-01-03 04:57:45 UTC
Isn't is possible that this bug is related to #2673? (Some newer? n800 and n810
devices won't power up only if they are put on the charger first).
Comment 2 Ryan Abel (reporter) maemo.org 2008-01-06 06:39:28 UTC
(In reply to comment #1)
> Isn't is possible that this bug is related to #2673? (Some newer? n800 and n810
> devices won't power up only if they are put on the charger first).
> 

Well, considering that soft power off doesn't really have anything to do
booting, no.

Really, though, this bug is irrelevant until soft power off is actually
functional again.
Comment 3 David Weinehall nokia 2008-07-23 16:31:35 UTC
Since the soft poweroff is supposed to simulate poweroff, having the device
"boot" on double [power] is counter-intuitive, since the device doesn't
normally boot when [power] is pressed twice (and NO, the fact that the
operation isn't 1:1 isn't a valid reason; you cannot open the device menu and
choose to power on the device when it's off either...)
Comment 4 Ryan Abel (reporter) maemo.org 2008-07-23 23:39:09 UTC
(In reply to comment #3)
> Since the soft poweroff is supposed to simulate poweroff, having the device
> "boot" on double [power] is counter-intuitive, since the device doesn't
> normally boot when [power] is pressed twice (and NO, the fact that the
> operation isn't 1:1 isn't a valid reason; you cannot open the device menu and
> choose to power on the device when it's off either...)
> 

Then remove the option from mce.ini. If you don't think the features makes
sense, why was it implemented?
Comment 5 Ryan Abel (reporter) maemo.org 2008-07-23 23:48:47 UTC
Upon re-reading, what you see to be saying is that it makes sense for the user
to be able to do one half of the soft poweroff-cycle operation with a
double-keypress but not the other?

No words. . . .
Comment 6 David Weinehall nokia 2008-07-25 15:55:15 UTC
OK, let's take this very, very, very slowly:

[normal poweroff]
1. Powering off the device can be achieved manually in (at least) two ways:
using the power button (single/double/long press configurable; long default),
and using the "Switch off!" option in the device menu
2. Powering on the device can be achieved manually in (at least) two ways:
using the power button (long press, not configurable), and connecting a charger

[soft poweroff]
1. Powering off the device can be achieved manually in (at least) two ways:
using the power button (single/double/long press configurable; disabled
default, since soft poweroff isn't a supported feature), and using the "Soft
poweroff" option in the device menu (again not enabled by default)
2. Powering on the device can be achieved manually in one way (I've realised
that for consistency modifying this to wake on charger might make sense); using
the power button (long press, not configurable)

The only thing that distinguishes soft poweroff from poweroff (apart from
charger not disabling soft poweroff) is that the led obviously don't blink when
the device is off, while it does in soft poweroff (unless the device on led is
disabled).  If this feature is ever granted some sort of official status, soft
poweroff will likely get its own pattern.

So, YES, I am saying that it makes sense for the user to be able to enter soft
poweroff by different means than waking from it.  The reason [power] double
click option was added as an option for entering soft poweroff is fairly easy
to explain; single press and long press already have assigned actions.

Once in soft poweroff, doing a "real" shutdown on long press in soft poweroff
would be counter-intuitive, since to most appearances, the device *is* already
off.  Thus we can use the intuitive way of powering up; the way the user is
used to; long [power] press.

I can of course understand your reasoning, I'm just saying that I don't agree,
and as long as this functionality remains a bonus add-on rather than a product
requirement, I'll implement things I believe makes sense.  If you want perfect
symmetry I can remove the double-click option from the list of supported
options for entering soft poweroff instead.