Bug 2247 - No way to clear/reset word prediction dictionary
: No way to clear/reset word prediction dictionary
Status: RESOLVED WONTFIX
Product: Desktop platform
Input method framework
: 5.0-beta
: All Linux
: Low enhancement with 14 votes (vote)
: ---
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-10 09:34 UTC by Jesse Michael
Modified: 2012-03-24 11:47 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jesse Michael (reporter) 2007-11-10 09:34:50 UTC
EXPECTED OUTCOME:

As far as I can tell, there's no way to clear (or return to the defaults) the
dictionary that is used for word prediction short of selecting "Clear user
data..." from the Control Panel (which erases lots of other things as well).

ACTUAL OUTCOME:

Should be an easy to use option to clear prediction dictionary similar to the
"Tools->Clear" menu in the Browser app.

STEPS TO REPRODUCE THE PROBLEM:

Use xterm+ssh client to login to remote server.  There's no easy way to remove
password which has now been recorded into word prediction dictionary.
Comment 1 Andre Klapper maemo.org 2009-06-15 11:46:38 UTC
Quoting a workaround from http://talk.maemo.org/showthread.php?t=29550 for
Diablo:

1) You can tap and hold on the offending word and hit remove.           OR
2)(This'll delete ALL words) - rm ~/.osso/hildon-input-method/*.dictionary
Comment 2 Saturn 2009-09-05 15:46:02 UTC
New words should go to an additional dictionary e.g. custom.dictionary (not
sure if this already done) and allow text editor view/edit too.
Comment 3 Andre Klapper maemo.org 2009-12-30 21:54:25 UTC
Note that dictionary data in Maemo5 is stored in the files
   /home/user/.osso/dictionaries/.personal.dictionary
   /home/user/.osso/dictionaries/.used.dictionary
Comment 4 dougalf 2010-02-21 11:52:13 UTC
I can't recreate the saving of an ssh password from an xterm but nor can I use
the workaround of highlighting and getting an option to delete from dictionary.
which app does this work in?

my problem is I was entering username and password for a std website
authentication and missed the tab button so now when I type my username to
login again it autocompletes with the password! Amusing but insecure.

Is the real bug that microB shouldn't add usernames to dictionary?

cheers,
 Dougal
Comment 5 Nelson Ferreira 2010-02-21 19:26:31 UTC
I agree that MicroB should not add passwords to the dictionary

but..

There should also be a way to edit the dictionary to remove unintended typos
that creep in. It is a glaring omission not to be able to do it...
Comment 6 Andre Klapper maemo.org 2012-03-24 11:47:16 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )