Bug 2237 - (zoran) maemo.org gives authorization request error on "yu" domain
(zoran)
: maemo.org gives authorization request error on "yu" domain
Status: RESOLVED WONTFIX
Product: maemo.org Website
Repositories
: 2.2
: 770 other
: High normal (vote)
: ---
Assigned To: Quim Gil
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-08 17:38 UTC by zoran
Modified: 2008-10-07 16:35 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description zoran (reporter) 2007-11-08 17:38:32 UTC
EXPECTED OUTCOME:refreshing rep lists from 770 and gregale.Downloading files
from repositories on maemo.org site

ACTUAL OUTCOME:failed to refresh since the actual connection failed to find
apps and pass authorization request. No list refresh on 770 and no file
download via browser.

STEPS TO REPRODUCE THE PROBLEM:the problems exists on "yu" domain only.From
that domain I cannot refresh the lists on 770. Manualy going to
repository.maemo.org/pool/gregale/free, any file is not available, since
authorization request error message. Using remote box, on any non-yu domain, I
could download all files as it was expected. I think the problem is the exact
server, not allowing access from "yu" domain.

OTHER COMMENTS:The problem comes to reality just few days ago. No configuration
change on 770 and no any change on desktop box.
Comment 1 zoran (reporter) 2007-11-11 08:50:02 UTC
Authorization Required
This server could not verify that you are authorized to access the document
requested. Either you supplied the wrong credentials (e.g., bad password), or
your browser doesn't understand how to supply the credentials required.

Apache/1.3.33 Server at ossostage.cidercone.com Port 80
Comment 2 zoran (reporter) 2007-11-11 08:54:08 UTC
Authorization Required
This server could not verify that you are authorized to access the document
requested. Either you supplied the wrong credentials (e.g., bad password), or
your browser doesn't understand how to supply the credentials required.

Apache/1.3.33 Server at ossostage.cidercone.com Port 80
Comment 3 zoran (reporter) 2007-11-11 09:09:37 UTC
Domain "sbb.co.yu" is not able to get files from repository.maemo.org. Error
401 was issued.
Comment 4 Quim Gil nokia 2008-02-08 08:36:47 UTC
After some investigation, this is what seems to be happening: 

Our download infrastructure is common to all Nokia and due to US legislation
there are some countries that get filtered unless a specific download service
is put for them.

As Nokia doesn't have official distribution in Yugoslavia for the Internet
tablets, it might be possible that you are suffering the consequences of this
filtering.

There is little to nothing we can do about this in the short term at maemo. I'm
really sorry about this.

Closing the bug. "wontfix" is the nearest status I've found although it's not
accurate. If one day there are devices with maemo software sold in Yugoslavia
then the service will work as well. 

Please reopen the bug if you feel this is not the cause.
Comment 5 sam 2008-03-24 09:49:17 UTC
please i have this message:

Authorization Required
This server could not verify that you are authorized to access the document
requested. Either you supplied the wrong credentials (e.g., bad password), or
your browser doesn't understand how to supply the credentials required.

Apache/1.3.33 Server at ossostage.cidercone.com Port 80



in iran too
Comment 6 Aleksandr Koltsoff 2008-03-24 09:51:33 UTC
*** Bug 3029 has been marked as a duplicate of this bug. ***
Comment 7 Aleksandr Koltsoff 2008-03-24 09:52:06 UTC
*** Bug 2939 has been marked as a duplicate of this bug. ***
Comment 8 Aleksandr Koltsoff 2008-03-24 10:00:10 UTC
Additional "bugs" relating to this one/giving 401 (for people who actually
search the bugzilla):

https://bugs.maemo.org/show_bug.cgi?id=798
https://bugs.maemo.org/show_bug.cgi?id=1896

So it seems that sometimes this is a "country" thing (Iran, Syria, Yogoslavia)
and sometimes it is a problem in some setting in akamai (798, 1896) and yet
sometimes it's related to the amount of requests coming from a single (NATted)
IP.
Comment 9 Andre Klapper maemo.org 2008-06-13 22:33:02 UTC
Sam: If it's basically the same issue, then comment #4 by Quim also applies.
Comment 10 Andre Klapper maemo.org 2008-10-07 16:35:42 UTC
Removing deprecated "Future" Target Milestone from WONTFIX bugs.