Bug 2155 - Downloads statistics in extras repository
: Downloads statistics in extras repository
Status: RESOLVED FIXED
Product: maemo.org Website
Repositories
: unspecified
: All Linux
: Medium enhancement (vote)
: ---
Assigned To: Niels Breet
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-23 08:28 UTC by Quim Gil
Modified: 2008-04-07 09:50 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Quim Gil (reporter) nokia 2007-10-23 08:28:13 UTC
EXPECTED OUTCOME:

Application developers want to the downloads of their apps in the extras
repository.

ACTUAL OUTCOME:

STEPS TO REPRODUCE THE PROBLEM:

OTHER COMMENTS:
It seems that this is one of the reason why developers would prefer to set
their own repos. This feature is important then, since we are promoting extras
as primary repo.
Comment 1 Ferenc Szekely maemo.org 2007-10-23 11:08:44 UTC
I am testing the web based reporting tool. It seems we can get scheduled
reports in form of csv files via email. Now we just need to setup a nice
parsing mechanism which would deliver info from these reports to the website.
Comment 2 Niels Breet maemo.org 2007-10-31 15:19:14 UTC
When we make applications in the AC use the same unixname as their package, we
can easily parse the logs and grep the unix name and target OS. We can then do
a midgard lookup in the products database and increase the downloads counter
when the product is found.

This can run as a cronjob.

Another method I tested is by placing a .htaccess file in the pool directories
and  run a php file on each download. This way we can beat the caching network,
if that needs to be circumvented.
Comment 3 Ferenc Szekely maemo.org 2008-02-01 23:21:56 UTC
Since I quit I'd like to reassign this bug.
Comment 4 Niels Breet maemo.org 2008-02-13 11:53:00 UTC
Marcell gave me some download statistics for the repositories. I can parse that
data to generate weekly statistics. We need to decide where we want to display
these statistics and where/how we are going to store that somewhere.
Comment 5 Niels Breet maemo.org 2008-04-07 09:50:15 UTC
Statistics have been online for a few weeks now. It seems to work ok.