Bug 2154 - Users reporting not having permissions to subscribe to wiki pages
: Users reporting not having permissions to subscribe to wiki pages
Status: CLOSED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All Linux
: High normal (vote)
: ---
Assigned To: unassigned
: midgard@maemo.org
: https://maemo.org/community/wiki/bugs...
:
:
:
  Show dependency tree
 
Reported: 2007-10-23 08:22 UTC by Quim Gil
Modified: 2007-12-04 12:59 UTC (History)
0 users (show)

See Also:


Attachments
clicking to subscribe to this page. (161.38 KB, image/png)
2007-10-24 01:19 UTC, Rainer Dorsch
Details
midguard login screen (235.29 KB, image/png)
2007-10-24 01:20 UTC, Rainer Dorsch
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Quim Gil (reporter) nokia 2007-10-23 08:22:21 UTC
EXPECTED OUTCOME:

A registered user should be able to subscribe to one/many/all wiki pages.

ACTUAL OUTCOME:

According to a couple of reports received recently, they can't. Instead, they
get a message telling them not to have enough permissions.
Comment 1 Rainer Dorsch 2007-10-24 01:19:29 UTC
Created an attachment (id=578) [details]
clicking to subscribe to this page.
Comment 2 Rainer Dorsch 2007-10-24 01:20:27 UTC
Created an attachment (id=579) [details]
midguard login screen
Comment 3 Rainer Dorsch 2007-10-24 01:22:11 UTC
I see expactly the described behavior. I added two screenshot which illustrate
it. I use Debian 4.0 (etch) and I see the problem no matter if I use iceweasel
or konqueror.
Comment 4 Scott Kelso 2007-10-24 06:13:25 UTC
I see the same symptoms when trying to log-in to
http://maemo.org/profile/edit/, using Internet Explorer, after entering my
correct user ID and password.  It churns for a while, and drops me to the
Midgard login failed screen with "Your user account does not have sufficient
privileges.  Access denied: You need the privilege midgard:update."
Comment 5 Quim Gil (reporter) nokia 2007-10-24 08:09:20 UTC
Scott, can it be that you are experiencing some king of Bug 2146 ?
Comment 6 Scott Kelso 2007-10-24 16:41:16 UTC
Resolved:  Maemo.org allowed me to log-in and update my profile this morning. 
Root cause probably was a bug 2146-type cron script failure.  But it's not an
exact match; I tested and failed ~6 hrs. after getting the Garage account, and
my user ID is all lower-case.
Comment 7 Quim Gil (reporter) nokia 2007-10-25 07:38:05 UTC
Rainer, can you check whether the issue is solved for you as well? Thanks.
Comment 8 eero.afheurlin 2007-11-05 16:47:17 UTC
bug 2146 has in fact nothing to do with cron but with pam_pgsql which has
issues with long passwords, but if you can log in to the https side in general
then that is not the issue.
Comment 9 Aleksandr Koltsoff 2007-11-27 13:34:26 UTC
Added URL that people can test with.
Comment 10 Jake Kunnari 2007-12-04 12:59:35 UTC
Closing FIXED bugs. if error/problem still occurs, please reopen bug with
comments.