Bug 2150 - (int-76488/int-120388) PDF Reader doesn't support internal document hyperlinks
(int-76488/int-120388)
: PDF Reader doesn't support internal document hyperlinks
Status: RESOLVED FIXED
Product: Utilities
PDF reader
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal with 17 votes (vote)
: Harmattan
Assigned To: unassigned
: pdf-reader-bugs
: http://download.oracle.com/docs/cd/B2...
: community-diablo, patch
:
:
  Show dependency tree
 
Reported: 2007-10-22 05:51 UTC by Jason Carter
Modified: 2010-08-20 18:55 UTC (History)
7 users (show)

See Also:


Attachments
the patch has performed the function of internal document hyperlinks (20.31 KB, patch)
2008-08-26 10:27 UTC, xujun
Details
the patch has performed the function of internal document hyperlinks (10.67 KB, patch)
2008-08-28 08:32 UTC, xujun
Details
the patch can support internal document hyperlinks (7.27 KB, patch)
2008-09-01 04:45 UTC, xujun
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Jason Carter (reporter) 2007-10-22 05:51:12 UTC
EXPECTED OUTCOME: Clicking on a hyperlink pointing to another portion of the
same PDF document does not do anything.

ACTUAL OUTCOME: Clicking on a hyperlink should move the user to the linked
portion of the document.

STEPS TO REPRODUCE THE PROBLEM:
1) Use the N800 to go to the address linked in the URL for this bug. It should
open the PDF reader.
2) Scroll down to page 3 of the PDF document.
3) Attempt to click on any blue underlined link shown.

OTHER COMMENTS:
This was a complaint found on the Internet Tablet Talk forums. Apparently this
problem exists on both IT2007 and IT2008.

For what it's worth, KPDF 3.5.7 running on Linux does not show *any* underlined
links.

If this bug will not be fixed, then the links should just be rendered as
regular text instead so as not to give the user the expectation that they will
work as they do in the web browser.
Comment 1 Jason Carter (reporter) 2007-10-22 06:01:55 UTC
My mistake, slight miscommunication.

The N800 does not render the table of contents as links, just as plain text,
just as it does in KPDF.
Comment 2 Jason Carter (reporter) 2007-10-22 17:52:15 UTC
It appears that Adobe Acrobat Reader on Windows does allow you to click on any
listing in the table of contents to skip to that portion of the PDF. The links
are  not shown as hyperlinks but work anyways.
Comment 3 N800 User 2007-10-23 00:30:45 UTC
CLARIFICATION/CORRECTIONS :
--------------------------

EXPECTED OUTCOME: Clicking on a hyperlink in a PDF document should move the
user to the linked portion of the document

ACTUAL OUTCOME: Clicking on a hyperlink pointing to another portion of the
same PDF document does not do anything.

STEPS TO REPRODUCE THE PROBLEM:
-------------------------------
1) Use the N800 to go to the PDF addresses/URL's in the examples listed below.
It should open the PDF reader.
2) Scroll down to the pages of the PDF document listed in the examples below
that have the links (blue text).
3) Attempt to click on any link (shown as blue text in PDF file) does not do
anything while the same PDF opened in Adobe Reader on a Windows PC moves the
user to the linked portion of the document.

EXAMPLES:
--------
1) Links on pages 3 to 7 of this PDF:
http://download.oracle.com/docs/cd/E10530_01/doc/epm.931/hsys9_install_start_here.pdf

2) Links on pages 3 to 4 of this PDF:
http://download.oracle.com/docs/cd/E10530_01/doc/epm.931/esb_sqlint.pdf

3) Links on Page 13 of this PDF:
http://download.oracle.com/docs/cd/B28928_01/doc/server.103/b28924.pdf
Comment 4 Jake Kunnari 2007-11-20 15:07:39 UTC
Bug forwarded.
Comment 5 xujun 2008-08-26 10:27:44 UTC
Created an attachment (id=907) [details]
the patch has performed the function of internal document hyperlinks

download the latest osso-pdf-viewer from the maemo repositories, and patch for
it. then, the function of internal document hyperlink will start work.
Comment 6 Eero Tamminen nokia 2008-08-26 11:03:30 UTC
(In reply to comment #5)
> Created an attachment (id=907) [details] [details]
> the patch has performed the function of internal document hyperlinks
> 
> download the latest osso-pdf-viewer from the maemo repositories, and patch for
> it. then, the function of internal document hyperlink will start work.

Thanks!

Could you add there information about:
- where the code comes (is it yours or from upstream, under what license etc)
?

(and maybe cleanup the patch a bit:
- not modify config* files unnecessarily(?)
- not remove somebody's copyright
- short explanation on what it does)
Comment 7 xujun 2008-08-28 08:32:53 UTC
Created an attachment (id=911) [details]
the patch has performed the function of internal document hyperlinks

this is another patch for the bug,it make the hyperlink work in simpler codes
than last patch. you can try it.
Comment 8 Andre Klapper maemo.org 2008-08-29 00:10:01 UTC
xujun:
Where does the code come from (is it yours? Under what license etc)?
How exactly did you create the patch? There is still lots of noise in it, like
all the "Only in osso-pdf-viewer-1.6/src" lines.
The functions do not have comments explaining what they do. There is also
commented *code* that is not used at all.
Also there are useless lines like
    /////////////////////////////////////////////////////

Please clean up the patch and submit it here again.
And again: Do not remove somebody's copyright!

Thanks.
Comment 9 xujun 2008-09-01 04:45:15 UTC
Created an attachment (id=916) [details]
the patch can support internal document hyperlinks

I had added another patch again that only makes the internal document hyperlink
work in N810 basing on xpdf source code. all of you can use it if you want to
bulit the package with supporting hyperlinks. 
By the way, I am sorry to modify the COPYRIGHT file in last patchs,but i don't
mean to ,just because i am not no familiar terms with how to create a patch.
Comment 10 Andre Klapper maemo.org 2008-11-17 00:09:27 UTC
>+    //extern void doAction(LinkAction *action);

Please remove this line.

>-//========================================================================
>-//
>-// PDFDoc.cc
>-//
>-// Copyright 1996-2003 Glyph & Cog, LLC
>-//
>-//========================================================================

You still remove the copyright here. Don't do that. :)


Can you please state from which exact file(s) in which exact version/tarball
(URL, please) from xpdf your changes were taken/adapted?
Comment 11 Andre Klapper maemo.org 2008-11-17 01:19:08 UTC
Also note that the 3rd party port of Evince provides this functionality:
http://maemo.org/downloads/product/OS2008/evince/
Comment 12 Javier Jardón 2009-03-30 19:22:20 UTC
Still valid in 4.1.3 (5.2008.43-7) maemo release
Comment 13 Andre Klapper maemo.org 2009-06-24 12:51:57 UTC
This will NOT be fixed for Fremantle but is considered for Harmattan.
Comment 14 Quim Gil nokia 2009-09-14 07:56:26 UTC
Bug moved to Harmattan program
Comment 15 Lucas Maneos 2009-10-22 07:56:35 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 16 Rigoberto Calleja 2010-03-31 15:37:24 UTC
Still present on maemo 5 version 3.2010.02-8
Comment 17 Andre Klapper maemo.org 2010-03-31 15:53:04 UTC
(In reply to comment #16)
> Still present on maemo 5 version 3.2010.02-8

See comment 14. There are no plans to fix this for Maemo5 currently, but for
Maemo6.
Comment 18 Andre Klapper maemo.org 2010-08-20 18:55:31 UTC
According to Nokia this will be fixed in Harmattan (the version after Maemo5).
WONTFIX for Maemo5 though.