Bug 2102 - SD cards formatted in the N800 show differences between boot sector and backup
: SD cards formatted in the N800 show differences between boot sector and backup
Status: RESOLVED WORKSFORME
Product: System software
File system
: 3.2
: N800 Linux
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: file-system-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-10-12 20:45 UTC by Jerome
Modified: 2009-04-09 17:41 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jerome (reporter) 2007-10-12 20:45:49 UTC
EXPECTED OUTCOME: fsck.vfat should show no error

ACTUAL OUTCOME: fsck.vat gives the error "there are differences between boot
sector and its backup"

STEPS TO REPRODUCE THE PROBLEM:
this is using os2007 version 4.2007.38-2 on the N800

1: format a card on the N800 (using the menu in "file manager")
2 run fsck.vfat on the card (/sbin/fsck.vfat /dev/mmcblk0p1 or mmcblk1p1)

OTHER COMMENTS:

you can only run fsck as root.
Comment 1 Eero Tamminen nokia 2007-10-15 13:08:40 UTC
Does "dmesg" report any errors when you do fsck?

If not, could you test also following (can take several minutes):
  dd if=/dev/mmcblk0p1 of=/dev/null

And check whether "dmesg" reports any errors in reading all the card contents?
Comment 2 Jerome (reporter) 2007-10-15 14:47:18 UTC
Sorry, but I won't try that. First, I fixed the problem on the cards, so I
could not do the test without reformatting the card (which would be rather
inconvenient). Second, I understand that you are trying to find out whether the
N800 has problems accessing certain areas of the card. It does not. I can fix
the problem in the N800 (simply by running fsck.vfat and answer "yes" to the
messages), and then the problem is indeed fixed, meaning the N800 could access
that particular area of the card to write a correct boot sector.


Last but not least: I forgot one piece of information. I got the problem
formatting big cards: one 4 GB SD (not SDHC) card and one 8 GB SDHC card, both
from Transcend. Maybe the bug only appears if the card is big enough.
Comment 3 Eero Tamminen nokia 2007-10-15 15:51:32 UTC
(In reply to comment #2)
> Sorry, but I won't try that. First, I fixed the problem on the cards, so I
> could not do the test without reformatting the card (which would be rather
> inconvenient).

fsck can be run without modifying the MMC contents, and the dd command
also only reads the MMC card, it doesn't write it.


> Second, I understand that you are trying to find out whether the
> N800 has problems accessing certain areas of the card. It does not. I can fix
> the problem in the N800 (simply by running fsck.vfat and answer "yes" to the
> messages), and then the problem is indeed fixed, meaning the N800 could access
> that particular area of the card to write a correct boot sector.

Thanks, this is indeed interesting; why format would have this issue,
if fsck can fix it?


> Last but not least: I forgot one piece of information. I got the problem
> formatting big cards: one 4 GB SD (not SDHC) card and one 8 GB SDHC card, both
> from Transcend. Maybe the bug only appears if the card is big enough.

Good point, thanks!
Comment 4 Kimmo Hämäläinen nokia 2007-10-16 09:20:47 UTC
What is the exact message dosfsck gives? I've seen that message after using
mlabel to change the volume label, but it seems harmless in that case.
Comment 5 Jerome (reporter) 2007-10-16 09:53:56 UTC
Can't you simply reproduce the bug at Nokia's? I am sure that you have plenty
of SD cards lying around with no essential data on them, while I would have to
go into the trouble of backing up one of my SD cards, formatting it, testing,
fix the problem again and then copy all of my data back.
Comment 6 Andre Klapper maemo.org 2008-07-18 17:14:09 UTC
Setting to moreinfo until we get more information from the reporter.
Jerome, sometimes it's not that easy to reproduce issues.
Comment 7 Andre Klapper maemo.org 2008-07-18 17:14:38 UTC
...and is this still an issue on Diablo?
Comment 8 Jerome (reporter) 2008-07-19 12:07:06 UTC
I just tried on a N800 running diablo, the bug is still there. I can't
understand why you can't reproduce the issue, the procedure is straightforward
and the error does not appear to be machine-specific (I have 4 N800 lying
around...).

I could be that the error only happens for SD cards which are big enough,
though. Originally, I tried on a 8GB SDHC and 4GB SD card. This time, I tried
with a 16GB SDHC card (because that was what I had lying around). I got a full
page of checked cluster numbers in addition to the error message that the boot
sector and its backup were different.
Comment 9 Andre Klapper maemo.org 2008-08-04 16:50:22 UTC
(In reply to comment #8)
> I can't understand why you can't reproduce the issue

If only all bugs were easy to reproduce...

What are the exact manufacturer/models of the three cards you tried?
Comment 10 Jerome (reporter) 2008-08-04 19:37:41 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > I can't understand why you can't reproduce the issue
> 
> If only all bugs were easy to reproduce...
> 
> What are the exact manufacturer/models of the three cards you tried?
> 

The first two (8GB and 4GB) are from Transcend, the second one (16GB) bears the
brand "Ram components class 6 SDHC card".
Comment 11 Andre Klapper maemo.org 2008-08-04 20:30:03 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > What are the exact manufacturer/models of the three cards you tried?
> 
> The first two (8GB and 4GB) are from Transcend

no modell name?

> the second one (16GB) bears the brand "Ram components class 6 SDHC card". 

sounds like some no-name card that always love to any break specs...
Comment 12 Jerome (reporter) 2008-08-05 00:30:46 UTC
(In reply to comment #11)
> sounds like some no-name card that always love to any break specs...
> 

I feel quite some contempt for no-brand cards in your last comment.

All right, I checked on my N810. I get the same error message "there are
differences between boot
sector and its backup" on both my Sandisk 8GB micro-SDHC card (uses a micro to
mini adapter) and on the built-in "memory card". I recall that I also formatted
those cards using the menu in "file manager" in my N810.

Now: why is it that you can't reproduce the issue? What did you try exactly,
and on which card?
Comment 13 Andre Klapper maemo.org 2009-04-09 17:41:55 UTC
Closing this bug report as the issue could not be reproduced and no further
information has been provided:

> What is the exact message dosfsck gives? I've seen that message after using
> mlabel to change the volume label, but it seems harmless in that case.

Please feel free to reopen this bug if you can provide the information asked
for/if you can still reproduce this. Thanks!