Bug 2076 - Adding file directories (i.e. Documents, MMC) to Task Launcher/Navigator
: Adding file directories (i.e. Documents, MMC) to Task Launcher/Navigator
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0-beta
: N800 Linux
: Medium enhancement (vote)
: Harmattan
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-05 15:54 UTC by Tim Samoff
Modified: 2012-03-24 11:40 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2007-10-05 15:54:03 UTC
EXPECTED OUTCOME: Create a way for users to add file directories (i.e.,
Documents, MMC, etc.) to Task Launcher/Navigator. (Btw, has the name changed
recently?)

ACTUAL OUTCOME: Task Launcher currently holds navigable directory structure for
applications only.

STEPS TO REPRODUCE THE PROBLEM: This is core functionality.

OTHER COMMENTS: It would be nice to be able to access user-specified
directories/files from the Task Launcher without having to launch the File
Manager.
Comment 1 Johan Bilien nokia 2007-12-19 09:21:11 UTC
Re-assigning to UI specifications
Comment 2 Roope Rainisto nokia 2008-11-27 10:11:35 UTC
I was going to set wontfix - since this will not come to Fremantle, and in
general we do not want to rely on File Manager as a good UI for the user access
his files, it should happen through the applications - then again, Harmattan
has interesting plans on content management, so setting for Harmattan.
Comment 3 Andre Klapper maemo.org 2012-03-21 18:06:54 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia, hence resetting the ASSIGNED
status to NEW/UNCONFIRMED as nobody is working on this.

Note that very likely any feature requests for Maemo5 will not receive fixes
(WONTFIX) - I might mass-set this status in the future. There is a very small
chance for issues in open source components that contributed patches could be
included in the Maemo 5 CSSU Community updates - see http://wiki.maemo.org/CSSU
for more information.


For completeness (as Harmattan is mentioned in some reports), MeeGo 1.2
Harmattan used for the N9 and N950 is handled in
http://harmattan-bugs.nokia.com/ which has recently been closed for new bug
report entry [1].

[1]
http://www.developer.nokia.com/Community/Blogs/blog/n9-developer/2012/03/08/harmattan-bugzilla-closed-for-new-bugs
Comment 4 Andre Klapper maemo.org 2012-03-24 11:40:32 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )