Bug 2063 - microb-browser and others uninstallable from extras; deb in pool but not in Packages
: microb-browser and others uninstallable from extras; deb in pool but not in P...
Status: CLOSED FIXED
Product: maemo.org Website
Repositories
: unspecified
: N800 Maemo
: Medium major with 2 votes (vote)
: ---
Assigned To: Ferenc Szekely
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-03 06:34 UTC by Scott Dubreuil
Modified: 2007-12-04 12:59 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Scott Dubreuil (reporter) 2007-10-03 06:34:30 UTC
EXPECTED OUTCOME: microb successfully installs

ACTUAL OUTCOME: microb fails to install

STEPS TO REPRODUCE THE PROBLEM: After intsalling the required catalogue it
errors with the following: 

Unable to download.
Application package not found.

A search for installable applications in App Manager displays only microb-eal.
When I check the problems tab for microb-eal it states that the missing
packages are browser-eal, libgtkmozembed and microb-|10n
OTHER COMMENTS:
Comment 1 tuukka.tolvanen nokia 2007-10-03 12:50:27 UTC
these could be useful:
 * application manager log showing the failure: menu -> Tools -> Log -> Save
 * your /etc/apt/sources.list
Comment 2 Jason Carter 2007-10-03 14:26:26 UTC
Works for me.
Comment 3 Scott Dubreuil (reporter) 2007-10-03 19:19:22 UTC
I'll check sources list and logs but if you check here I am not the only one
experiencing this problem.

http://www.internettablettalk.com/forums/showthread.php?t=10193
Comment 4 Scott Dubreuil (reporter) 2007-10-03 20:30:08 UTC
There's also this post in response to others having problems installing other
apps.
Comment 5 Scott Dubreuil (reporter) 2007-10-03 21:53:08 UTC
The App manager log contains nothing.  I have now reflashed again and still the
same outcome.  The sources.list contains:

Nokia Catalogue
essential
http://catalogue.tableteer.nokia.com/certified/  bora user

Nokia Catalogue (3rd party software)
http://catalogue.tableteer.nokia.com/non-certified/  bora user

Maemo
http://repository.maemo.org/  bora free non-free extras

Hack
http://maemo-hackers.org/apt/ bora main

bora-extras
http://repository.maemo.org/extras   bora free non-free

I realize there is a redundancy here for maemo extras but I have tried this
with and without it already present and also with just the base repositories. 
same thing every time when I follow the instructions from the web page for
Mozilla browser for Maemo.
Comment 6 Scott Dubreuil (reporter) 2007-10-03 22:03:29 UTC
Now I have found errors in the logs from App Manager:

osso-application-installer 4.46, UI version 2
W: GPG error: http://catalogue.tableteer.nokia.com bora Release: The following
signatures were invalid: BADSIG CBFC2BECC6903E72 Nokia Internet Tablet Archive
Automatic Signing Key <integration@maemo.org>
W: GPG error: http://maemo-hackers.org bora Release: The following signatures
couldn't be verified because the public key is not available: NO_PUBKEY
5FD45CD3EA68E29D
Comment 7 Daniel Martin Yerga 2007-10-03 23:26:52 UTC
Please, could you try it deleting *extras* in:
"Maemo
http://repository.maemo.org/  bora free non-free extras" ?
Comment 8 Scott Dubreuil (reporter) 2007-10-03 23:31:04 UTC
Already tried deleting extras and also tried with just the 2 default Nokia
Catalogues immediately after flashing (note, flashed twice with same results). 
I'm not clear on how the extras correlates to the errors about signature keys?
Comment 9 Stephen Moehle 2007-10-03 23:40:52 UTC
I am having the same problem, but the problem seems to be that the
microb-browser package simply does not exist.

http://repository.maemo.org/extras/dists/3.2/install/microb-browser.install
(from Maemo downloads) contains:

[install]
repo_name = bora-extras
repo_deb_3  = deb http://repository.maemo.org/extras bora free non-free
package   = microb-browser

But http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages
does not contain any package called microb-browser.

Strangely enough, binary-i386/Packages does contain the microb-browser package.
microb-browser is an "all" architecture package, and what is even stranger is
that binary-i386/Packages contains all the "all" architecture packages whereas
binary-armel/Packages contains not a single one.

I am not a Debian user so please forgive my confusion.
Comment 10 Scott Dubreuil (reporter) 2007-10-04 00:00:21 UTC
Bug 2067 seems related
Comment 11 Scott Dubreuil (reporter) 2007-10-04 00:17:51 UTC
(In reply to comment #10)
> Bug 2067 seems related
> 

Interestingly in the other bug the user had flashed with 4.2007.26-8 so this
seems to probably not be an issue with the latest firmware.
Comment 12 Steve Greenland 2007-10-04 01:17:06 UTC
This problem has nothing to do with either firmware version, nor the key issues
in other repositories. The problem, as comment #9 pointed out, is that the
Packages file for arm is missing all the "Architecture: all" packages.
Regenerating the packages file to include them will fix this problem, and many
other installation problems, all with the same symptom. Yes, I do have long
experience with Debian packaging.

Since I'm new here, I won't try to mess with the summary or who this bug is
assigned to. I hope someone who knows the right thing to do will do it.
Comment 13 Ferenc Szekely maemo.org 2007-10-04 14:23:51 UTC
My 2 cents:

http://repository.maemo.org/microb/dists/bora/free/binary-armel/Packages does
contain the microb-browser package. It actually contains all 4 versions that
have been released so far. The debs are in the pool, everything looks OK from
repo management's point of view.

Would help me if you sent the list your browser will display when you click
here:
http://repository.maemo.org/microb/dists/bora/free/binary-armel/

I am interested in the files size of Packages. The URL above points to a
caching network. It could be that somewhere on the globe one or more caches are
not updated/refreshed properly. Here in Helsinki, Finland I see the following:

Name                                      Last modified       Size  Description
-------------------------------------------------------------------------------
Parent Directory                          06.08.2007 13:38       -
Packages.bz2                              13.08.2007 12:18    5744
Packages                                  13.08.2007 12:18   41821
Packages.gz                               13.08.2007 12:18    5467
Release                                   13.08.2007 12:18     106

So looking forward receiving these lists.
Comment 14 tuukka.tolvanen nokia 2007-10-04 15:14:52 UTC
> http://repository.maemo.org/microb/dists/bora/free/binary-armel/Packages does
> contain the microb-browser package. It actually contains all 4 versions that

rmo/microb? Never heard of that repo, nor do any .installs that I know of point
there. I see that microb-browser packages are present in both

http://repository.maemo.org/microb/pool/bora/free/m/microb-browser/
http://repository.maemo.org/microb/dists/bora/free/binary-armel/Packages

but as far as I know that's not where anyone at large gets their
microb-browser. Some sort of staging repo? The repo that the .installs
available from maemo.org/downloads and browser.garage.maemo.org for
microb-browser point to is rmo/extras, and the following urls appear to
disagree about its contents:

http://repository.maemo.org/extras/pool/bora/free/m/microb-browser/
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages

> caching network. It could be that somewhere on the globe one or more caches are

Don't think that's the issue here. Also note differences between
python2.5-runtime versions listed at

http://repository.maemo.org/extras/pool/bora/free/p/python-runtime/
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages
http://repository.maemo.org/extras/dists/bora/free/binary-i386/Packages

arch:all packages are listed in binary-i386/Packages but not in
binary-armel/Packages.
Comment 15 Ferenc Szekely maemo.org 2007-10-04 16:02:59 UTC
Yeah, they uploaded the package to extras too and the package is not in that
Packages file..

It seems the bora extras repo got corrupted and our repo manager tool can not
rebuild the Packages file. The same goes for gregal extras... 

I need more time to investigate this. Pls be patient.
Comment 16 luca 2007-10-04 16:10:12 UTC
Re. comment #13, Packages now has microb-browser, but only because someone
restored the file with date 13.08.2007. Before it was 03.10.2007.
Comment 17 luca 2007-10-04 16:11:43 UTC
Oh, sorry, disregard my comment, I didn't notice it didn't point to maemo
extras.
Comment 18 Steve Greenland 2007-10-04 19:42:56 UTC
Just for the record, as of Thu Oct  4 16:37:17 UTC 2007, the file my browser
(and the n800 apt-get) retrieves from
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages does
not reference microb-browser. This is the repo pointed to by the one-click
install at browser.garage.maemo.org. The result of 'host repository.maemo.org'
is:

~$ host repository.maemo.org
repository.maemo.org    CNAME   repository.maemo.org.edgesuite.net
repository.maemo.org.edgesuite.net      CNAME   a515.g.akamai.net
a515.g.akamai.net       A       204.52.135.215
a515.g.akamai.net       A       204.52.135.213

The index of http://repository.maemo.org/extras/dists/bora/free/binary-armel/
shows:

Parent Directory                           12.01.2007 00:53       -
Packages.bz2                               03.10.2007 07:00   49864
Packages                                   03.10.2007 07:00  249856
Packages.gz                                03.10.2007 07:00   45174
Release                                    04.10.2007 12:56     106
Comment 19 Quim Gil nokia 2007-10-04 23:00:28 UTC
Increasing severity since we are getting more complaints through different
channels that seem to refer to the same issue pointed here.
Comment 20 Quim Gil nokia 2007-10-04 23:19:22 UTC
https://bugs.maemo.org/show_bug.cgi?id=2067 seems to be related.
Comment 21 Steve Greenland 2007-10-04 23:33:23 UTC
Bug 2067 is related, in that both 2063 and 2067 are conflating two completely
different problems.

One is the incorrect Packages file oni r.m.o/extras/which is missing the
Architecture: all .debs. Thus, no microb-browser package, thus the single-click
install fails, as do several others (e.g. kagu, openssh).

The other problem is that the GPG signatures on the Release file at two
completely different repos are borked. Either the signing key was updated
without distributing it first, or the signature is just broken. It possible
that the key was updated in the new firmware, which means people who haven't
updated yet are seeing this problem. I *think* it's possible to sign with
multiple keys, so that both the old and new work together, but you'd need to
ask the appropriate Debian people how they make this work.
Comment 22 tuukka.tolvanen nokia 2007-10-05 01:03:59 UTC
> One is the incorrect Packages file oni r.m.o/extras/which is missing the
> Architecture: all .debs. Thus, no microb-browser package, thus the single-click
> install fails, as do several others (e.g. kagu, openssh).

fwiw looks like it's not only arch:all that's missing, see
openssh-client/server packages here:

http://repository.maemo.org/extras/pool/bora/free/o/openssh/
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages

> The other problem is that the GPG signatures on the Release file at two
> completely different repos are borked. Either the signing key was updated

Indeed per http://www.gossamer-threads.com/lists/maemo/users/28400#28400 not
fatal so let's pursue that elsewhere
Comment 23 John Rudd 2007-10-05 06:40:40 UTC
Yeah, I'm fine with separating the GPG issue (well, on my bug, 2067, anyway). 
I only mentioned it in ticket 2067 because it was the only symptom I could find
being reported in Ap Manager.  So I assumed it was related to the problem (and,
if the GPG error was causing the download to fail, then that would in fact
explain the problem on the client side; but if the problem isn't on the client
side, then the larger and more important issue is: that we can't install
packages from certain repos right now).
Comment 24 Martin Draexler 2007-10-05 11:31:35 UTC
Why does it take so long to fix the package-list for an apt repository??? Due
to the recent firmware-upgrade I started reinstalling my apps, but most of them
depend on packages in maemo-extras! To my mind the bug is getting more and more
severe every hour it is not fixed, because my N800 is UNUSABLE!

Isn't it possible to create a temporary repository that works?
Comment 25 Ferenc Szekely maemo.org 2007-10-05 11:46:02 UTC
Some mysql and sqlite packages caused a segfault in 'apt-ftparchive generate'
that is used to regenerate the repo index. The packages were removed from pool
and the index has been regenerated. microb-browser is in the 
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages

I will create a page explaining details on apt-ftparchive and the packages that
made it to dump core. 

Pls test the installation of microb. Thanks.
Comment 26 tuukka.tolvanen nokia 2007-10-05 13:10:21 UTC
At least microb-browser and openssh are found in app manager and install fine
for me now from bora extras.
Comment 27 Steve Greenland 2007-10-05 18:22:13 UTC
I too was able to install microb-browser and kagu this morning. Thanks for
fixing this quickly, Ferenc. I would definitely be interested in knowing what
caused dpkg-ftparchive to segfault; I suspect the Debian dpkg developers would
as well.
Comment 28 John Rudd 2007-10-05 19:20:38 UTC
Yeah, openssh client (bug 2067) installs fine now.

Thanks :-)
Comment 29 luca 2007-10-06 23:09:16 UTC
FYI microb-browser is missing again from 
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages
dated 6.10.2007 10:00
Comment 30 Cairn 2007-10-07 01:43:42 UTC
I am currently unable to install MicroB after upgrading to most recent firmware
this morning and restoring backup. Clicking on "install" arrow at maemo.org
gives me error "Unable to download. Application package not found." Bug does
not appear to be resolved.
Comment 31 luca 2007-10-08 19:55:12 UTC
The repository is still broken. Could somebody reopen the bug or (preferably)
fix the repository?
Comment 32 Cairn 2007-10-08 20:46:36 UTC
(In reply to comment #31)
> The repository is still broken. Could somebody reopen the bug or (preferably)
> fix the repository?
> 

The repository seemed to be working as of yesterday and the tool here:

https://garage.maemo.org/docman/view.php/106/295/inst.html

shows that the package is working. Try this:

1. Open xterm (you may need to install it if you haven't already)
2. type "sudo apt-get update" (without the quotes). This will ask for your root
password. If you have never created a root password, just hit enter.
3. now try to install MicroB using this link:

http://repository.maemo.org/extras/dists/3.2/install/microb-browser.install

Does that work for you?
Comment 33 luca 2007-10-08 22:04:28 UTC
Maybe yesterday it was fine, but today is broken. I don't need to install
microb (thankfully I managed to install it during the short window when the
repository was fixed, if I needed to install it now it wouldn't work because
microb-browser isn't currently in the Packages file, so apt-get would't find
it) but I'd like to install python (which doesn't work for the same reason:
various packages are missing from the Packages file).
Comment 34 luca 2007-10-08 22:17:10 UTC
ok, now I see my "fault": now it seems python is in another repository, since
the install file from the link you provided worked. I assumed it was in maemo
extras.
Comment 35 luca 2007-10-08 22:33:51 UTC
well, I checked and it's actually in maemo extras. I dont' understand why
apt-get (after an update) couldn't find it before and neither could I (by
looking at the Packages files) and now it works with no change in the date of
the Packages file. I suppose I shouldn't check these things from the tablet
itself but with a real keyboard. Sorry for all the noise.
Comment 36 Quim Gil nokia 2007-10-09 08:11:57 UTC
fyi I just could install the Mozilla based browser without any problem, going
to http://maemo.org/downloads/product/microb-browser and clicking the big green
arrow.
Comment 37 Jake Kunnari 2007-12-04 12:59:27 UTC
Closing FIXED bugs. if error/problem still occurs, please reopen bug with
comments.