Bug 2036 - (int-87027) MicroB engine goes in loop on Oracle page
(int-87027)
: MicroB engine goes in loop on Oracle page
Status: RESOLVED FIXED
Product: Browser
MicroB engine
: 4.1 (4.2008.23-14)
: N800 Linux
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: microb-bugs
: http://download.oracle.com/docs/cd/E1...
:
:
:
  Show dependency tree
 
Reported: 2007-09-21 04:52 UTC by N800 User
Modified: 2009-06-08 13:50 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description N800 User (reporter) 2007-09-21 04:52:08 UTC
I downloaded the MicroB engine from downloads and installed it without any
problems on my Nokia N800 with latest firmware update. It works good on some
sites but Opera works better on other sites. For example, if you go to Wall
Street Journal website, MicroB browser handles it poorly and loses the
Touch-scrolling completely. You have to use scollbar on the Wall Street journal
website: http://online.wsj.com/home/us

Also, here is another example of site that works fine when using Opera engine
but goes in a loop when using the MicroB browser:
http://download.oracle.com/docs/cd/E...ef/techref.htm
Comment 1 N800 User (reporter) 2007-09-21 05:04:21 UTC
Sorry, one of the URL's was incorrect. Here is the correct URL that makes
MicroB engine on Nokia N800 go in the loop:
http://download.oracle.com/docs/cd/E10530_01/doc/epm.931/html_esb_techref/techref.htm

(In reply to comment #0)
> I downloaded the MicroB engine from downloads and installed it without any
> problems on my Nokia N800 with latest firmware update. It works good on some
> sites but Opera works better on other sites. For example, if you go to Wall
> Street Journal website, MicroB browser handles it poorly and loses the
> Touch-scrolling completely. You have to use scollbar on the Wall Street journal
> website: http://online.wsj.com/home/us
> Also, here is another example of site that works fine when using Opera engine
> but goes in a loop when using the MicroB browser:
> http://download.oracle.com/docs/cd/E...ef/techref.htm
Comment 2 Andre Klapper maemo.org 2008-07-18 16:41:42 UTC
I can confirm that
http://download.oracle.com/docs/cd/E10530_01/doc/epm.931/html_esb_techref/techref.htm
endlessly loops on Diablo, N810.



Could not reproduce the second issue: I went to http://online.wsj.com/home/us
(was redirected because I'm not a subscriber) and I could scroll by using my
fingers on the touchscreen.
Comment 3 Eero Tamminen nokia 2008-08-06 10:54:51 UTC
(In reply to comment #2)
> I can confirm that
> http://download.oracle.com/docs/cd/E10530_01/doc/epm.931/html_esb_techref/techref.htm
> endlessly loops on Diablo, N810.

There's an easy workaround for viewing these pages, just disable
JavaScript from the Browser Settings dialog.

Even with JavaScript the page re-loading can be stopped by pressing
the toolbar "X" button when the page is *re-connecting*, but that leaves
the page blank and for some reason it doesn't stop the reloads if done
while the page is loading or loaded.


> Could not reproduce the second issue: I went to http://online.wsj.com/home/us
> (was redirected because I'm not a subscriber) and I could scroll by using my
> fingers on the touchscreen.

That's probably because of the browser optimizations done for Diablo.
And note that the bug wasn't reported for 4.1, but year ago
(i.e. before Chinook).
Comment 4 Andre Klapper maemo.org 2009-06-08 13:44:05 UTC
This issue cannot be reproduced and hence has been FIXED in the internal
Fremantle browser version.

Unfortunately this is a WONTFIX for Diablo as Diablo is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.
Comment 5 Andre Klapper maemo.org 2009-06-08 13:50:26 UTC
The page in general seems to have issues - Fennec 1.0 beta 1 on my Desktop
computer also does not render it correctly, hence I have filed
https://bugzilla.mozilla.org/show_bug.cgi?id=496874 .