Bug 2 - Static linking under SDK-PC does not work
: Static linking under SDK-PC does not work
Status: CLOSED FIXED
Product: Development platform
general
: unspecified
: All Linux
: Medium normal (vote)
: ---
Assigned To: Ferenc Szekely
: dev-platform-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2005-04-28 15:26 UTC by Alexey Pchelintsev
Modified: 2008-12-06 13:29 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alexey Pchelintsev (reporter) 2005-04-28 15:26:07 UTC
Static linking under SDK-PC does not work.

The compiler shows the following errors:
-----
host-gcc: /usr/lib/libhildonwidgets.a: No such file or directory
host-gcc: /usr/lib/libhildonfm.a: No such file or directory
host-gcc: /usr/lib/libossothumbnail.a: No such file or directory
-----
Comment 1 Eero Tamminen nokia 2005-05-25 18:11:26 UTC
This is not very well explained under the Scratchbox documentation, but
host-gcc
is intended only for compiling binaries for the host environtment (which go
under /host_usr/ and /scratchbox/ directory structures inside the Scratchbox
chroot sandbox).

You need a x86 target toolchain to build x86 target binaries.


IMHO this bug should be moved under documentation.

It would also be clearer if the host-toolchain would be something that user
needs to install separately instead of coming with Scratchbox as it's mostly of
interest only to Scratchbox developers.  The download page could then also
explain that it's needed for compiling the Scratchbox host environment tools.
I.e. it's needed only when user wants to optimize the builds by making a host
version of some new tool needed in the building (nowadays there aren't that
many
of those, for example the doctools package includes even LaTeX :)).
Comment 2 Janne Kataja 2005-09-01 13:14:15 UTC
It is a documentation issue, not a bug.
Comment 3 Maemo QA (deprecated) 2006-05-29 13:46:58 UTC
Closing bug.