Bug 1925 - mplayerplug-in compiles, but does not work
: mplayerplug-in compiles, but does not work
Status: RESOLVED WORKSFORME
Product: Browser
MicroB engine
: 3.2
: All Maemo
: High enhancement (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-08-28 20:51 UTC by Tim Steiner
Modified: 2008-12-25 15:55 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Steiner (reporter) 2007-08-28 20:51:56 UTC
EXPECTED OUTCOME:
once installed, mplayerplug-in shows up in the list of installed plugins, and
functions normally

ACTUAL OUTCOME:
once installed, mplayerplug-in does not show up in the list of installed
plugins

STEPS TO REPRODUCE THE PROBLEM:
I have been able to compile mplayerplug-in 3.45 against the microb engine
libraries using the following steps:

./configure --prefix=/usr/local/mplayerplug-in/3.45
/usr/lib/microb-engine/xpidl -I /usr/share/idl/microb-engine -m header
Source/nsIScriptableMplayerPlugin.idl
/usr/lib/microb-engine/xpidl -I /usr/share/idl/microb-engine -m typelib
Source/nsIScriptableMplayerPlugin.idl
mv nsIScriptableMplayerPlugin.h Source/
mv nsIScriptableMplayerPlugin.xpt Source/
make
scp mplayerplug-in*.so mplayerplug-in*.xpt root@****:/usr/lib/browser/plugins/

in addition to adding the line:
#include "nsIProgrammingLanguage.h"
to Source/nsScriptablePeer.h at line 48.

However, when I copy the .so files to /usr/lib/browser/plugins/ on my n800, the
plugin does not appear in my browser's list of plugins.

OTHER COMMENTS:
I have been able to compile the basic unix plugin from the mozilla SDK and have
it show up in the list, so getting mplayerplug-in working seems possible. 
Unfortunately, I don't have much experience debugging browser plugins and I am
at a loss.
Comment 1 Tim Steiner (reporter) 2007-08-28 21:03:52 UTC
I forgot to mention that I also made copies of all of the microb-engine*.pc
files as mozilla*.pc and changed their "Requires:" lines in the same manner.
Comment 2 Andre Klapper maemo.org 2008-10-09 17:57:09 UTC
Hi Tim,
is this still an issue in Diablo (which exact version)? Which exact hardware is
this (N800, N810)?
Comment 3 Quim Gil nokia 2008-12-25 14:39:45 UTC
Tim, a lot has happened since you filed this report. Is this still an issue?