Bug 192 - wireless connections fail almost immedially with spi/softmac errors
: wireless connections fail almost immedially with spi/softmac errors
Status: CLOSED FIXED
Product: Connectivity
WiFi
: 1.0
: All Maemo
: High critical (vote)
: 1.1
Assigned To: Jorma Virkkunen
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2005-11-01 10:17 UTC by Jochen Eisinger
Modified: 2009-05-30 19:32 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jochen Eisinger (reporter) 2005-11-01 10:17:57 UTC
When connecting to my wlan, the connection almost immedially goes down. This
didn't happen to me with 2005.40, and it worked long enough with 2005.42 to
install about 20mb of software.

In dmesg I have the following entries:

Loading 3825.arm firmware
CX3110x: MAC address xx:xx:xx:xx:xx:xx
No power saving
Scan complete, scanned 13 channels
No power saving
Scan complete, scanned 13 channels
No power saving
Scan complete, scanned 13 channels
No power saving
Scan complete, scanned 13 channels
No power saving
Scan complete, scanned 13 channels
No power saving
No power saving
We wake up for DTIMs
We haven't received an SPI packet for 2 seconds...
We haven't received an SPI packet for 2 seconds...
We haven't received an SPI packet for 2 seconds...
We haven't received an SPI packet for 2 seconds...
We haven't received an SPI packet for 2 seconds...
SPI timer timeout, getting out of here
DEAUTHENTICATE trap
DEAUTHENTICATE trap
Shut down SoftMAC
SoftMAC not initialized, chip not booted (Set oid 0x12000001)
SoftMAC not initialized, chip not booted (Set oid 0x12000002)
SoftMAC not initialized, chip not booted (Set oid 0x150007e0)
SoftMAC not initialized, chip not booted (Set oid 0x12000000)
SoftMAC not initialized, chip not booted (Set oid 0x12000001)
SoftMAC not initialized, chip not booted (Set oid 0x12000002)
We wake up for DTIMs
SoftMAC not initialized, chip not booted (Set oid 0x14000000)
SoftMAC not initialized, chip not booted (Set oid 0x12000001)
SoftMAC not initialized, chip not booted (Set oid 0x12000002)
SoftMAC not initialized, chip not booted (Set oid 0x150007e0)
Loading 3825.arm firmware
CX3110x: MAC address xx:xx:xx:xx:xx:xx
Comment 1 Victor Toni 2005-11-04 01:58:08 UTC
Confirmed.
Could connect only once with 2005.42 then the connection somehow got interrupted
and I couldn't connect again.
After flashing back to 2005.40 it works like a charm.
Comment 2 Roberto Resoli 2005-11-06 11:54:53 UTC
Tried with no encryption, working
Tried with WEP 40 bit, working
Tried with WPA, TKIP, failing
Tried with wpa, AES, failing.
Comment 3 Jochen Eisinger (reporter) 2005-11-06 11:58:23 UTC
I'm connecting to an Cabletron 802.11b access point with WEP 128 and the AP
doesn't broadcast the ESSID.
Comment 4 Jochen Eisinger (reporter) 2005-11-06 12:29:17 UTC
i'm changing this to a blocker... nokia is hardly going to sale a wireless
product without working wifi :)
Comment 5 Noèl Köthe 2005-11-10 00:10:14 UTC
dont know if it helps, but I can also confirm this with
Nokia_770_0.2005.42-9.bin
I'm trying to use WPA with Preshared Key.
Comment 6 Jorma Virkkunen nokia 2005-11-10 11:43:58 UTC
Thank you for the report. Yes, there is some trouble with WPA authentication.
We
are working on it. The suggested Priority/Severity accepted.
Comment 7 Samuel Ortiz nokia 2005-11-10 11:58:15 UTC
(In reply to comment #0)
> When connecting to my wlan, the connection almost immedially goes down. This
> didn't happen to me with 2005.40, and it worked long enough with 2005.42 to
> install about 20mb of software.
How many APs do you see when you scan ?
Comment 8 Jochen Eisinger (reporter) 2005-11-10 12:07:15 UTC
Depending on the time of day between 2 and 6 APs, all shown with a closed lock
symnol, and only one belongs to my WLAN. I'm not sure whether there are all on
distinct channels. I just started kismet to monitor that a little... more infos
when I return home later today.
Comment 9 Samuel Ortiz nokia 2005-11-10 13:45:15 UTC
(In reply to comment #8)
> Depending on the time of day between 2 and 6 APs, all shown with a closed lock
> symnol, and only one belongs to my WLAN. I'm not sure whether there are all on
> distinct channels. I just started kismet to monitor that a little... more infos
> when I return home later today.
And does it work with WEP or open authentication ?
Comment 10 orsoni 2005-11-10 15:30:04 UTC
same problem, same dmesg, both wpa-psk tkip and aes.
AP is an usrobotics 9106 (wireless gateway), maemo 2005.42
i'll try wep this evening
Comment 11 orsoni 2005-11-10 15:37:21 UTC
Let me add that there are no other APs shown, and that i could never connect.
Sometimes the [W] icon keeps flashing forever until i click "disconnect". I
couldn't find 2005.40 to give it a try.
Comment 12 Jochen Eisinger (reporter) 2005-11-10 21:04:49 UTC
(In reply to comment #7)
> How many APs do you see when you scan ?
there are 6 WLANs (inkl. mine), all WEP protected. two of those (incl. mine)
dont' broadcast the essid
Comment 13 orsoni 2005-11-11 10:00:47 UTC
http://www.internettablettalk.com/forums/showthread.php?t=345&page=2&pp=10
Adding a bogus AP did the trick for me, even though it disconnects pretty often.
Comment 14 Urho Konttori 2005-11-14 12:02:37 UTC
Trouble connecting to DI-614+ router. I have problems connecting to my home
router , D-link 614+ (2 antenna version) using WEP 128, wep 64 or open. 770
seems to be trying to connect to it constantly with processor in 100%. It seems
to make arout 40 connections per second and naturally isn't able to connect to
the router.
Comment 15 Jorma Virkkunen nokia 2005-11-21 10:54:31 UTC
There will be a new release available within few days. It has a working WiFi.
Comment 16 Samuel Ortiz nokia 2005-12-05 13:07:45 UTC
(In reply to comment #15)
> There will be a new release available within few days. It has a working WiFi.
I would like to know if some of you guys could test this new release, and check
if it fixes stuff or not.
Please let me know.
Comment 17 Jerome 2005-12-10 19:27:59 UTC
I have the same problem on firmware "2.2005.45-8", I left more comments at the
following address:
http://www.internettablettalk.com/forums/showthread.php?p=3898#post3898

What do I do?
Comment 18 Jochen Eisinger (reporter) 2005-12-10 19:34:43 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > There will be a new release available within few days. It has a working WiFi.
> I would like to know if some of you guys could test this new release, and check
> if it fixes stuff or not.
> Please let me know.
> 
> 
The new release fixes my (original) problem. Thanks.

If there are remaining problems, maybe a new bug should be opened..

regards
-- jochen
Comment 19 Samuel Ortiz nokia 2005-12-10 21:12:45 UTC
(In reply to comment #18)

 
> The new release fixes my (original) problem. Thanks.
No problem.
 
> If there are remaining problems, maybe a new bug should be opened..
Right. If you encounter other problems, please open a new bug.

Cheers,
Samuel.
Comment 20 Samuel Ortiz nokia 2005-12-10 21:14:07 UTC
(In reply to comment #17)
> I have the same problem on firmware "2.2005.45-8"
It is not the same problem. Please update bug #329 as it looks like you have the
same problem.
Comment 21 Maemo QA (deprecated) 2006-05-29 15:36:09 UTC
Fix seems to have been verified, closing bug.
Comment 22 Andre Klapper maemo.org 2009-05-30 19:32:29 UTC
Please ignore.
(Fixing obsolete milestones to pass Bugzilla database sanity check)