Bug 1897 - Mouse support (Bluetooth and USB support)
: Mouse support (Bluetooth and USB support)
Status: RESOLVED FIXED
Product: Core
X Server
: unspecified
: All Maemo
: Low enhancement with 10 votes (vote)
: 5.0-beta
Assigned To: unassigned
: x-server-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-08-23 15:37 UTC by bob
Modified: 2010-05-21 11:25 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description bob (reporter) 2007-08-23 15:37:19 UTC
This is more of an enhancement than a bug.

SOFTWARE CHANGES:
(changes to the given release version: different kernel, additional
packages...)
Mostly the X server, probably requires enabling a kernel driver or two.  Should
probably create a configuration applet for enabling disabling external mouse.

Why do this?  This enables usage of the platform in a laptop replacement
setting.  Corporate users who are doing lots of email while travelling, or
someone on vacation doing some web work will able to switch to "desk mode" with
a mouse and folding keyboard (and ideally something to prop hold the Tablet up
closer to eye level.)
Comment 1 bob (reporter) 2007-09-11 17:26:39 UTC
Using the 770 and the just released Hacker Edition 2007, I'm getting closer.  I
make the mouse visible by tweaking the Transparent setting...

After hooking up the self-powered hub and who ha, I can see the mouse is
recognized and working in the kernel via

    cat < /dev/input/event3

and moving the mouse generates lots of characters.

So, now I would like the Xomap server to use it as input....  currently the
Xomap server does something like this (in /etc/init.d/x-server)

    $ Xomap -mouse tslib ...

I was hoping that

    $ Xomap -mouse /dev/input/event3 ...

would bring me joy... alas no joy.

Does anyone have any ideas about how to cause the Xomap server to use the usb
mouse and not the touch screen?   Or how to configure "tslib" to use both the
touch screen and the real mouse (say via a /etc/ts.config module perhaps?)
Comment 2 bob (reporter) 2007-09-12 04:20:17 UTC
I forgot to mention, someone did have luck getting a bluetooth mouse working
with Maemo.  They patched the kernel and the Xserver.  I was hoping with 2007
HE to skip some of that...

Here's the URL to the bt mouse experiment,

   http://thelemming.org.uk/maemo/btmice/maemo_mouse_readme.txt
Comment 3 Daniel Stone nokia 2007-11-15 01:37:14 UTC
Using ITOS2008, you should be able to pass -mouse ps2,/dev/input/eventN. 
There's no great technical reason why hotplug doesn't work, only lack of time
to finish it properly.
Comment 4 Dave Blank 2008-01-05 19:44:44 UTC
I've tried to get a PS2/USB mouse working last night in OS2008 by passing the
option "-mouse ps2,/dev/input/event4" to Xomap, and while I can "cat
/dev/input/event4" and see that the mouse is generating data, it still does not
work in X.

I also tried using evdev instead of ps2, and both report "Couldn't find pointer
driver (evdev or ps2)", tslib is the only one that doesn't report an error.

Are there really any pointer drivers other than tslib available for the stock X
server?

I'd like to avoid compiling Xomap, if possible.

If I *do* end up having to compile Xomap, is there a way to find out what
--configure flags were used in the stock server?

Thanks
Comment 5 Dave Blank 2008-01-05 22:29:49 UTC
Disregard my last line about configure flags, I grabbed the
xorg-server-1.3.99.0~git20070321 source, which conveniently came with
debian/rules :)

I still can't figure out how to load anything other than tslib, unfortunately.

Any help is greatly appreciated.
Comment 6 Daniel Stone nokia 2008-06-13 00:22:09 UTC
At the moment, there's no way to do it without recompiling KDrive, but this
will definitely be fixed in Fremantle, but that will probably just come from
using Xorg rather than KDrive ...
Comment 7 Andre Klapper maemo.org 2008-06-17 18:48:45 UTC
"Next" milestone is confusing and misleading, removing.
Comment 8 Andre Klapper maemo.org 2008-11-17 16:50:20 UTC
(In reply to comment #0)
> This is more of an enhancement than a bug.

Indeed - changing severity.
Comment 9 Quim Gil nokia 2008-12-09 11:13:46 UTC
(In reply to comment #6)
> At the moment, there's no way to do it without recompiling KDrive, but this
> will definitely be fixed in Fremantle, but that will probably just come from
> using Xorg rather than KDrive ...

The Fremantle pre-alpha sources are out and they include the updated Xorg.
Anybody willing to check what is the status of this feature now?
Comment 10 Andre Klapper maemo.org 2008-12-09 18:36:53 UTC
(In reply to comment #9)
> The Fremantle pre-alpha sources are out and they include the updated Xorg.
> Anybody willing to check what is the status of this feature now? 

Bob, Dave?
Comment 11 bob (reporter) 2008-12-09 18:41:38 UTC
Ha! My 770 won't power on anymore.   I'm not sure what happened. but I've tried
and tried and it is toast...  I'm currently looking into the G1 phone.  It
appeals to me as a java developer.  And I like that it combines the phone (one
less thing to carry.)   Although I miss the 770's nice big screen.
Comment 12 Quim Gil nokia 2008-12-11 08:11:21 UTC
Removing 770 from the header. 

Also, it seems that Daniel is the default assignee for X server but he is not
working at Nokia anymore...
Comment 13 Andre Klapper maemo.org 2008-12-15 15:26:05 UTC
(In reply to comment #12)
> Also, it seems that Daniel is the default assignee for X server but he is not
> working at Nokia anymore...

Not anymore: https://bugs.maemo.org/describecomponents.cgi?product=Core
Reassigned the two remaining bugs.
Comment 14 Quim Gil nokia 2008-12-18 17:22:06 UTC
I asked Daniel and he said:

> It's already fixed in Fremantle, and should just work out of the box.

Resolving as FIXED, then.
Comment 15 Andre Klapper maemo.org 2009-04-28 15:35:16 UTC
Setting Target Milestone to Fremantle SDK beta.
Comment 16 Alan Bruce maemo.org 2009-11-27 00:36:02 UTC
What needs to be done to make this work in Maemo 5 / N900? Enable HID support,
pair the BT mouse, then... how does one make the pointer visible? If you go
into "mouse mode" in the browser, you can see the pointer move correctly, but
the pointer is invisible everywhere else.
Comment 17 Frederik Niedernolte 2009-12-18 09:59:31 UTC
It looks like it doesn't work in Fremantle:
http://talk.maemo.org/showpost.php?p=431766&postcount=22
I will try it out ASAP. Would be nice if it would work because then you could
use the N900 (together with a Bluetooth keyboard) like a real computer.
Comment 18 Andre Klapper maemo.org 2009-12-18 18:09:13 UTC
Also see http://wiki.maemo.org/Fremantle_Unsupported_Bluetooth_profiles
Comment 19 Frederik Niedernolte 2009-12-19 02:15:45 UTC
Yeah, we know and input is enabled. Maybe you should read the whole thread on
http://talk.maemo.org/showthread.php?p=431766
Currently there are four different reports from users. Some of them can pair
their mouse but then they are unable to use the mouse because it isn't working
properly: "Hi! after tweaking my n900 bluetooth config file i got my logitech
bluetooth mouse to pair succesfully and connected, but it really does not work.
i tried with Q3A and cursor moves but it just goes fast from side to side. so
maybe little more tweaking it could be possible to actually use it?" for
example.
Comment 20 teemui 2010-02-01 13:36:23 UTC
(In reply to comment #14)
> I asked Daniel and he said:
> 
> > It's already fixed in Fremantle, and should just work out of the box.
> 
> Resolving as FIXED, then.
> 

I dont understand why "FIXED", after PR1.1 firmware update cant connect to bt
mouse at all. It pairs, but thats all it does. This bug should be reopened!
Comment 21 Pelau Vadim 2010-02-06 15:13:05 UTC
(In reply to comment #14)
> I asked Daniel and he said:
> 
> > It's already fixed in Fremantle, and should just work out of the box.
> 
> Resolving as FIXED, then.
> 

So how exactly is this fixed? I understand that there's no usb support
[period].
But why there's no mouse support I don't get it...
Even symbian has it and N900 is supposed to be something of a small PC.

I kindly ask you to rename this bug to bluetooth mouse support and reopen it.
Comment 22 Uwe Koch 2010-02-22 11:04:54 UTC
I just bought a new bt mouse and can confirm that even after a successfully
coupling of my mouse with Pr 1.1.1 the pairing doesn't work.

Could you please reopen this bug?

Best regards,
Uwe
Comment 23 Andre Klapper maemo.org 2010-02-22 11:55:27 UTC
(In reply to comment #22)
> I just bought a new bt mouse and can confirm that even after a successfully
> coupling of my mouse with Pr 1.1.1 the pairing doesn't work.
> 
> Could you please reopen this bug?

Please provide exact information first (hardware, firmware etc) plus exact
steps to reproduce.
Comment 24 teemui 2010-02-22 12:09:09 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > I just bought a new bt mouse and can confirm that even after a successfully
> > coupling of my mouse with Pr 1.1.1 the pairing doesn't work.
> > 
> > Could you please reopen this bug?
> 
> Please provide exact information first (hardware, firmware etc) plus exact
> steps to reproduce.
> 

Same problem here with the newest firmware 3.2010.02-8, and my logitecht bt
mouse. I can pair the mouse but no connection, allways get error connecting to
device.
Comment 25 Pelau Vadim 2010-02-22 19:05:38 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > I just bought a new bt mouse and can confirm that even after a successfully
> > coupling of my mouse with Pr 1.1.1 the pairing doesn't work.
> > 
> > Could you please reopen this bug?
> 
> Please provide exact information first (hardware, firmware etc) plus exact
> steps to reproduce.
> 

The mouse Is called Logitech V470:
http://www.logitech.com/index.cfm/notebook_products/mice/devices/3287&cl=us,en#section=specs

Connecting in PR 1.1 worked randomly but actual usage in games like open arena
was not possible(tested with HID enabled via some bluetooth config file can't
remember exactly).
Comment 26 Pelau Vadim 2010-03-03 22:30:24 UTC
So for now N900 is a computer that doesn't support USB, can't we even have
blueto0th peripheral support now???

So much of a computer this is...
Comment 27 Andre Klapper maemo.org 2010-03-03 23:44:12 UTC
So it seems that Bluetooth mice do not work, or also BT keyboards?

I'd like to keep that separate from this (already vague) original request for
both BT and USB support. Anybody willing to file a new bug report and add their
comments there, with exact steps to reproduce (click by click), and linking to
it from here? Thanks in advance!
Comment 28 Pelau Vadim 2010-03-04 00:19:43 UTC
Some details:

I enabled mu logitech V470 via:
http://wiki.maemo.org/Fremantle_Unsupported_Bluetooth_profiles#HID_host_.28i.e._support_for_Bluetooth_keyboards.29

The mouse can be paired with code "0000".

Results are the following:
Open Arena "Tilt scroll right aka forward" acts as mouse 1 but it only gets one
click out of two.
Leafpad doesn't read any inputs as letters or characters.
MGutenberg allows scrolling, the trick is to first scroll up or else it will
quit unexpectedly.
EmelFM2, Contacts app, Modest one/a few lines and quits randomly.
Music player, calendar perfect scrolling!
Browser, horizontal only (any movement defaults to the top of the screen) and
really quick, and clicks (any) will move the cursor in the last used direction
(either left or right).
Scrolling on the desktop acts as a tap and the "configure desktop icon" and the
mouse appears to be right on top since the icon appears when moving the mouse
right + scroll; while moving left (over the menu, clock etc part of the screen)
nothing happens. However I haven't managed to click any items.
Pressing the screen and moving the mouse allows you to switch desktops but it's
limited by the place where your finger presses.

So far the buttons don't seem to work under any circumstance, the movement
function seems to be horizontal only while the scroll appears to work in
certain "lists".

Overall behavior is completely inconstant and makes the mouse unusable.
Comment 29 Pelau Vadim 2010-03-04 00:28:50 UTC
I have created a new, more speciffic thread over here:

https://bugs.maemo.org/show_bug.cgi?id=9389
Comment 30 Mohammad Abu-Garbeyyeh 2010-05-21 11:25:30 UTC
This doesn't seem to be fixed in Fremantle, mouse sensitivity is very high that
moving the mouse less than 10mm moves it across the screen.
Apparently this seems to be the case with both BT and USB mice.