Bug 1815 - Anonymous users don't see favs
: Anonymous users don't see favs
Status: CLOSED FIXED
Product: maemo.org Website
News
: unspecified
: All Linux
: High normal (vote)
: ---
Assigned To: Oskari Kokko
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-08-14 18:36 UTC by Quim Gil
Modified: 2007-12-04 12:59 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Quim Gil (reporter) nokia 2007-08-14 18:36:46 UTC
Anonymous users don't see favs. Only logging in you see the whole stuff.
Comment 1 Quim Gil (reporter) nokia 2007-08-23 13:31:49 UTC
(this comment had been placen in another bug, my mistake)

Setting to P1. I think this functionality is crucial, since otherwise regular
users don't see the fave hearts and they don't notice their own role in the
maemo social news.

After the first boom of favoriting we are seeing how this is decreasing. That
was expected but we can get to almost zero if users don't see those little
hearts.
Comment 2 Henri Bergius 2007-08-24 12:35:01 UTC
Assigning to myself. Should've been dealt with by
http://trac.midgard-project.org/changeset/11611 but needs more investigation.
Comment 3 Henri Bergius 2007-08-29 15:00:34 UTC
Fixed, now fav icon points to https also for anon users.
Comment 4 Quim Gil (reporter) nokia 2007-08-30 08:05:30 UTC
Cool, but still a couple of details missing.

1. You click on a heart as anonymous.

2. You get the login window. That's ok for registered users, but we need to
provide something for the potential non-registered users. They might be a
majority, at least in the short term.

3. You go to the favorites step to confirm (I still don't see why this
confirmation but this is another bug/RFE)

4. After ok you are left back to the logged-out screen! You don't see your
heart red and your fav counted.

5. If you click again (because you think something went wrong) the page won't
change at all, nor will give an error message that would tell you what's going
on. The solution of course is to kept users in https once they are logged in.
Comment 5 Quim Gil (reporter) nokia 2007-08-30 08:16:09 UTC
A related issue (I can file a bug apart if you want, but it's just a new case
of the same problem described before):

1. Log in
2. Fav an item.
3. Log off.
4. Fav the same item as anonymous.

EXPECTED: a message telling me that I have already faved that item.

ACTUAL RESULT: nothing happens.

There is a variant:

1. Log in
2. Fav an item.
3. Log off.
4. Clean cookies, sessions, etc or simply pick another browser / computer.
5. As anonymous fav the same item.
6. Fill the login and press ok.

Same expected and actual results.

This might be confusing to users not remembering that they had already
favorited a news story days/weeks ago.
Comment 6 Quim Gil (reporter) nokia 2007-08-30 08:48:32 UTC
Can you also please comment on the possibility of having the Ajax solution
everybody wants to see there? I know it's not written in the requirements, I
want to know how far are we from having this lovely feature in place.

I was even thinking that the work flow could go like this:

1. Anonymous user favs item
2. Heart turns red and counts go +1 instantly, making the user happy. They are
though temporary values, a trick while the user identifies himself.
3. Login/register window appears, telling the user that needs to identify in
order to store values to their favorites.

3a. If user identifies, values are stored and available in her Favorites page.
3b. If user don't, values are deleted after... 1h?

Registered users should only see hearts turning red and +1 counts instantly. No
need to extra Favorites confirmation page. Just fav, fav, fav!
Comment 7 Henri Bergius 2007-08-31 15:08:34 UTC
The AJAX solution is definitely doable, but not within the constraints of the
current project. We have to think of assigning some retainer time or something
else for it a bit later.

Marking bug as LATER to keep it in store.
Comment 8 Quim Gil (reporter) nokia 2007-08-31 22:30:21 UTC
Alright, the AJAX thing for later. But please don't ignore the issues reported
in between.
Comment 9 Henri Bergius 2007-09-03 16:39:00 UTC
The actual issue of anonymous users not seeing favs has been addressed. Other
issues should be reported in their own bugs.
Comment 10 Quim Gil (reporter) nokia 2007-09-04 06:19:57 UTC
Fave process sends you back to anonymous after logging in
https://bugs.maemo.org/show_bug.cgi?id=1969

fav hearts turning red instantly
https://bugs.maemo.org/show_bug.cgi?id=1970
Comment 11 Quim Gil (reporter) nokia 2007-09-24 06:46:34 UTC
Regression: the hearts in the right column 'latest' are not visible to
anonymous users anymore. They are visible in the highlights, though.

See: http://maemo.org/news/
Comment 12 Henri Bergius 2007-09-25 09:44:36 UTC
*** Bug 1994 has been marked as a duplicate of this bug. ***
Comment 13 Quim Gil (reporter) nokia 2007-09-25 11:55:59 UTC
Ok, but not exactly a duplicate. Let's just not forget that apart from the
right column, announcements like
http://maemo.org/news/announcements/view/1190039774.html also should have a
heart/bury.

And the news in the home, but I assume this will be discussed when we define
the home.
Comment 14 Quim Gil (reporter) nokia 2007-10-11 08:07:31 UTC
Regression: now you can't see the fav/bury icons in the right column even if
you are logged in.

It would be good to see why this regression has happened once again and make
sure it doesn't happen a third time.
Comment 15 Quim Gil (reporter) nokia 2007-10-14 17:41:35 UTC
Please fix this regression asap. Thanks!
Comment 16 Henri Bergius 2007-10-15 10:46:02 UTC
The regression came from the Favourites folder getting hidden from navigation,
meaning that all elements where the location of that folder is not "hardcoded"
are unable to find it, and so don't display favs.

We are fixing this today.
Comment 17 Oskari Kokko 2007-10-15 11:40:31 UTC
Fixed, sidebar has favorites now
Comment 18 Jake Kunnari 2007-12-04 12:59:16 UTC
Closing FIXED bugs. if error/problem still occurs, please reopen bug with
comments.