Bug 1801 - tapping browser rss icon should list ATOM feed, not just RSS
: tapping browser rss icon should list ATOM feed, not just RSS
Status: RESOLVED FIXED
Product: Browser
MicroB engine
: 5.0-beta
: All Maemo
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: microb-bugs
: data:text/html,<head><link rel%3D"alt...
:
:
:
  Show dependency tree
 
Reported: 2007-08-13 11:20 UTC by timeless
Modified: 2010-03-15 20:51 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2007-08-13 11:20:43 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5)
Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9a6pre)
Gecko/20070810 Firefox/3.0a1 Tablet browser 0.1.16 RX-34_2007SE_4.2007.26-8

RSS button in toolbar ignores ATOM feeds

Reproducible: Always

Steps to Reproduce:
1. open browser
1' look for the toolbar at the bottom of the screen (if it isn't present, use
app menu>view>show toolbar>normal screen/full screen - depending on whether app
menu>view>full screen is checked)
2. load about:
2' verify it says microb (if it doesn't use app menu>set engine>microb, and
restart the browser)
3. load http://browser.garage.maemo.org/news/news.html
3' note the rss icon in the toolbar
4. tap the rss toolbar button

Actual Results:  
the RSS Feed Reader application launches with
http://browser.garage.maemo.org/news/index.rss

Expected Results:  
a popup menu should appear containing an item labeled ATOM and an item labeled
RSS

This is the only site where I've seen this bug, I knowingly posted the news
article about the browser with the corresponding browser (intending to analyze
it today and file this bug).

However, I think it basically means that any site advertising:
<link rel="alternate" type="application/atom+xml" title="ATOM" .../> will be
ignored by the browser.
Comment 1 tuukka.tolvanen nokia 2007-08-29 16:11:05 UTC
> This is the only site where I've seen this bug, I knowingly posted the news

> However, I think it basically means that any site advertising:
> <link rel="alternate" type="application/atom+xml" title="ATOM" .../> will be
> ignored by the browser.

fwiw http://planet.maemo.org/ now has a sane atom feed (bug 1845) which it
advertises as <link rel="alternate"  type="application/atom+xml"  title="ATOM
feed"  href="http://maemo.org/news/planet-maemo/atom.xml" /> and is ignored by
microb-browser 0.0.8-3, unlike the three application/rss+xml alternates, so
there's another testcase
Comment 2 Andre Klapper maemo.org 2009-02-04 16:13:44 UTC
> Expected Results: A popup menu should appear containing an item labeled ATOM 
> and an item labeled RSS
> This is the only site where I've seen this bug,

Any URL that offers both RSS and Atom && MicroB offering the popup menu? I've
tried a few but I only get RSS or RDF files offered.
Comment 3 Andre Klapper maemo.org 2009-06-05 02:40:06 UTC
...moreinfo as per last question. Need a testcase.
Comment 4 tuukka.tolvanen nokia 2009-06-12 01:43:07 UTC
data:text/html,<head><link rel%3D"alternate" type%3D"application%2Frss%2Bxml"
title%3D"RSS 2.0 feed"
href%3D"http%3A%2F%2Fmaemo.org%2Fnews%2Fplanet-maemo%2Frss.xml">%0D%0A<link
rel%3D"alternate" type%3D"application%2Frss%2Bxml" title%3D"Another RSS 2.0
feed"
href%3D"http%3A%2F%2Fmaemo.org%2Fnews%2Fplanet-maemo%2Frss.xml%3Fpoop">%0D%0A<link
rel%3D"alternate" type%3D"application%2Fatom%2Bxml" title%3D"ATOM feed"
href%3D"http%3A%2F%2Fmaemo.org%2Fnews%2Fplanet-maemo%2Fatom.xml">%0D%0A<link
rel%3D"alternate" type%3D"application%2Fatom%2Bxml" title%3D"Another ATOM feed"
href%3D"http%3A%2F%2Fmaemo.org%2Fnews%2Fplanet-maemo%2Fatom.xml%3Fpoop"></head>
Comment 5 Andre Klapper maemo.org 2009-06-19 17:03:35 UTC
Thanks for the testcase!

I can still reproduce this in Diablo 4.1.3 and current Fremantle.
Comment 6 Andre Klapper maemo.org 2009-06-19 17:58:21 UTC
Are ATOM feeds supported *at all*?

Going for example to http://assessment.cetis.ac.uk/members/scott/blogview I
don't get the ATOM feed offered.
Anybody having a working example?
Comment 7 Andre Klapper maemo.org 2009-07-02 17:07:59 UTC
(In reply to comment #6)
> Are ATOM feeds supported *at all*?

--> moreinfo
Comment 8 pepitoe 2010-01-19 23:22:12 UTC
Just came accross this when adding feeds on my N900 (running 2.2009.51-1).  At
www.theregister.co.uk there is only a valid atom feed offered
(http://www.theregister.co.uk/headlines.atom) which is not detected by the
browser.  I also tried phpbb.com which only has a <link> tag for their atom
feed and again is not detected.  So it seems the browser is missing all atom
feeds for some reason.  Since the RSS Reader supports Atom it would make sense
for the browser to also.
Comment 9 tuukka.tolvanen nokia 2010-01-20 02:15:40 UTC
theregister.co.uk [+] [subscribe] works in the current future browser, and the
feed reader appears to be happy with the feed too. the testcase in the url
field here shows two rss and two atom feeds. not quite sure when that happened
though :)
Comment 10 Andre Klapper maemo.org 2010-03-15 20:51:05 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).