Bug 1744 - (int-77923) Provide dialpad button during call
(int-77923)
: Provide dialpad button during call
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
VoIP
: 4.1 (4.2008.23-14)
: All Maemo
: Low enhancement with 4 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: rtcomm@maemo.org
: internet-call-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-08-02 00:56 UTC by Ryan Pavlik
Modified: 2008-11-27 10:59 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Pavlik (reporter) 2007-08-02 00:56:05 UTC
When no call is in progress, a dialpad button is available to provide DMTF
dialing.  However, once a call is in progress, the button is no longer
available.  To access DMTF dialing, one must go into the menu and bring up the
dialpad.

I use the GrandCentral service, which, among other things, can ring my N800
over SIP.  It immediately provides a numerical menu that requires the dialpad,
and so when answering such a call, I must quickly navigate the menus to load
the dialpad and make an entry before the menu times out, which is difficult. 
Adding a button similar to that placed on the screen with no call in progress
to bring up the dialpad would make this and other use cases much easier. 
Thanks for your consideration and this trial component - it seems to work
great!
Comment 1 Andre Klapper maemo.org 2008-06-04 12:00:01 UTC
The internal ticket has been closed as WONTFIX - as far as I can see this is
not planned for Diablo or Fremantle.
Comment 2 Mikhail Zabaluev nokia 2008-06-04 12:29:41 UTC
(In reply to comment #1)
> The internal ticket has been closed as WONTFIX - as far as I can see this is
> not planned for Diablo or Fremantle.

No word on Fremantle yet, but the UI may become more usable.
Meanwhile, on N810, you can use a shortcut: Fn+number on the hardware keyboard.
Why is the keyboard not in numeric mode during a call is probably a topic for
another bug.
Comment 3 Mikhail Zabaluev nokia 2008-09-01 17:47:03 UTC
*** Bug 3658 has been marked as a duplicate of this bug. ***
Comment 4 Roope Rainisto nokia 2008-11-27 10:21:46 UTC
Call UI is redesigned, but no direct DTMF button - there are even higher
priority functions that also have no button directly, it's quite a rare action
anyway.
Comment 5 Mikhail Zabaluev nokia 2008-11-27 10:59:12 UTC
(In reply to comment #4)
> Call UI is redesigned, but no direct DTMF button

It will however be one click away instead of two, right?