Bug 169 - (int-33072) Rendering Artifacts in Marbles Game
(int-33072)
: Rendering Artifacts in Marbles Game
Status: RESOLVED WONTFIX
Product: Games
Marbles
: 3.0
: All Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: marbles-bugs
:
: ITOS2007HE-garage
: int-26316
:
  Show dependency tree
 
Reported: 2005-10-29 22:51 UTC by Simon Budig
Modified: 2008-07-17 20:53 UTC (History)
1 user (show)

See Also:


Attachments
savegame for chapter 1 (275 bytes, application/octet-stream)
2007-07-21 22:50 UTC, Simon Budig
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Simon Budig (reporter) 2005-10-29 22:51:48 UTC
There are some rendering artefacts in the Marbles Game.

a) marbles that are sitting on top of blinking "pushing arrows" are flashing
(probably when the animation cycle of the pushing arrow starts again). See e.g.
Chapter 3 Level 3.

b) Boxes that disintegrate have an "exploding particles" animation. The
Animation for some reason does not start when the box disappears, but on the
beginning of the next move. When the move stops, the particles stick on the
screen and don't disappear. See e.g. Chapter 2, Level 8.
Comment 1 Simon Budig (reporter) 2005-10-29 23:29:44 UTC
Oh, the same problem as in (a) happens for marbles stationary on top of
teleporters.

and (c) when a level is finished and the marbles disappear a part of the blue
ring marking the last active marble sticks around a bit...
Comment 2 Jorma Virkkunen nokia 2005-11-01 12:17:44 UTC
Reassigning.
Comment 3 Maemo QA (deprecated) 2006-04-25 12:44:26 UTC
Claiming ownership.
Comment 4 Maemo QA (deprecated) 2006-04-25 12:45:22 UTC
Simon, is this still the case with the latest product image (2006-13)?
Comment 5 Maemo QA (deprecated) 2006-05-18 09:58:15 UTC
Got info from upstream maintainer. These issues have been fixed in Internet
Tablet 2006 Software Edition. Thus marking bug FIXED. Please verify with the
IT2006SE image after it has been publicly released.
Comment 6 Simon Budig (reporter) 2006-06-11 23:52:38 UTC
Problem a) is *not* fixed in the BETA.SU-18_2006SE_0.2006.22-21_PR_F5_MR0_ARM
beta release.

Problem b) is *not* fixed in the BETA.SU-18_2006SE_0.2006.22-21_PR_F5_MR0_ARM
beta release.

Problem c) indeed seems to be fixed.

Reopening this bug.
Comment 7 Simon Budig (reporter) 2006-06-12 00:03:15 UTC
Detailed way to reproduce this:

Select Chapter 3, level 3. Move the leftmost blue marble upwards. Now move the
orange marble near the center down. It moves left and gets stopped on top of the
arrows by the blue marble. Now select any other marble so that the marking ring
is no longer on the orange marble. The orange marble now starts flashing.

Interestingly it is *not* synchronous to the animation loop. you can see
different brightly lit arrow parts when you watch it for a while.
Comment 8 Maemo QA (deprecated) 2006-06-19 19:08:27 UTC
Thanks for verifying. Filed a new bug to upstream maintainer.
Comment 9 Jake Kunnari 2007-03-26 14:59:25 UTC
WONTFIX, no activities for N770 anymore.
Comment 10 Jake Kunnari 2007-03-26 15:00:19 UTC
Closed by Error Manager 26.03.2007
Comment 11 Jussi Kukkonen 2007-03-28 13:04:36 UTC
changing product to n800, reopening. Bug's still there, exactly as described.
Comment 12 Jason Carter 2007-07-18 17:09:37 UTC
I would like to verify if this bug still exists in the latest firmware, however
I am not very good at Marbles, so if anyone has a cheat code or a save game
file they can post here to allow us direct access to the level Simon is
mentioning, it would be *very* helpful.
Comment 13 Simon Budig (reporter) 2007-07-21 03:27:39 UTC
Ok, I don't have my N800 here right now, but you can also reproduce this in
Chapter 1, Level 8:

- move the marble in the bottom row to the right
- move the blue marble in the third row from the bottom to the right and then
down, so that it gets stuck on top of the arrows.
- tap on any other marble to move the blue highlight away from the blue marble.

The marble is stuck on top of the arrows and starts blinking. Eeek.

I can provide a savegame for this level, unfortunately the save game of the
complete solution is lost somewhere.
Comment 14 Simon Budig (reporter) 2007-07-21 22:50:17 UTC
Created an attachment (id=492) [details]
savegame for chapter 1
Comment 16 Andre Klapper maemo.org 2008-06-03 15:30:57 UTC
I really have to spend more time in becoming better in Marbles. :-P

As already written, the internal ticket has been closed as WONTFIX - just not
important enough to fix it, priorities seem to be different. Patches accepted.
Comment 17 Quim Gil nokia 2008-07-17 20:53:54 UTC
Same reason as in Bug 122 - if wontfix then let's be clear and resolve as
wontfix. Keeping open bugs since 2005 doesn't help. Sorry Simon!